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Contacting Telestream
To obtain product information, technical support, or provide comments on this guide, contact us using 
our web site, email, or phone number as listed below.

Copyrights and Trademark Notices
Copyright © 2023 Telestream, LLC and its Affiliates. All rights reserved. No part of this publication may 
be reproduced, transmitted, transcribed, altered, or translated into any languages without written 
permission of Telestream, LLC. Information and specifications in this document are subject to change 
without notice and do not represent a commitment on the part of Telestream. Specifications subject to 
change without notice.

Telestream, Aurora, CaptionMaker, CaptureVU, Cerify, Content Manager, ContentCentral, Cricket, DIVA, 
DIVAdirector, DIVADocs, DIVAGrid, DIVANet, DIVAProtect, DIVASolutions, Episode, Encoding 
Intelligence, Episode, FLEXVU, Flip4Mac, FlipFactory, Flip Player, Geminus, Glim, GraphicsFactory, 
Inspector, IQ & Design, Kumulate, Lightspeed, MassStore, MassTech, MetaFlip, Post Producer, Prism, 
ScreenFlow, Sentry, Singulus, Split-and-Stitch, Stay Genlock, Surveyor, Tempo, TrafficManager, Vantage, 
Vantage Cloud Port, VOD Producer, and Wirecast are registered trademarks of Telestream, LLC and its 
Affiliates and its Affiliates. 

Resource Contact Information

Telestream Technical 
Support

Web Site: http://www.telestream.net/telestream-support/
Support Email: support@telestream.net
Enterprise Telephone Support: 
U. S. Toll Free: (877) 257-6245
U. S. from outside U.S.: (530) 470-2036
Europe | Middle East | Africa | Asia | Pacific:
 +49 228 280 9141
Terms and times of support services vary, per the terms of 
your current service contract with Telestream.

Telestream, LLC Web Site: www.telestream.net
Sales and Marketing Email: info@telestream.net
Telestream, LLC
848 Gold Flat Road, Suite 1
Nevada City, CA USA 95959

International 
Distributor Support

Web Site: www.telestream.net
See the Telestream Web site for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriter@telestream.net
Share comments about this or other Telestream documents.

http://www.telestream.net/telestream-support/vantage/support.htm
mailto:support@telestream.net
http://www.telestream.net
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net
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Argus, ContentAgent, Cricket, e-Captioning, Inspector, iQ, iVMS, iVMS ASM, MacCaption, Pipeline, 
Switch, and Vidchecker are trademarks of Telestream, LLC and its Affiliates. All other trademarks are the 
property of their respective owners. 

Adobe. Adobe® HTTP Dynamic Streaming Copyright © 2014 Adobe Systems. All rights reserved.

Apple. QuickTime, MacOS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour logo, and the 
Bonjour symbol are trademarks of Apple, Inc.

Avid. Portions of this product Copyright 2012 Avid Technology, Inc.

CoreOS. Developers of ETCD.

Dolby. Dolby and the double-D symbol are registered trademarks of Dolby Laboratories Licensing 
Corporation.

Fraunhofer IIS and Thomson Multimedia. MPEG Layer-3 audio coding technology licensed from 
Fraunhofer IIS and Thomson Multimedia.

Google. VP6 and VP8 Copyright Google Inc. 2014 All rights reserved.

MainConcept. MainConcept is a registered trademark of MainConcept LLC and MainConcept AG. 
Copyright 2004 MainConcept Multimedia Technologies.

Manzanita. Manzanita is a registered trademark of Manzanita Systems, Inc.

MCW. HEVC Decoding software licensed from MCW.

MediaInfo. Copyright © 2002-2013 MediaArea.net SARL. All rights reserved. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY 
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL 
THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Microsoft. Microsoft, Windows NT|2000|XP|XP Professional|Server 2003|Server 2008 |Server 
2012|Server 2016|Server 2019|Server 2022, Windows 7, Windows 8, Windows 10, Windows 11, Media 
Player, Media Encoder, .Net, Internet Explorer, SQL Server 2005|2008|2012|2016|2019, and Windows 
Media Technologies are trademarks of Microsoft Corporation.

NLOG, MIT, Apache, Google. NLog open source code used in this product under MIT License and 
Apache License is copyright © 2014-2016 by Google, Inc., © 2016 by Stabzs, © 2015 by Hiro, Sjoerd 
Tieleman, © 2016 by Denis Pushkarev, © 2015 by Dash Industry Forum. All rights reserved.

SharpSSH2. SharpSSH2 Copyright (c) 2008, Ryan Faircloth. All rights reserved. Redistribution and use in 
source and binary forms, with or without modification, are permitted provided that the following 
conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer:
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Redistributions in binary form must reproduce the above copyright notice, this list of conditions and 
the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors may be used to 
endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY 
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL 
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Swagger. Licensed from SmartBear.

Telerik. RadControls for ASP.NET AJAX copyright Telerik All rights reserved.

VoiceAge. This product is manufactured by Telestream under license from VoiceAge Corporation.

x264 LLC. The product is manufactured by Telestream under license from x264 LLC.

Xceed. The Software is Copyright ©1994-2012 Xceed Software Inc., all rights reserved.

ZLIB. Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler.

 

Other brands, product names, and company names are trademarks of their respective holders, and are 
used for identification purpose only.

MPEG Disclaimers

MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT COMPLIES WITH THE 
MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR PACKAGED MEDIA IS EXPRESSLY 
PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE PATENTS IN THE MPEG-2 PATENT PORTFOLIO, 
WHICH LICENSE IS AVAILABLE FROM MPEG LA, LLC, 4600 S. Ulster Street, Suite 400, Denver, Colorado 
80237 U.S.A.
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MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE FOR THE 
PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING VIDEO IN COMPLIANCE 
WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/OR (ii) DECODING MPEG-4 VIDEO THAT 
WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR 
WAS OBTAINED FROM A VIDEO PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER 
USE. ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL AND 
COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE HTTP://
WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL USE OF 
A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE REMUNERATION TO (i) ENCODE VIDEO 
IN COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS 
ENCODED BY A CONSUMER ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A 
VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED 
FOR ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://
WWW.MPEGLA.COM.

MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE FOR 
ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT AN ADDITIONAL 
LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR ENCODING IN CONNECTION WITH (i) DATA 
STORED OR REPLICATED IN PHYSICAL MEDIA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) 
DATA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR 
PERMANENT STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, 
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.

Limited Warranty and Disclaimers
Telestream, LLC (the Company) warrants to the original registered end user that the product will 
perform as stated below for a period of one (1) year from the date of shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment supplied but 
not manufactured by the Company but NOT including any third party equipment that has been 
substituted by the Distributor for such equipment (the “Hardware”), will be free from defects in 
materials and workmanship under normal operating conditions and use.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any defective Hardware 
component or part, or Software Media, with new or like new Hardware components or Software Media. 
Components may not be necessarily the same, but will be of equivalent operation and quality. 
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Software Updates
Except as may be provided in a separate agreement between Telestream and You, if any, Telestream is 
under no obligation to maintain or support the Software and Telestream has no obligation to furnish 
you with any further assistance, technical support, documentation, software, update, upgrades, or 
information of any nature or kind.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or Software Media, 
or any part thereof, is damaged due to abuse, misuse, alteration, neglect, or shipping, or as a result of 
service or modification by a party other than the Company, or (ii) Software is modified without the 
written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER WARRANTIES, 
EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE. No oral or written information or advice given by the Company, 
its distributors, dealers or agents, shall increase the scope of this Limited Warranty or create any new 
warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the country in which 
the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF TELESTREAM, 
LLC WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS LIMITED WARRANTY. Your sole and 
exclusive remedy for any and all breaches of any Limited Warranty by the Company shall be the 
recovery of reasonable damages which, in the aggregate, shall not exceed the total amount of the 
combined license fee and purchase price paid by you for the Product. 

Damages
TELESTREAM, LLC SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, 
LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OR 
INABILITY TO USE THE PRODUCT, OR THE BREACH OF ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF 
THE COMPANY HAS BEEN ADVISED OF THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY 
PROVIDED FAILS OF ITS ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC
848 Gold Flat Road
Nevada City, CA 95959 USA

You can call Telestream during U. S. business hours via telephone at (530) 470-1300.
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Regulatory Compliance
Electromagnetic Emissions: FCC Class A, EN 55022 Class A, EN 61000-3-2/-3-3, CISPR 22 Class A

Electromagnetic Immunity: EN 55024/CISPR 24, (EN 61000-4-2, EN 61000-4-3, EN 61000-4-4, EN 61000-
4-5, EN 61000-4-6, EN 61000-4-8, EN 61000-4-11)

Safety: CSA/EN/IEC/UL 60950-1 Compliant, UL or CSA Listed (USA and Canada), CE Marking (Europe)

California Best Management Practices Regulations for Perchlorate Materials:
This Perchlorate warning applies only to products containing CR (Manganese Dioxide) Lithium coin 
cells. Perchlorate Material-special handling may apply. See www.dtsc.ca.gov/hazardouswaste/
perchlorate.
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Introduction

Telestream ScreenFlow is a Mac-based tool for screen recording and video editing.

Topics
■ Introducing ScreenFlow

■ ScreenFlow Movies

■ ScreenFlow Slide Shows

■ ScreenFlow Trial Mode

Note: To install ScreenFlow, see Installation.

Introducing ScreenFlow
ScreenFlow enables you to compose, edit, and export screencasts. You can create 
software demos, tutorials, application previews, training videos, and business 
presentations. With ScreenFlow and ScreenFlow Helper, you can record your display, 
camera video, and audio simultaneously. The ScreenFlow editing interface lets you 
combine video, still images, voice-overs, text, and music. You can add call-outs and 
transitions. When you’re done. ScreenFlow encodes your video to MPEG-4, and 
publishes it to any of several video-hosting platforms.

ScreenFlow is built on Cocoa, with full support for 64-bit architecture, ColorSync, and 
Retina displays.

Note: ScreenFlow can record the computer screen as well as camera video. 
Throughout this guide, the computer screen is referred to as the display—as in display 
video—in keeping with Apple terminology.
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ScreenFlow Movies
ScreenFlow helps you make movies quickly and easily. Import your clips into the media 
library, and drop them into the timeline. Join and sync clips in a single drop. Then, add 
transitions, voice-overs, and music beds. ScreenFlow includes tools for trimming clips, 
nesting and grouping clips, adding transitions, and adding effects to video and sound.

ScreenFlow Slide Shows
Slide shows have never been easier to make. You can use images in leading formats 
such as PNG, TIFF, and JPEG. Set the duration for each image. Add transitions, text 
overlays, and graphics. Add your own voice-overs and music beds. Then, use 
ScreenFlow to render your slide show for publication or distribution.

ScreenFlow Trial Mode
If you acquired ScreenFlow directly from Telestream, ScreenFlow operates in trial mode 
until you purchase and activate a license. In trial mode, all ScreenFlow features are 
available, but your movies are watermarked when you export or publish them.

If you acquired ScreenFlow from the Mac App Store, ScreenFlow behaves differently. 
The App Store has its own installation and licensing procedure.

To unlock ScreenFlow, go to Unlocking ScreenFlow via Telestream Web Store.
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Installation

You can install, upgrade, and uninstall ScreenFlow, and related subsystems, on any Mac 
meeting the ScreenFlow system requirements.

Topics
■ System Requirements

■ Licenses (Telestream Web Store Only)

■ Installing ScreenFlow via Telestream Web Store

■ Unlocking ScreenFlow via Telestream Web Store

■ Activating Your Telestream Web Store License

■ Installing Telestream Audio

■ Deactivating Your ScreenFlow License

■ Removing ScreenFlow from Your Computer

■ Launching ScreenFlow

Note: Be sure to review the system requirements before installing ScreenFlow.

System Requirements
• Intel-based Mac2 CPU with 64-bit processor (Core i3 or higher); or Apple M1 (or 

higher) CPU.

• Operating Systems

– macOS Monterey 12

– macOS Big Sur 11.3

– macOS Catalina 10.15

• Minimum 4 GB RAM
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• 20 GB hard drive

• Apple macOS-approved graphics card

• Online Help browser requirements: Safari.

Note: ScreenFlow does not support “Hackintosh” systems.
ScreenFlow requires a GPU officially supported by Apple.
ScreenFlow does not support NVIDIA “Web Drivers.”

Licenses (Telestream Web Store Only)
You must license ScreenFlow to fully enable export capabilities. If ScreenFlow is not 
licensed, all exported files are watermarked.

The Licenses tab of the Settings dialog displays your serial number and allows you to 
manage your licenses.

Only administrators can unlock license functions. Guests can’t remove your license.

Note: If you purchased ScreenFlow through the Mac App Store, ScreenFlow doesn’t 
display the Licenses tab. The Mac App Store has its own licensing and updating 
processes.

See Production & Streaming: Renewal & Licensing Questions.

Licensing ScreenFlow
To activate a ScreenFlow license, do the following:

1. Select ScreenFlow > Settings.

2. Select the Licenses tab.

See Licenses Settings Tab.

3. Click Purchase. Select and purchase a ScreenFlow product.

Telestream emails you the serial number for ScreenFlow.

4. Enter the serial number into the Serial Number field, and click Activate.

Deactivating a Serial Number
To deactivate a ScreenFlow license, do the following:

1. Select ScreenFlow > Settings.

2. Select the Licenses tab.

See Licenses Settings Tab.

3. Enter the serial number into the Serial Number field.

4. Click Deactivate.



https://support.telestream.net/s/article/Licensing-Questions
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Removing or Changing the ScreenFlow License

Note: Don’t use this method if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

To remove or change the ScreenFlow license, do the following:

1. Click the lock at the bottom of the window.

2. Make the changes desired.

3. When done, click the lock again.

Updating ScreenFlow
You can check for updates to ScreenFlow by selecting ScreenFlow > Check for Updates. 
When ScreenFlow displays the Software Update screen, click Install Update.

Installing ScreenFlow via Telestream Web Store
Note: Use this method only if you purchased ScreenFlow directly from the Telestream 
Web Store. If you purchased ScreenFlow from the Mac App Store, refer to the Mac App 
Store installation and upgrade instructions.

Note: You must be logged in as an administrator in order to continue.

ScreenFlow is available from Telestream as a DMG installer file, as well as from the Mac 
Apps Store. This topic is for users who have downloaded ScreenFlow from the 
Telestream Web site.

To install ScreenFlow, do the following:

1. To download and launch the ScreenFlow installer, do one of the following:

– Using the Safari browser, download or open the ScreenFlow DMG installer file.

MacOS automatically mounts the disk image and runs the installer.

– Using a browser other than Safari, download the ScreenFlow DMG installer file. 
Double-click the DMG file to run the ScreenFlow installer.

Note: The installer attempts to close applications including QuickTime, Final Cut Pro, 
Episode Desktop, and Pipeline Control before installation. If the installer can’t close 
these applications, installation will fail after about a minute.

The installer displays an icon for ScreenFlow and an icon for the Applications folder.

2. Drag the ScreenFlow icon onto the Applications folder.



Installation
Unlocking ScreenFlow via Telestream Web Store

22

ScreenFlow User Guide

3. Enter an administrative user name and password to continue.

Your computer installs ScreenFlow.

4. When installation is complete, close the installer.

See also Purchase Menu (Telestream Web Store Only) and Install and Activate ScreenFlow.

Unlocking ScreenFlow via Telestream Web Store
Note: Use this method only if you purchased ScreenFlow directly from the Telestream 
Web Store. If you purchased ScreenFlow from the Mac App Store, refer to the Mac App 
Store installation and upgrade instructions.

You must purchase a ScreenFlow license in order to export movies without watermarks.

Note: You must be logged in as an administrator in order to continue.

To purchase a ScreenFlow license, do the following:

1. Start ScreenFlow.

2. Select ScreenFlow > Settings and click the Licenses tab.

See Licenses Settings Tab.

3. Click Purchase. This redirects you to the Telestream online store where you can 
purchase or upgrade your license.

When the purchase is complete, ScreenFlow installs the license automatically.

Note: If ScreenFlow doesn’t display a Purchase button, ScreenFlow already is 
purchased, registered, activated, and unlocked.

Activating Your Telestream Web Store License
Note: Use this method only if you purchased ScreenFlow directly from the Telestream 
Web Store. If you purchased ScreenFlow from the Mac App Store, refer to the Mac App 
Store installation and upgrade instructions.

If you have already purchased a license through the Telestream Web Store, Telestream 
sent you an email receipt containing your license key.

Note: If your Macintosh is not connected to the Internet, follow the instructions in the 
Manual Activation Guide to activate your license and unlock ScreenFlow.

The easiest way to register the license key and activate ScreenFlow is to click on the link 
provided in your email receipt. If the link doesn’t work, register ScreenFlow as follows:

http://dev2.telestream.net/telestream-support/screen-flow/help.htm 
http://dev2.telestream.net/telestream-support/screen-flow/help.htm 

http://www.telestream.net/telestream-support/screen-flow/activation.htm
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1. Launch ScreenFlow.

2. Select ScreenFlow > Settings and click the Licenses tab.

See Licenses Settings Tab.

Note: If ScreenFlow doesn’t display a Purchase button, ScreenFlow already is 
purchased, registered, activated and unlocked.

3. Enter your serial number and click Activate.

Note: If the Activate button is dimmed, the license is invalid. Double-check your 
license from the e-mail. Make sure that all letters are capitalized, dashes are included, 
and all 0s are zeros, not the capital letter O. It might help to copy and paste your serial 
number from your e-mail. Don’t copy any additional text such as spaces. If you still 
have activation problems, contact technical support.

Your serial number is activated and ScreenFlow is unlocked. Close the Settings window 
to continue.

See Install and Activate ScreenFlow.

Installing Telestream Audio
To capture computer audio, ScreenFlow must install the Telestream audio driver. 
ScreenFlow starts the installation process automatically if you attempt to record 
computer audio without the driver installed.

Note: To proceed, log in as an administrator.

Note: If you purchased ScreenFlow from the Mac App Store, ScreenFlow directs you 
to the Telestream website to download and install the driver.

To install the Telestream audio driver manually, follow these steps:

1. In ScreenFlow, select ScreenFlow >  Settings. Then click the Advanced tab.

See Advanced Settings Tab.

2. Using the Installer application, click the Install Driver button.

ScreenFlow displays the Install Telestream Audio dialog.

3. Click Continue.

The installer displays a space-requirement message.

4. Click Install.

5. To install the driver, enter your password and click OK.

The Installer installs the Telestream audio driver.

6.  To close the Installation Complete dialog, click Close.


http://www.telestream.net/telestream-support/screen-flow/activation.htm
http://www.telestream.net/telestream-support/screen-flow/contact-support.htm
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Upgrading Telestream Audio Manually

Note: If ScreenFlow prompts you to upgrade the audio driver, select Cancel to exit the 
upgrade message. Before installing the new audio driver, uninstall the current audio 
driver. Then, install the latest version of the audio driver, either manually or using the 
Record Computer Audio checkbox.

To upgrade the Telestream audio driver manually, do the following:

1. In ScreenFlow, select ScreenFlow > Settings. Then click the Advanced tab.

See Advanced Settings Tab.

2. Click the Install Driver button to display the Install window, then click Continue.

3. When ScreenFlow displays the space requirement message, click Install.

4. Enter your password and click Install Software.

5. After ScreenFlow installs the Telestream audio driver, click Close.

Upgrading Telestream Audio Via the New Recording Tab

Note: If ScreenFlow prompts you to upgrade the audio driver, select Cancel to exit the 
upgrade message. Before installing the new audio driver, uninstall the current audio 
driver. Then, install the latest version of the audio driver, either manually or using the 
Record Computer Audio checkbox.

To upgrade the Telestream audio driver through the New Recording tab, do the 
following:

1. Launch ScreenFlow to display the Welcome window.

2. Select New Recording.

3. Check Record Computer Audio.

4. When ScreenFlow displays the upgrade message, select Upgrade, and click 
Continue.

5. When ScreenFlow displays the space requirement message, click Continue.

6. Enter your password and click Install Software.

7. After ScreenFlow installs the Telestream audio driver, click Close.

Uninstalling the Telestream Audio Driver
To uninstall the Telestream audio driver, do the following

1. Select ScreenFlow > Settings.

2. Click the Advanced tab.

See Advanced Settings Tab.

3. Click Uninstall Driver and enter the password.
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Configuring the Telestream Audio Capture Device
You can use Audio MIDI setup to control the sample rate at which the Telestream Audio 
Capture device records audio. The sample rate you select for the Telestream Audio 
Capture device is the sample rate at which ScreenFlow records the audio. The 
ScreenFlow default sample rate is 48 kHz.

ScreenFlow has an inherent latency. Audio flows to the Telestream audio driver, back to 
ScreenFlow recording system, then out through the speakers. However, you can 
configure the audio driver to eliminate latency. To enable recording without latency, do 
the following:

1. Go to ScreenFlow > Settings > Advanced.

See Advanced Settings Tab.

2. Check both of these boxes:

– Allow device to be Sound Output

– Disable Sound Output Monitoring

3. Open Audio MIDI setup and press the (+) button. Then select Create Multi-Output 
Device.

4. Add your system speakers to this multi-output device.

5. Add Telestream Audio Capture to this multi-output device.

6. Click the Gear button and select Use This Device For Sound Output.

7. (Optional) If desired, also select Play Alerts and Sound Effects Through This Device.

When configured in this way, audio flows immediately to your output device. 
ScreenFlow can now record the audio without adding latency to the recording.

Note: When you configure ScreenFlow without latency, ScreenFlow disables the 
audio level controls.

Note: Consider configuring your Digital Audio Workstation (DAW) to route desired 
channels to the Telestream Audio Capture Device. The DAW adds an output from the 
DAW directly to ScreenFlow, while leaving your workflow untouched.

Deactivating Your ScreenFlow License
Note: Use this method only if you purchased ScreenFlow directly from the Telestream 
Web Store. If you purchased ScreenFlow from the Mac App Store, refer to the Mac App 
Store installation and upgrade instructions.

If you want to use your ScreenFlow license on another computer, you must deactivate it 
first.
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Note: You must log in as an administrator. If you don’t have an administrative 
account, create one in order to continue.

To deactivate the ScreenFlow license, do the following:

1. Launch ScreenFlow.

2. Select ScreenFlow > Settings and click the Licenses tab.

See Licenses Settings Tab.

3. Click Deactivate to deactivate the license on the computer. Now, you can use the 
same license in ScreenFlow running on another computer. Please allow 15 minutes 
before reactivating your license.

Removing ScreenFlow from Your Computer
To uninstall ScreenFlow, open the Applications folder and drag the ScreenFlow 
application to the trash.

Note: The ScreenFlow license is stored separately, so you don’t need to re-activate 
your license if you reinstall ScreenFlow.

To completely remove a version of ScreenFlow that has been upgraded to a newer 
version, do the following:

1. Save any work in progress, and make sure ScreenFlow is not open.

2. Open a new Finder window.

3. Select the GO menu at the top of screen, press and hold the Option key and select 
the Library that is displayed.

4. In the Library folder open the Caches folder.

5. Delete all folders that start with net.telestream.ScreenFlow (4/5/6/7/8/9).

6. Open a new Finder window.

7. Select the GO menu at the top of screen, select 
Computer > [your computer name] > Library > Preferences.

8. In the Preferences folder, delete all folders that start with net.telestream.ScreenFlow 
(4/5/6/7/8/9). You will be asked for your admin password.

9. Delete all of the following files:

– ~/Library/Preferences/WSG985FR47.net.telestream.ScreenFlowhelper.plist

– ~/Library/Saved Application State/net.telestream.ScreenFlow6/7/8/9/
10.savedState

– ~/Library/Application Support/ScreenFlow/Global Library

10. Select the GO menu at the top of screen, select 
Computer > [your computer name] > System > Extensions.

11. Delete this file: TelestreamAudio.kext.



Installation
Launching ScreenFlow

27

ScreenFlow User Guide

Note: Some of these files may not be present, because the associated feature was not 
used.

Note: You may need also to reactivate your license.

Launching ScreenFlow
To launch ScreenFlow, follow these steps:

1. Open your Applications folder.

2. Drag ScreenFlow onto your dock bar.

3. Click the ScreenFlow icon to launch the application.

ScreenFlow displays a Welcome window.
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Configuration

You can customize ScreenFlow to meet your needs through ScreenFlow settings.

Topics
■ Settings

■ Configuring ScreenFlow Helper

■ The ScreenFlow Document Formats

■ Configuring Recording Options

■ Setting the Countdown Window Preference

■ Setting Permissions for Recording

■ Configuring the Canvas

■ Configuring Video Properties

■ Configuring Audio Properties

■ Configuring Screen Recording Properties

■ Configuring Callout Properties

■ Configuring Annotations Properties

■ Changing Shortcut Keys

Settings
To choose settings, select ScreenFlow > Settings. Then, click the tab desired.

See ScreenFlow Settings and Deleting Cache & Preferences.

Configuring ScreenFlow Helper
Configure ScreenFlow Helper to launch, either when you log in to your computer, or 
only when you start ScreenFlow. Once launched, ScreenFlow Helper runs in the 
background so that you can start and stop recording without changing the state of 


https://support.telestream.net/s/article/Deleting-Cache-Preferences
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your system. To have ScreenFlow Helper launch when you boot your computer, or to 
disable ScreenFlow Helper from starting when you boot your computer, do the 
following:

1. Select ScreenFlow > Settings > General.

2. Do one of the following:

• To have ScreenFlow Helper launch when you boot your computer, check the box 
for Launch Screenflow Helper at user login.

• To have ScreenFlow Helper not launch when you boot your computer, uncheck the 
box for Launch Screenflow Helper at user login.

When ScreenFlow Helper is running, it displays a camera-menu button , in the menu 
bars for ScreenFlow and Finder.

The ScreenFlow Document Formats
ScreenFlow stores the settings of its properties, and references to related media files, in 
document files. There are two types of ScreenFlow document files: the Packaged 
Document format type and the ScreenFlow Flat Document type.

When you choose Packaged Document, ScreenFlow stores the media files associated 
with the document, as a document bundle, in the document file itself. ScreenFlow 
saves the Packaged-Document document in a file with the extension SCREENFLOW.

When you choose the ScreenFlow Flat Document file format, ScreenFlow doesn’t 
bundle the associated media files. Instead, ScreenFlow stores pointers to the media files 
in a document file with the extension SCREENFLOWF.

Note: ScreenFlow contains references, called bookmarks, to ScreenFlow Flat 
Document files. When you move a Flat Document file to a different folder, ScreenFlow 
automatically tracks the file to its new location. You don’t need to relink the file.

Configuring the ScreenFlow Document Format
To configure the ScreenFlow document format, do the following:

1.  Select ScreenFlow >Settings > Advanced.

2. Select a file format from the Default File Format drop-down menu.

3. To close the Settings dialog, click the red “x.”

Configuring Recording Options
ScreenFlow provides several settings for recording. The recording options are displayed 
on the General tab and on the Advanced tab.
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You can set up ScreenFlow to record video and audio from various cameras and 
microphones, depending on your document, and you can change these settings at any 
time.

To configure your recording options, do the following:

1. Do one of the following:

• Click the ScreenFlow Helper button  and select Configure Recording.

If the New Recording option is grayed-out, you must first open an existing recording 
or create a new one.

• Select File > New.

• Select File > Add Additional Recording.

See ScreenFlow Helper Menu.

ScreenFlow displays the New Recording dialog.

Note: Add Additional Recording allows you to not record the screen, and allows you to 
close ScreenFlow automatically before recording. Configure Recording always records 
the screen. The recording options are identical in both windows.

2. Check the box next to Record on one or more of the source rows, and select a 
source from each drop-down menu.

3. Click the Plus (+) to add more Record options and source menus.

Note: You can also add recordings from the media library.

Setting the Countdown Window Preference
By default, each time you start recording, ScreenFlow displays the countdown window, 
providing a delay to allow you to prepare for recording. By default, the countdown is 
set to five seconds. To change the countdown preference (or to enable or disable the 
countdown), do the following:

1. Select ScreenFlow > Settings > General. 

See General Settings Tab.

2. Set the countdown delay for up to ten seconds.

Note: To skip a countdown in progress, simply click on the countdown window. 
ScreenFlow begins recording immediately.

Setting Permissions for Recording
Before you can record audio or video, you must give ScreenFlow permission to access 
your devices. To set device permissions, do the following:
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1. On the Welcome screen, click Permissions.

ScreenFlow opens the Grant ScreenFlow Permissions dialog.

2. Click a Recording field or the Optional field.

ScreenFlow opens the Security & Privacy control panel.

3. Set the permission for the device or function named in the field.

4. Close the control panel.

Configuring the Canvas
Before you start working on a document, configure the Canvas. This determines the 
frame size and background color of your video outputs.

1. To view and configure the Canvas properties, click the Canvas button  in the 
Editor window.

See The Properties Window.

Note: When ScreenFlow displays Canvas controls, you can’t use the Canvas. Click the 
button again to hide the controls.

2. Click the green check mark to save your settings and close the Canvas control bar.

3. To view and configure Canvas settings, click the Canvas tab on the Settings dialog.

See Canvas Settings Tab and The Canvas Window.

Changing the Canvas Size
By default, ScreenFlow sets the Canvas size to the size of the screen when you begin 
capturing. Document Settings enables you to change the Canvas size of the document 
you have created.

To change the Canvas size, do the following:

1. Select File > Document Settings.

ScreenFlow displays the Canvas settings window.

These settings are similar to the options offered when you create a new document.

2. Select a preset or enter the width and height needed, and select a Timeline 
framerate. Click Update.

ScreenFlow immediately resizes the Canvas to the new dimensions.

See Document Settings, File Menu, and The Canvas Window.


https://vimeo.com/227277802
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Configuring Video Properties
You can configure video properties to make visual changes to screen recordings, 
camera-based video, stills, and imported video clips. To add video properties to a clip, 
do the following:

1. Select a video clip or still-image clip—or place the scrubber at the start or end of a 
video action.

2. To display the Video Properties tab, in the Properties window, click the Video 
Properties button.

See The Properties Window.

3. In the Video Properties tab, select the properties desired.

Note: You can also add video actions (transitional properties which change over 
time) to a clip. ScreenFlow displays actions as yellow rectangles inside the clip. You can 
apply properties to those actions.

Note: To create transitions, you can add video actions to both the start and end of a 
clip.

Configuring Audio Properties
You can apply audio properties to any clip which contains audio, including clips with 
both video and audio. To add audio properties to a clip, do the following:

1. Select a video clip with audio, an audio clip, or a screen recording clip with audio—
or place the scrubber at the start or end of an audio action.

2. To display the Audio Properties tab, click the Audio Properties button  in the 
Properties window.

See Audio Properties.

3. In the Audio Properties tab, select the properties desired.

4. To reset all audio properties in the selected clip to default values, click the gear icon 
 at the top-right corner of the pan and select Reset to Defaults.

Note: You can also add audio actions (transitional properties which change over 
time) to a clip. You can apply properties to audio actions.

Note: To create transitions, you can add audio actions to both the start and end of a 
clip.

In the Timeline, ScreenFlow displays a waveform for each video clip with a soundtrack. 
This waveform provides a visual representation reflecting volume changes.
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See Audio Properties.

Configuring Screen Recording Properties
ScreenFlow records your computer displays in proprietary-format video clips saved in 
the ScreenFlow document with an SCC extension. Only ScreenFlow can open these SCC 
files. Because ScreenFlow manages these files automatically, you rarely have to work 
with them directly.

Note: You can apply screen-recording properties only to ScreenFlow screen-
recording clips. If you try to apply properties to recording actions, ScreenFlow applies 
the properties to the whole clip. ScreenFlow doesn’t apply screen recording properties 
to clips recorded by other applications.

To apply screen-recording properties, do the following:

1. Select a screen recording or select the start or end of a screen recording action in 
the clip.

2. To display the Screen Recording Properties tab, click the Screen Recording Properties 
button in the Properties window.

3. In the Screen Recording Properties tab, select the properties desired.

When you add a screen recording action, ScreenFlow displays the action in yellow.

See Screen Recording Properties.

Configuring Callout Properties
Callouts are transitional properties: they change over time. Use callouts to highlight 
specific portions of the screen.

You can add cursor and foreground-window callouts only to screen recording clips. You 
can add freehand callouts to video clips, still-image clips, and screen recording clips.

You can’t apply callout properties at a clip level, only to specific callouts within a clip.

To apply screen-recording properties, do the following:

1. Select a video clip.

2. Click the +Action button to add a new callout.

3. To display the Callout Properties tab, click the Callout Properties button in the 
Properties window.

4. Select the properties desired.

Note: You must add and/or select a callout before configuring its settings.

See Callout Properties.
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Configuring Annotations Properties
You can use annotations for displaying simple shapes in your document. Annotations 
are clips you can add to your timeline. Annotations behave like image clips. You can 
apply several video properties—such as scaling, position, x/y/z rotation, and opacity—
and video actions to annotations.

To display the Annotations Properties tab, click the Annotations Properties button in the 
Properties window.

See Annotations Properties.

Changing Shortcut Keys
You can customize the ScreenFlow keyboard shortcut commands through the 
Shortcuts tab. To change a shortcut keyboard command assignment, do the following:

1. Select ScreenFlow > Settings.

ScreenFlow opens the Settings dialog.

2. Select the Shortcuts tab.

See Shortcuts Settings Tab.

3. Click a shortcut in the list, to the right of the shortcut name.

ScreenFlow displays the editable shortcut field.

4. Enter a new key combination for the shortcut.

Modified shortcuts are updated immediately, in either the main menu, ScreenFlow 
Helper menu, or with the keyboard-only functionality.

Note: If you enter a key combination that already has a shortcut associated with it, a 
warning triangle appears next to each shortcut in conflict. The filter bar changes to 
include a Conflict Filter, allowing you to display only the conflicted shortcuts. You must 
resolve each conflict.

For a complete list of ScreenFlow keyboard shortcuts that you can customize, see 
ScreenFlow keyboard shortcuts.

Also see Finding Keyboard Shortcuts, Shortcuts Settings Tab, and Keyboard Shortcuts 
and Hotkey Customizations.


https://www.telestream.net/pdfs/technical/screenflow-shortcuts.pdf

https://vimeo.com/227757577

https://vimeo.com/227757577
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Tutorials

Take the following three tutorials before beginning your first ScreenFlow document. 
You’ll gain a basic familiarity with the program before you begin a project.

First, record or import video. Next, edit the screencast. Finally, export your finished 
video to a file or publish it directly to a video hosting service.

Topics
■ Tutorial 1: Recording a Screencast

■ Tutorial 2: Editing a Screencast

■ Tutorial 3: Exporting or Publishing a Screencast

Tutorial 1: Recording a Screencast
Before creating a video for publication, record a few sample screencasts. This will 
familiarize you with ScreenFlow recording options. First, select the sources you want to 
record. Then, record a screencast.

Selecting Your Sources
To select your video and audio sources, do the following:

1. Connect any external video or audio sources to your Mac by cable.

2. On the Welcome screen, click New Recording.

ScreenFlow opens the New Recording dialog, showing fields for selecting sources.

3. Check the box next to the first Record field to enable the field.

4. In the first Record field, click the arrows to the right of the field.

ScreenFlow opens a drop-down menu of sources.

5. Click a source from the list that you want to record.
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Note: When you select Computer Audio as a source, ScreenFlow might display the 
message, Recording Audio from other applications in ScreenFlow. If it does, please 
consult ScreenFlow 7.3.1: New Audio Driver located on the Telestream Knowledge Base 
at: New Audio Driver.

6. To add another source, check the box for another Record field, and select the 
desired source from the drop-down menu. Repeat this step for every source you 
want to add.

7. To add additional source fields, click the “+” icon toward the bottom of the dialog.

8. Click the icon containing an ellipse (...) to the right of a source field, to open 
advanced options for the source. Select the option desired.

Note: Also, you can select sources by navigating to Configure Recording in ScreenFlow 
Helper.

Recording Video and Audio
1. Click the Record button.

ScreenFlow enters a countdown mode before recording. You can change the 
length of this countdown.

2. After the countdown, create a short presentation.

3. To stop the recording: press Shift-Command-2 or select Stop Record from the 
ScreenFlow Helper menu  in the upper-right corner of your display.

ScreenFlow captures all sources synchronously, whether audio, video, or both.

ScreenFlow combines display video and computer audio into one clip and saves 
the clip as an SCC file. ScreenFlow also combines camera video and microphone 
audio into another clip and adds it to your document.

When you stop recording, ScreenFlow opens your recording in the ScreenFlow Edi-
tor window with all of your recorded sources placed at the beginning of the time-
line. The media elements on the timeline reference your document’s stored media. 

Capturing Part of the Screen
To record only a portion of the screen, do the following:

1. On the New Recording dialog, click the Partial Screen Record button to the left of the 
red Record button.

ScreenFlow darkens the screen and draws a rectangular capture area.


https://support.telestream.net/s/article/ScreenFlow-7-3-1-and-higher-New-Audio-Driver


Tutorials
Tutorial 2: Editing a Screencast

39

ScreenFlow User Guide

Figure 1. The ScreenFlow Capture Area

Note: While the rectangular selection is present, you can’t interact with any windows 
on the desktop.

2. Drag an edge or corner of the rectangle to resize it.

3. Click the Record button.

ScreenFlow enters a countdown mode before recording. You can change the 
length of this countdown.

4. After the countdown, create a short presentation.

5. To stop the recording: press Shift-Command-2 or select Stop Record from the 
ScreenFlow Helper menu  in the upper-right corner of your display.

When you stop recording, ScreenFlow opens your recording in the ScreenFlow edit-
ing window with all of your recorded sources placed on the timeline.

You can cancel partial-screen capture, start the recording, or use presets to constrain 
the region you are capturing from the control strip towards the bottom of the screen.

For more information about partial screen capture, see the ScreenFlow User Guide.

Tutorial 2: Editing a Screencast
This tutorial introduces some basic ScreenFlow editing techniques.

For a description of the ScreenFlow user interface, see the ScreenFlow User Guide.

Note: Changes made on the timeline or in the Editor window do not alter your 
original recorded media.

Trimming a Clip
To trim a clip, do any of the following:
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• To trim the beginning of the selected clip, position the scrubber at the time you 
want the clip to begin, then press the W key or select Clip > Trim Front to Scrubber. 
This trims the clip up to the scrubber, thus changing the start time.

• To trim the end of the clip, position the scrubber at the time where you want the 
clip to end, then press the E key or select Clip > Trim End to Scrubber. This trims the 
clip after the scrubber.

• To shorten a clip, grab either edge of the clip and drag it inward toward the clip 
center.

• To lengthen a previously-trimmed clip, pull either edge out from the clip center.

Note: Trimming changes the amount of time the clip plays; it doesn’t modify the 
referenced media file.

Adding Transitions
To add a transition, select a clip and do one of the following:

• Select Clip > Add Starting Transition to add a transition to the front of the clip.

• Select Clip > Add Ending Transition to add a transition to the end of the clip.

• Select Clip > Add Starting & Ending Transition to add a transition to both ends.

You can also create transitions between two clips by dragging one clip over an adjacent 
clip. The section where the two clips overlap is the transition.

Adding a Video or Audio Filter
To add a filter to one or more clips, follow these steps:

1. Select the video or audio clip to filter.

2. Select the Video or Audio properties tab, as appropriate.

3. Next to the Filters and Effects heading in the Video tab, or next to the Audio Filters 
heading in the Audio tab, click the (+) button.

ScreenFlow displays the list of available filters.

4. Scroll through the list of filters. Alternatively, in the Audio tab, enter a filter name 
into the Search field and press Enter.

5. Select a filter, and click Add to add it to the filter list for the selected clip.

Note: If a manufacturer's audio unit plug-in does not work in a “sandbox” 
environment, it will not work in the Mac App Store version of ScreenFlow. Contact the 
manufacturer of the audio plugin directly for information on plugin sandbox support.

See Video Filters and Effects.



https://vimeo.com/560931223
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Tutorial 3: Exporting or Publishing a Screencast
This tutorial introduces techniques for exporting or publishing your screencast.

Note: ScreenFlow screencasts are not video files—they are saved as ScreenFlow 
documents (with a SCREENFLOW extension), which only ScreenFlow can open.

You can export screencasts to standard video file formats, or you can publish them 
directly to a video hosting service, such as Vimeo or YouTube.

The correct export settings for your screencast depends on the complexity of your 
screencast and the intended use of the video.

Exporting a Screencast
To export a screencast, do the following:

1. Select File > Export or press Command-E to export your presentation.

ScreenFlow opens the Export dialog.

2. Select the desired settings for your screencast.

See The Export Settings Dialog in the ScreenFlow User Guide.

Publishing a Screencast
To publish a screencast to a video hosting platform, do the following:

1. Select File > Publish to [platform] for the platform desired.

ScreenFlow opens the Publish to dialog for the chosen platform.

2. Select the desired settings for your screencast.

See The “Publish to” Dialogs in the ScreenFlow User Guide.
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Documents and Recordings

You can use ScreenFlow to create documents and to record media.

Note: ScreenFlow automatically stops recording when there is one gigabyte or less 
free on your system disk volume.

Topics
■ Documents

■ ScreenFlow Recordings

■ Tips for Screencasting

Documents
Before you start recording, create a document. ScreenFlow saves a media library, SCC 
files, properties, and various commands in each document file. ScreenFlow saves 
documents in files with either the Packaged Document format extension SCREENFLOW 
or with the ScreenFlow Flat Document format extension SCREENFLOWF.

Creating a Document
To create a ScreenFlow document, do the following:

1. Select File > New or press Command-N.

ScreenFlow displays the New dialog.

See The New Dialog.

2. Select the New Document tab.
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3. Select properties for the document as desired.

ScreenFlow displays a dialog which allows you to set your canvas size to any dimen-
sion, regardless of your display size. Valid document dimensions are any even num-
ber between 2 and 8192 as minimum and maximum, respectively.

See The Properties Window.

4. Click Save.

When you first save a document, ScreenFlow opens a popup menu at the bottom 
of the Save panel. Here, you can choose between the Packaged Document format 
and the ScreenFlow Flat Document format.

See The ScreenFlow Document Formats.

Specifying the Default Document Format
You can set the default document format.

Note: You can override this default when you first save a document.

To can set the default document format, do the following:

1. Click ScreenFlow > Settings > Advanced.

2. Open the File Format drop-down menu, and select the desired format.

See The ScreenFlow Document Formats.

Creating a Document Template
You can use a document as a template for creating other documents. This allows you to 
specify consistent starting, variable, and ending content. When you create a document 
made from a template, ScreenFlow determines the starting and ending content based 
on the Template Placeholder Clip information, and places the variable content 
(recordings) in the middle.

You can share templates between different computers. ScreenFlow automatically reads 
templates in the shared template folder.

To create a template from any unsaved ScreenFlow document, do the following:

1. Create a new document.

See Creating a Document.
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2. Select Insert > Template Placeholder Clip.

ScreenFlow displays the placeholder dialog.

You must insert a template placeholder clip before you can save a document as a 
template. If you haven’t inserted a template placeholder clip, ScreenFlow displays 
the message No Template Placeholder Clips.

The Template Placeholder Clip gives you control over the variable portion of the 
template. The placeholder also determines the options presented when you create 
a new document from an existing template.

Note: You can position, scale, and rotate the placeholder clip like other clips. 
However, ScreenFlow labels the placeholder clip so it stays matched with the correct 
content when you create a document from the template.

3. (Optional) When adding a Screen Recording or Camera placeholder, you can add an 
audio placeholder clip at the same time, enabling the configuration of audio-
specific properties.

4. In the placeholder dialog, select the type of template placeholder clip: Screen 
Recording, Camera, or IOS Device.

5. Select File > Save As Template.

ScreenFlow displays a dialog box allowing you to name your template.

6. Enter a template name and click Save.

ScreenFlow saves the template in a sub-folder of the Users Library folder located at:
         ~/Library/Application Support/ScreenFlow/Templates/.

This sub-folder contains all the content needed by the template. However, the new 
template file is given the a file extension of ScreenFlowTEMPLATE (not SCREEN-
FLOW which is used for ScreenFlow documents). ScreenFlow manages this tem-
plate folder by deleting and updating files as needed, so you should not make any 
changes directly.

Once a document has been converted to a template, the Save as Template menu 
item is disabled.

Creating a Document from a Template
After a template has been created and saved, it’s ready for immediate use. To create a 
new document from a template, do the following:

1. Select File > New.

ScreenFlow displays the New dialog.

See The New Dialog.

2. Select the New From Template tab.

3. Select a template, then click the Open button. You can also edit a selected template 
by clicking the Edit Template button.
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4. Click the gear button to set up the recording.

ScreenFlow displays the recording settings window.

5. Set up your recording as needed.

6. Click the radio button to open the other settings window.

ScreenFlow displays the other recording settings window.

7. Finish setting up your recording.

8. Click the Record button to begin recording, using your new template.

ScreenFlow Recordings
With ScreenFlow, you can record video and audio from a variety of devices.

ScreenFlow records display video, computer audio, camera video, and microphone 
audio into proprietary Screencast files, with the file extension SCC. In addition to audio 
and video, SCC files contain spatial and temporal information about mouse tracking 
and key presses. This data enables powerful special effects to enhance your screencast.

ScreenFlow stores screencast files in a ScreenFlow-controlled location, and adds 
screencast files to the document media library.

Note: ScreenFlow captures video at a maximum of 60 fps, even from sources with 
frame rates higher than 60 fps. ScreenFlow automatically down-converts higher-than-
60 fps video to 60 fps.

Adding Recordings to a ScreenFlow Document
To record a clip and add it to an open document, do the following:

1. Make sure the document window is open and selected.

2. Then, select File > Add Additional Recording (Shift-Command-R) or press the 
Add Recording button in the media library.

3. Verify your settings and click Record.

Depending on your settings, ScreenFlow displays the countdown window, and then 
begins recording. During recording, the camera icon on the ScreenFlow Helper button 

 displays a black dot. When you stop recording, ScreenFlow adds the clip you just 
recorded to the document.

Enabling Recording of Computer Sound
You can enable ScreenFlow to record sounds produced by your computer. To enable 
recording of computer sound, do the following:

1.  Select File > Add Additional Recording (Shift-Command-R) or press the Add 
Recording button in the media library.
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2. In the New Recording dialog, check an empty box for a Record field.

3. Select Computer Audio from the drop-down menu.

4. If ScreenFlow offers to install a new audio driver, click Install.

5. To configure ScreenFlow to record the audio from individual apps to separate clips, 
click the circle containing three dots. Then check the box for Separate recorded apps 
into individual clips.

Recording Clips
To record a clip without deciding which document to add it to first, do the following:

1. Click the ScreenFlow Helper  button.

2. Select Record, or select File > New > New Recording and click the red Record button. 
Depending on your settings, ScreenFlow displays the countdown window, and 
then ScreenFlow begins recording. During recording, the camera icon of the 
ScreenFlow Helper button  displays a black dot.

When you stop recording, ScreenFlow displays a Recording Complete window so 
that you can create a new document with your recording, or add your recording to 
any open document.

3. To verify your settings first, click on the ScreenFlow Helper  button and select 
Configure Recording.

4. Click the Record button. Depending on your settings, ScreenFlow displays the 
countdown window, and then ScreenFlow begins recording.

When you stop recording, ScreenFlow displays the Recording Complete window, as 
shown above, so that you can add your recording to an open document, start a new 
one, or discard your recording.

Note: The only limitation on the length of your recording is the amount of space 
available on your hard drive. ScreenFlow automatically stops recording when you 
have less than 100 MB free on your system disk volume.

Recording iOS devices
ScreenFlow enables you to record the screen of your iOS device. You must have your 
device connected to your computer with an Apple Lightning-USB cable.

1. Connect your device to the computer and check iTunes to verify that macOS 
detects the device.

Note: If it is the first time the iOS device is connected to your computer, you will be 
asked if you trust the device. Select Trust to continue.

2. Open ScreenFlow and select New Recording.

3. Select your iOS device from the Record Desktop from drop-down list.
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4. Click the Record button. After the countdown, you can begin recording your iOS 
device.

Note: ScreenFlow doesn’t preview your iOS screen, but records it. ScreenFlow doesn’t 
record touches or swipes. You can add callouts to simulate touches and swipes.

5. When done, stop the recording.

ScreenFlow displays your iOS device on the canvas. ScreenFlow automatically ori-
ents the screen for apps that display in landscape mode. You may need to adjust 
the canvas size.

6. (Optional) Display a recording monitor by selecting Show Recording Monitor from 
the Record configuration menu.

The monitor displays stereo volume meters, a Preview Volume slider, and an Add 
Marker button. Preview Volume allows you to hear the system audio playing on your 
iOS device through your computer audio output as it is being recorded.

Note: If you do not hear iOS audio while recording, toggle the ringer/vibrate switch 
on your iOS device. Also, if you record computer audio while monitoring iOS audio, 
you will hear iOS audio twice in the screencast.

When you play or scrub through the video, the iOS device displays all of the actions you 
performed.

Stopping, Pausing & Resuming Your Recording
• Before you start recording, it’s good to know how to stop. To stop recording in 

ScreenFlow, click the ScreenFlow Helper  menu button, and select Stop Record 
or press Shift-Command-2.

• To pause your recording, click the ScreenFlow Helper  menu button and select 
Pause. When you pause recording, the solid black recording dot changes to a pause 
symbol . To start recording again, select Resume from the ScreenFlow Helper 
button .

Recording When you Start ScreenFlow
To record a clip for a new document, do the following:

1. Start ScreenFlow.

ScreenFlow displays the recording window.
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2. Click the red Record button to start recording your first clip.

During recording, the camera icon of the ScreenFlow Helper button displays a black 
dot.

When you stop recording, ScreenFlow displays a window that lets you add your 
recording to a new document, add it to an existing document, or discard the docu-
ment.

Adding Clip Markers While Recording
ScreenFlow enables you to attach markers directly to your clips. During a recording, if 
something important or notable occurs, it may be desirable to create a marker during 
the recording process to provide quick access, later, when organizing a document.

ScreenFlow enables the Add Marker menu item only during recording, and disables it 
when the recording is paused or stopped.

• To set a clip marker during recording click the Add Marker button.

Once you’ve completed your recording, ScreenFlow displays, in the timeline, any 
markers you added, and attaches the markers to the primary clip.

See also Adding a Clip Marker and Adding a Timeline Marker.

Viewing the Recording Monitor
To open the Recording Monitor, click the ScreenFlow Helper (camera) button, then select 
Show Recording Monitor.

See The Recording Monitor.

Setting the Recording Timer
You can configure ScreenFlow to record a screencast, and to stop recording, 
unattended. For example, you can start recording a webinar, and set ScreenFlow to 
automatically stop recording when the webinar is over.

To set up ScreenFlow to stop recording after a certain time, do the following:

1. Click the ScreenFlow Helper  menu and select Configure Recording.

Marker on 
timeline
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2. Use the Stop Recording option on the second panel to specify the elapsed time to 
stop the recording.

3. Click Set Timer, then start recording. 

Elapsed-time recording is a one-off event—you must set it every time you want to use 
it.

Configuring a Recording
1. To configure a recording, do one of the following:

• Launch ScreenFlow.

ScreenFlow launches ScreenFlow Helper and the Configure Recording window.

•  Select File > New > New Recording or ScreenFlow Helper > Configure Recording.

2. Click the Show Advanced Options (three dots) button.

See The Advanced Options Pane for New Recordings.

When you stop recording, you can add this new recording to a new document, or add 
the recording to a ScreenFlow document that’s already open. If you have no other 
documents open, ScreenFlow automatically creates a document file for the new 
recording.

Partial Screen Capture
Partial screen capture enables you to record a selected portion of the screen. To capture 
a portion of a screen, do the following:

1. Make sure the document window is open and selected.

2. Then, select File > Add Additional Recording (Shift-Command-R) or press the 
Add Recording button in the media library.

ScreenFlow opens the Welcome dialog.

3. Click the partial-screen record button (the dashed rectangle icon to the left of the 
main record button).

ScreenFlow darkens the screen, and displays a rectangular selection area.
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4. Click and drag to resize the selection area. While setting the selection area, you 
can’t interact with any other windows.

There is a control strip at the bottom of the focused screen where you can cancel 
out of this mode, start the recording, or use presets to constrain the region you are 
capturing.

5. If there are multiple displays connected, click on the display to record.

Once you click on a display, the control strip moves to the display selected. The pre-
set button displays a popup giving you some constraint presets, such as 1280x720. 
You can also enter a fixed width and height directly.

6. (Optional) You can use shortcut keys to move the rectangle around the screen. If 
you hold the Shift key while nudging, ScreenFlow increases the movement. If you 
move the mouse over a window and press the space bar, ScreenFlow resizes the 
selection rectangle to fit just that window. You can use the Escape key at any time 
to exit out of selection mode.

Note: The selection rectangle is always cropped to a single display, and can’t span 
multiple displays.

7. To record, click the red record button.

The selection area disappears and the standard recording countdown begins. The 
recording inherits any other recording settings, such as camera and microphone 
settings, from the main user interface. ScreenFlow sets the canvas size to the size of 
the region you selected.

Cancel

Record

Presets

Partial screen 
record button
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ScreenFlow remembers the selection rectangle size and location the next time you 
enter region selection mode. However, ScreenFlow doesn’t display this preset rectangle 
automatically if you pick Record from the ScreenFlow Helper button . Clicking 
Record continues recording only in full screen mode. You can activate region recording 
only through the front-end window.

Once the recording has ended, you can interact with the new document as usual.

Viewing the Media Library
Once you’ve recorded or imported the first media file into a ScreenFlow document, 
ScreenFlow creates a media library for the ScreenFlow document.

Note: ScreenFlow saves or duplicates every file you add to the library in the Media 
folder. ScreenFlow recordings are media files with an SCC extension. Only ScreenFlow 
opens SCC files.

For Packaged Document format documents, ScreenFlow keeps the media library in a 
folder inside the SCREENFLOW document file itself. For Flat Document format 
documents, ScreenFlow keeps the media folder inside the SCREENFLOWF document 
folder. In either case, the media folder contains SCC files and copies of external media 
files. These are managed by the media library as you record clips, add files, or delete 
files.

To view the media folder, do the following:

1. Control-click (right-click) the project file in Finder and select Show Package Contents.

2. Open the Media folder to view the files in the media library for this document.

Caution: Unless directed by customer service, you should not delete or rename 
files in this directory, which could corrupt your document.

Tips for Screencasting
Before you begin your screencast, it’s useful to consider how you and your users intend 
to use your screencast, how you want to organize your media, and how best to present 
your screencast on screen.

Setting Your Display Resolution
Before you begin recording, consider the resolution of your display and the intended 
export resolution of your screencast. Typically, you shouldn’t export your screencast at 
the resolution at which you recorded it. Export your final video at a lower resolution 
than screen resolution—especially if you are recording a high resolution display or a 
Retina display (maximum 2880 x 1800). This is especially important when you have text 
which must be legible.
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Telestream recommends that you check your display resolution, via Mac System 
Preferences > Displays, before recording. Lower your display resolution as much as 
possible without impairing your ability to view your screencast clearly. To prevent 
quality loss, don’t lower the resolution below your intended export resolution.

Best Text for Screencasts
Digital video was designed primarily for capturing real world images, so it is often 
difficult to capture the thin lines of text legibly. Here are a few tips to consider for text in 
your video:

• Use font sizes of 25 points or more. Larger characters always render better than 
small ones.

• Don’t use serif fonts like Times Roman. Always use sans-serif fonts such as Arial or 
Helvetica.

• Use boldface fonts, since they render better, especially at smaller sizes.

• Don’t use odd values for the output movie's frame height or width. Always use even 
numbers. Also, importing sources with odd height or width values can result in 
illegible titles.

• Always generate non-interlaced video. Interlaced video is prone to poor quality text 
rendering, and can introduce flickering.

The Lossless preset is the only preset which you can specify as interlaced.

Approaches for Narrated Screencasts
When creating narrated screencasts, consider two different approaches. For a simple 
demo, you might narrate the demo as you perform it. For a more complex demo, you 
might record the demo first; then add narration in a separate step.

Recording Everything at Once
Using this method, you record each recording source in a single session—
simultaneously recording the display, camera video, microphone audio, and computer 
audio. When you are done recording, you can use the editing tools to finalize your 
screencast document.

For example, you might start a screencast by recording your display, then cut to a 
Picture-in-Picture of a camera recording, as you demonstrate the application. Later, you 
fade out your video, leaving only the audio to narrate the remaining moments of the 
screencast.

This method is considered a single-pass production. It works well when your subject 
matter is simple, straightforward, or short. For longer or more complex screencast 
screencasts, you might find the second approach more comfortable.
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Recording Your Display—Then Adding Narration
Using this method, you first record the display (optionally, without computer audio), 
demonstrating your application or subject matter without any video or voice-over.

When you have finished your demonstration, you record your camera and microphone 
sources while playing the video preview of your demonstration in ScreenFlow. You can 
do this in a single long recording or in several short recordings.

You then edit your recordings to align your narration with your demonstration or fade 
your camera recording in and out when appropriate.

This workflow is effective when the screencast involves a series of complex mouse or 
keyboard operations, or when you have several comprehensive steps or tasks to 
achieve.
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Media Editing

You can use ScreenFlow to add media to your document, and to edit your media into a 
finished video.

Topics
■ Viewing the ScreenFlow User Interface

■ Finding Keyboard Shortcuts

■ Editing Clips

■ Editing on the Canvas

■ Editing in the Timeline

Viewing the ScreenFlow User Interface
To view the ScreenFlow user interface, launch ScreenFlow.

For descriptions of the various windows in ScreenFlow, see The ScreenFlow User 
Interface.

For descriptions of ScreenFlow menus, see Menus.

For descriptions of ScreenFlow properties, see Properties.

Finding Keyboard Shortcuts
To speed up your workflow, you can start many ScreenFlow features with keyboard 
shortcut commands.

• For a complete list of ScreenFlow keyboard shortcuts that you can customize, see 
ScreenFlow keyboard shortcuts.

Also see:

Shortcuts Settings Tab

Changing Shortcut Keys


https://www.telestream.net/pdfs/technical/screenflow-shortcuts.pdf
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Keyboard Shortcuts and Hotkey Customizations

ScreenFlow Tutorial - 3 Handy Timeline Shortcuts

Editing Clips
Before editing, you add clips to a ScreenFlow document. Clips are the building blocks of 
every ScreenFlow screencast. A clip in ScreenFlow points to one or more media files, 
but doesn’t contain the media files. A clip does contain all the information needed to 
play and render the media file. Clip information can include start and stop times, 
transitions, and other assigned properties.

Whether you record your display directly, or record a camera and microphone, 
ScreenFlow adds clips for those recordings to your document. You can also add still 
images or media files recorded outside of ScreenFlow.

ScreenFlow supports video and audio file formats that QuickTime Player can play in 
macOS 10.6.x and higher. ScreenFlow also supports many image formats, including 
PNG, JPEG, GIF, and TIFF.

The media library holds all the clips for a ScreenFlow document. You can add clips to a 
media library by dragging and dropping media files into the media library. 
Alternatively, ScreenFlow adds a clip to the media library for every media file you drop 
into the ScreenFlow timeline.

See The Properties Window for more detail on how to add media to your library.

Adding Clips to a Media Library
Drag a clip from the file system (Desktop or Finder window) directly onto the 
ScreenFlow timeline. This allows you to place the clip on the track you want, at the 
point on the timeline you want. ScreenFlow automatically adds the clip to the media 
library.

Adding Clips to the Timeline or Canvas
To add clips to your timeline or canvas, do one of the following:

• To add a clip to the timeline at the scrubber, double-click the clip in the media 
library.

• To place the clip on the track you want, at the location you want, drag a clip from 
the media library directly onto the timeline.

• To add several clips sequentially by time onto a single track, select the clips sequen-
tially and-drag the group onto the timeline.

• To place clips as stacked layers on the timeline, hold the Shift key down while click-
ing and dragging multiple clips onto the timeline.



https://vimeo.com/227757577


https://vimeo.com/756972927
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Note: You can select one or more clips using lasso selection—click and drag across 
some portion of several clips to select them.

• To place a clip to the timeline at the current scrubber position, click the plus (+) icon 
and select a clip from the drop-down list.

• To place a clip spatially on the canvas, drag the clip from the media library directly 
onto the canvas. ScreenFlow also places the clip in a new top track on the timeline 
at the scrubber.

• Copy and paste clips in the same document, or copy and paste clips between open 
ScreenFlow document windows.

ScreenFlow derives the default name of a clip from the media file it references. To 
change the name of a clip, double-click on the text or click the gear icon  on the clip, 
and select Rename Clip. The new name does not change the name of the source file.

Viewing Clip Metadata
To view the metadata of a video clip, do the following:

1. Select the Media Library tab in the Properties window.

See Media Library.

2. Click the Metadata button, and select a clip.

Deleting Clips
To delete clips from your document do one of the following:

• Select a clip on the canvas or timeline and press Delete or select Edit > Delete. This 
removes the clip from the canvas and timeline, but leaves the original clip in the 
media library.

• Select a clip in the media library and press Delete or select Edit > Delete. This 
removes the clip from the canvas, timeline, and media library. If the clip is on the 
timeline, ScreenFlow displays a Delete dialog. Click Delete to continue.

These deletions remove the clips from the document. They don’t delete the refer-
enced media files.

Editing on the Canvas
You can place clips in different parts of the screen using the Canvas.

See the Canvas in the screenshot in the topic, The ScreenFlow User Interface.
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Zooming and Panning the Canvas
You can zoom in and out on the canvas to view details or see the big picture. When the 
canvas is larger than the panel, scroll bars appear so that you can scroll in any direction 
to view hidden portions of the canvas.

To zoom in or out on the canvas, hold down the Option Key and move the scroll wheel.

You can also use these commands:

• Zoom in—select View > Zoom In (Command-=)

• Zoom out—select View > Zoom Out (Command--)

• Zoom to full pixel size—select View > Zoom to 100% (Option-Command-0 (zero))

• To scroll the canvas with a mouse, hold down the spacebar and drag. Also, you can 
use normal trackpad actions.

• If you press the Space Bar while moving the Canvas, the position values are not 
changed.

ScreenFlow changes the position values in the Video tab accordingly.

See The Transitions Inspection Window.

Clips on the Canvas
After you add clips to your document, you can edit the clips on the canvas. For example, 
you can arrange clips spatially, and can crop, resize, rotate, or add filters.

Selecting a Clip
To select a clip, click the clip on the canvas or on the timeline.

ScreenFlow highlights the clip both on the canvas and the timeline, and displays 
the properties of the selected clip in the Properties window.

See Properties.

Placing a Clip Spatially on the Canvas
To place a clip anywhere on the canvas, drag the clip and drop it at the location desired.

As the clip approaches the vertical or horizontal center of the canvas, yellow guide-
lines appear to help you center the clip.

Alternatively, select the clip and click the Video Properties tab. To change the clip 
location on the canvas, adjust the X and Y values in the Video Properties tab.

See Moving Images.

Resizing or Scaling a Clip on the Canvas
To resize (or scale) a clip up or down, select the clip, and do one of the following:

• Select any resize handle, and drag.



https://vimeo.com/756972594


Media Editing
Editing in the Timeline

59

ScreenFlow User Guide

• Hold down the Command key while turning the scroll wheel on your mouse.

• Click the Video Properties tab. Drag the Scale slider or manually enter a percentage.

• Select Arrange > Scale.

• Right-click on a clip in the canvas to access the following controls:

– Scale to Fit Enlarges clip to fill the window, while maintaining its scale.

– Stretch Enlarges clip to fill the window, without maintaining its scale (fills the 
entire window).

– Reset Restores the clip to its original scale and size.

Cropping a Clip on the Canvas
To crop a clip, select the clip and do one of the following:

• Press and hold the Control key, and drag any resize handle inward.

• To preserve the aspect ratio, press and hold Control-Shift while dragging a handle.

• Select the Video Properties tab. Click the Details icon. Drag the left, right, top and 
bottom sliders, or manually enter a pixel value.

Rotating a Clip on the Canvas
To rotate a clip on its access, do one of the following:

• Click and drag the center handle of the clip; then rotate it.

• Select the Video Properties tab. Drag the X, Y, and Z thumbwheels, or manually enter 
a degree value.

Editing in the Timeline
You can use the controls in the Timeline to navigate your document.

See The Timeline Window.

Navigating the Timeline with the Scrubber
In the timeline, the red vertical bar with the red flag handle at the bottom is the 
scrubber. The scrubber identifies the current temporal position of the frame displayed 
on the canvas. ScreenFlow displays the timecode of this frame in the toolbar.

See the scrubber in the screenshot in the topic, The ScreenFlow User Interface.

• To scrub (move) through your screencast, grab the top handle (in the time scale) 
and move it right or left.

Note: As you use the scrubber to scrub your screencast, the canvas updates in real 
time.
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• To jump the scrubber to the beginning of the timeline, press the Home key. Alterna-
tively, select Mark > Go to > Project Start.

• To jump the scrubber to the end of the timeline, press the End key. Alternatively, 
select Mark > Go to > Project End.

• To move the scrubber a frame at a time, press the left or right arrow keys. Alterna-
tively, select Mark > Go to > Previous Frame or Mark > Go to > Next Frame.

• To insert empty time across all layers on the timeline, drag the red flag handle of 
the scrubber.

Note: This action splits clips that fall under the scrubber,

See The Timeline Window.

Measuring Duration with Scale
ScreenFlow displays the scale at the top of the timeline. The scale is a precise measure 
of the total length of time in the screencast.

You can view the start and stop time of each clip (or action in a clip) by dragging the 
scrubber to the beginning or end of the clip.

See the scrubber in the screenshot in the topic, The ScreenFlow User Interface.

Zooming In and Out on the Timeline
You can zoom in on an area of the timeline to make adjustments—or zoom out to see 
the big picture.

See the screenshot in the topic, The ScreenFlow User Interface.

Note: Apple Magic Trackpad and MacBook Pro users can use pinch gestures to zoom 
in/out on the timeline.

To zoom in or out of the timeline, do one of the following:

• Drag the scale slider in the lower left corner of the timeline.

At maximum magnification, each line on the scale represents a single frame of 
video.

Note: You can also click repeatedly on the small and large magnifier icons to 
incrementally zoom in or out.

• To fit the entire screencast in the timeline, select View > Zoom Timeline to Fit (Con-
trol-T).

• To zoom in, select View > Zoom Timeline In (=).
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• To zoom out, select View > Zoom Timeline Out (-) menu items.

See The Timeline Window.

Detaching Timelines
You can detach the timeline window, or any timeline tab, from the ScreenFlow layout. 
You can move a timeline window independently from the ScreenFlow layout, even 
onto a second monitor.

To detach a timeline, select Window > Detached Timeline

ScreenFlow detaches the timeline window from the ScreenFlow layout.

See The Timeline Window.

Note: With Detached Timeline enabled, ScreenFlown opens documents in the 
detached-timeline state by default. Also, ScreenFlow re-opens currently-open 
documents in detached-timeline mode. ScreenFlow retains this setting, and applies it 
when the application is reopened.

The initial position of a detached timeline window is close to the normal location of the 
timeline in the ScreenFlow layout. ScreenFlow appends “-Timeline” to the name of the 
detached timeline window. The detached timeline window maintains its own title bar, 
Close, Maximize and Minimize controls.

Note: Closing a detached timeline window closes the entire document associated 
with it.

Timeline Tracks
The timeline is divided into tracks. Tracks allow you to superimpose clips on one 
another. If clips are place on different tracks at the same point in time, the clip in a 
higher track appears on top of the clip in a lower track.

Clips in the top track can’t be obscured. Clips in the bottom track always appear below 
clips in all other tracks.

When you place a text box on a track higher than a track with a video clip in it, 
ScreenFlow superimposes the text on top of the video. If you place the text box on the 
track below the video clip, the video clip obscures the text.

You can place multiple clips sequentially in a single track or you can place clips 
separately on individual tracks. You can create as many tracks as you need.

Note: QuickTime X and VLC require a chapter marker on the first frame of your 
project. To prevent QuickTime or VLC chapter markers from moving from their 
intended locations, set a chapter marker at the very beginning of your project.
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Adding and Deleting Tracks
• To add a track, drag a clip into the timeline below the existing tracks.

ScreenFlow creates a new lowest track.

• To delete a track, select the track and press the Delete key.

Customizing Tracks with the Track Controller
Use the track controls at the left of each track to adjust the track height or to re-arrange 
track order.

See track controls in the screenshot in the topic, The ScreenFlow User Interface.

• To adjust the height of a track, click the down arrow to decrease track height; or 
click the up arrow to increase track height.

• To re-arrange a track’s position, select the track position handle and drag the track 
up or down in relation to the other tracks on the timeline. Drop the track into the 
new position.

This allows you to move all of the clips in a track to a higher or lower layer, rather 
than moving one clip at a time.

• To create a new track for a clip, drag the clip downward past the bottom of the low-
est track. When ScreenFlow creates a new track, drop the clip into the new track.

• To hide or unhide the video in a track, click the eye icon on the left end of the track. 
To mute or unmute the audio in a track, click the speaker icon on the left end of the 
track.

Creating and Closing Gaps in a Single Track
• To create a gap in a track between existing clips, drag to shift the clips to the left or 

right as desired.

• To close a gap in a track, click in the gap. ScreenFlow highlights the gap in purple 
with diagonal gray stripes. Press the Delete key, or control-click and select Close 
Gap.

Creating a Gap Across All Tracks
Occasionally, you might want to create a gap in all tracks of the timeline, to make room 
for additional clips. To create a gap in all tracks, do the following:

1. Position the scrubber where you want the gap to occur.

See the scrubber in the screenshot for the topic, The ScreenFlow User Interface.

2. Grab the handle (red flag) at the bottom of the scrubber and move it to the right.

As the gap is created and widened, all clips to the right of the scrubber (in every 
track) move to the right to create the timeline gap. If the scrubber is positioned 
over any clip, ScreenFlow splits the clip in two.
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Closing a Gap Across All Tracks
To close a gap in all tracks, do the following:

1. Position the scrubber at the beginning of the gap you want to close.

See the scrubber in the screenshot for the topic, The ScreenFlow User Interface.

2. Drag the bottom scrubber handle (red flag) to the left.

This doesn’t join clips which have been split; it just butts them together. If clips 
overlap, this forms a transition.

Timeline Markers
You can place markers on your timeline to identify milestones on your screencast. 
Timeline markers are particularly useful for editing complex screencasts. Unlike clip 
markers, timeline markers remain at their locations on the timeline, regardless of 
changing clip locations.

Note: You can export marker locations as chapter markers in supported formats.

Adding a Timeline Marker
To add a timeline marker, do the following:

1. Add an unnamed marker in one of the following ways:

• Move the scrubber to the desired location and select Mark > Markers > Add.

• Control (right)-click in the time scale (scrubber jumps) and select Add Marker.

• Select Window > Markers, then move the scrubber to the desired location and in the 
Markers window, click the plus (+) icon at the bottom left.

ScreenFlow displays a dialog so you can name the marker.

2. After entering the name of the marker, click OK.

Note: Markers display as orange ticks on the time scale if they are named, but display 
in blue if blank or unnamed. You can select them to rename them, or drag them to re-
arrange them.

Jumping to a Marker
To jump to a given marker, do the following:

1. Select Window > Markers.

ScreenFlow displays the Markers window.
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2. Do one of the following:

– Click the arrow to the left of a marker to quickly move to that marker in the 
timeline.

– Control (right)-click in the time scale—select the marker that you want to jump 
to.

Note: You can use keyboard shortcuts for jumping to markers. See Shortcuts Settings 
Tab.

Deleting Markers
To delete markers, do one of the following:

• Control- (right)-click the orange or blue marker in the time scale and select Delete.

• In the Markers window, select the marker and press Delete or click the minus (-) icon 
at the bottom left.

• Move the scrubber over the marker and select Marker > Delete Marker.

Timeline In and Out Points
You can place in and out points on the timeline, so that you can edit the contents of 
tracks between the in and out points.

Creating Timeline In and Out Points
You can create in and out points on your timeline, and use them in the editing of tracks. 
To set timeline in and out points, do the following:

1. Place the scrubber at the desired in point. Select Mark > Mark In Point (or press I). 
Alternatively, press shift-click to the left of the scrubber.

ScreenFlow highlights the timeline in blue from the beginning of the timeline to 
the in point.

2. Place the scrubber at the desired out point and select Mark > Mark Out Point (O) to 
set the out point. Alternatively, press shift-click to the right of the scrubber.

ScreenFlow highlights the timeline in purple from the out point to the end of the 
timeline.

Note: When you create an in point without an out point, ScreenFlow automatically 
sets the out point to the end of the last clip. When you create an out point without an 
in point, ScreenFlow sets the in point to the beginning of the timeline.

See The Timeline Window.
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Editing Tracks Between Timeline In and Out Points
You can export or delete a section of the timeline you’ve marked with in and out points, 
as follows:

• To delete the selected (marked) section of the timeline and close the gap, select 
Edit > Ripple Delete (Command-Backspace).

ScreenFlow deletes all clips between the in and out points on all tracks. ScreenFlow 
shifts all clips to the right of the deletion to the left, closing gaps. After performing 
in and out point operations, ScreenFlow removes the timeline in and out points.

• To delete the selected (marked) section of the timeline, without closing the gap, 
select Edit > Delete.

ScreenFlow deletes all clips between the in and out points on all tracks, leaving a 
gap on the timeline. After performing in and out point operations, ScreenFlow 
removes the timeline in and out points.

• To publish the range of clips bounded by the points, select 
File > Publish to Selected Range > Vimeo > YouTube > Google Drive > Dropbox > 
Wistia.

ScreenFlow displays the selected Publish dialog. Proceed as appropriate for the 
publisher.

See Media Export and Project Archiving for details.

• To export the range of clips bounded by the points, select File > Export Selected 
Range.

See Video Encoding.

Clips on the Timeline
You can trim clips directly on the tracks in the ScreenFlow timeline.

Arranging and Adjusting Clips in the Timeline
• To adjust the start time of a clip relative to other clips, click and drag a clip left or 

right in a track.

• To move a clip from one track to another, click and drag the clip.

Splitting a Clip in the Timeline
To split a clip into two smaller clips, position the scrubber between the frames where 
you want the split to occur,. Then press the T key or select Edit > Split.

ScreenFlow splits the selected clip at the scrubber. Then, ScreenFlow selects the 
newly-created clip to the left of the split.

Note: Press Shift-T to split the clip and have ScreenFlow select the clip on the right.
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Trimming a Clip in the Timeline
• To trim the front of a clip to the location of the scrubber, select the clip. Place the 

scrubber at the time when you want the clip to begin. Then, press the W key or 
select Clip > Trim Front to Scrubber.

This trims the beginning of the clip up to the scrubber, changing the clip start time.

• To trim the end of the clip to the scrubber, select the clip. Place the scrubber at the 
time where you want the clip to end. Then press the E key or select 
Clip > Trim End to Scrubber.

This trims the end of the clip back to the location of the scrubber., changing the 
end time.

• To trim either end of a clip, grab the desired end of the clip and drag it inward 
towards the center of the clip.

• To restore frames in a previously-trimmed clip, grab the desired end of the clip and 
drag it outward from the center of the clip.

Note: Trimming changes the amount of time the clip plays; it doesn’t modify the 
referenced media file.

Giving a Clip a Custom Name
To give a clip a custom name, do the following:

1. Double-click the clip on the timeline.

2. Enter a custom name for the clip.

ScreenFlow renames the clip in the timeline, but doesn’t rename its referenced 
media files in the media library.

Deleting Clips Between Timeline Markers
To delete all assets between two markers from the timeline, do the following:

1. Mark In and Out points on your timeline.

2. Select Delete to remove all assets from the timeline between the In and Out points:

Note: To shift clips left to fill the hole created by the deletion, use Ripple Delete 
(Command-backspace), the scrubber handle, or right-click (Control-click) in the empty 
space and select Close Gap.

Adding a Clip Marker
Clip markers remain on their clips even when you move the clips.Timeline markers 
remain at their locations on the timeline, regardless of changing clip locations.

To add a clip marker, do the following:

1. Select a clip and make sure the scrubber is within the bounds of the clip.
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2. Select Mark > Markers > Add to Clip.

3. When ScreenFlow displays the popup dialog box, enter a name for your marker, 
and click Create.

You can create the marker without a name. Clicking away from the popup cancels 
the Add To Clip operation.

ScreenFlow places the marker at the bottom of the parent clip.

4. (Optional) To reposition the marker, drag and drop it.

5. (Optional) To change the name of the marker, double-click it. Enter a new name 
into the marker popup.

6. (Optional) To view all markers, select Window > Markers.

ScreenFlow displays a list of all markers.

Note: You can convert clip markers to chapter markers for YouTube or QuickTime 
exports. 

See Adding Clip Markers While Recording and Mark Menu.

Changing Clip Play Speed
You can change the play speed of individual clips on the timeline.

To change the play speed of a clip, do one of the following:

• Press and hold the Option key and move your cursor to the edge of the clip. The 
cursor displays a clock icon indicating that you are changing the clip speed. Move 
the edge of the clip inward to speed the clip up and outward to slow the clip down. 

• Click on the gear icon. Select Show Clip Inspector, and do one of the following:

– Use the slider or manually enter a percentage value.

– Change the duration to change the speed. Short is faster, longer is slower.

– To play the clip backwards, check Play Clip in Reverse.

– To prevent editing of the clip, check Locked.

ScreenFlow marks the clip with a speed badge—a turtle or rabbit icon—to indicate 
that the clip speed was decreased or increased.

Grouping and Un-grouping Clips
You can group a set of clips together to link them to one another in their current order. 
You can move a group in a single operation.

Note: Since they are on the same timecode, grouping a screencast clip with a 
corresponding iSight clip makes it easy to keep the two in sync.

Do one of the following:
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• To group a set of clips together, select the clips you want to group, and select 
Edit > Group or press Command-G.

• To ungroup a group of clips, select the group, then select Edit > Ungroup or press 
Command-U.

Note: ScreenFlow also supports nesting of clips to reduce timeline complexity. For 
details, see Nested Clips.

Nested Clips
After you add many clips to the timeline, it could become hard to manage. A solution: 
create nested clips for complex clip sequences.

You can merge a sequence of multiple clips into a single, nested clip. This reduces the 
visual complexity of the high-level timeline.

You can do any of the following with clip nesting:

• Display the contents of each nested clip on its own tab in the timeline. 

• Re-use nested clips in various tracks and timelines.

• Edit a nested clip, thereby changing to the whole set of nested clips as a unit.

• Nest clips recursively. That is, you can nest a sub-set of the clips already in a nested 
clip.

• Nest one nested clip inside another nested clip.

• Create a nested clip from an existing nested clip and another clip.

Creating a Nested Clip
1. To nest a set of clips, select the clips you want in the set and do one of the 

following:

• Select Edit > Nest Clips.

• Click the gear icon  on one of the clips and select Nest Clips (Option-Control-N).

• Control (right)-click one of the clips and select Nest Clips (Option-Command-N).

ScreenFlow replaces the set of nested clips with a single clip the length of the now-
nested clips on the timeline. Also, ScreenFlow opens a new timeline tab displaying 
the nested clip.

ScreenFlow supports up to ten levels of nesting.

Un-nesting a Nested Clip
To un-nest a nested clip, do the following:

1. Select the nested clip.

2. Select Edit > Unnest Clips.
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Viewing and Editing Nested Clips
To display the clips inside of a nested clip, double-click the nested clip in the Timeline 
tab.

To display the tab bar, select View > Show Tab Bar. (Uncheck it to hide it again). The tab 
bar displays the Timeline tab at the far left. The Timeline tab displays the entire view of 
the timeline, including nested clips in relation to all other clips.

Additional tabs display the name of each nested clip in the Timeline tab. To change it, 
double-click on the name in the clip and rename it. The name on the tab automatically 
updates when you change the master clip’s name.

To display the clips inside a given nested clip, select the tab for that clip. ScreenFlow 
hides the Timeline tab contents, and uses the entire window to display all of the clips 
that comprise the nested clip. ScreenFlow opens the nested clip and displays all of its 
contents on the timeline.

To view the big picture of your timeline, you can click the Timeline tab at any time.

Nesting also provides another benefit: You can apply video filters and actions such as 
color correction or effect filtering to a nested clip. These changes apply to all clips 
inside the nested clip.

You can organize nested-clip tabs to suit the needs of your document. For example, you 
might display nested clip tabs in the same order in which the nested clips appear in the 
timeline. Alternatively, you could display nested clip tabs alphabetically. To move a tab, 
click and drag it to its new location.

When you delete a nested clip, all clips inside are deleted, and its tab is automatically 
removed from the timeline as well.

Keep in mind that after you have trimmed a video, the untrimmed portion displays with 
diagonal lines.

Locking Clips
To prevent a clip from modification, lock the clip so that it can’t be altered in any way on 
the timeline. When you lock a clip, it appears dim and can’t be modified or moved.

To lock a clip, select it and use one of these methods:

• Select Arrange > Lock Clip.

• Click the gear icon  on the clip and select Show Clip Inspector, then check Locked 
or select Lock Clip (Option-Command-L).

To unlock the clip, select it and select Arrange > Unlock Clip or display the gear menu 
and select Show Clip Inspector or select Unlock Clip (Option-Command-L).

Creating Rolling Edits
The rolling edit feature is enabled when two clips are connected to each other with no 
gap between them. To create a rolling edit, do the following:
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1. Move the mouse over the seam of the two clips.

The rolling edit icon appears at the top of the clips.

2. To activate rolling edit mode, click on this icon.

3. To alter the duration of the clip on the left, and alter the in-point and duration of 
the clip on the right, move the mouse left and right.

Note: When the clips have a potentially infinite duration (text or still image clips), the 
only limit on the operation is that no clip can shrink smaller than a single frame. When 
the clips have a finite duration (recorded clips), the clips cannot be resized past the 
amount of content available.

Creating a Freeze Frame
To create a freeze frame, do the following:

1. Select the desired clip and move the scrubber to the frame you want to freeze.

2. Select Clip > Add Freeze Frame to create a still image of the current frame of video.

This command splits the video into two clips, and adds a two-second freeze frame 
clip between the two split clips.

3. (Optional) Modify the duration of the freeze frame by expanding or contracting the 
freeze frame clip.

See Clips on the Timeline.

See also How Transitions Affect Clips and Layers.

Adding Transitions
To add a transition, select a clip and do one of the following:

• Select Clip > Add Starting Transition to add a transition to the front of the clip.

• Select Clip > Add Ending Transition to add a transition to the end of the clip.

• Select Clip > Add Starting & Ending Transition to add a transition to both ends.

You can also create transitions between two clips by dragging one clip over an adjacent 
clip. The section where the two clips overlap is the transition.

See The Transitions Inspection Window.

Rolling edit icon

https://telestream.secure.force.com/kb/articles/Knowledge_Article/ScreenFlow-7-How-Transitions-Effect-Clips-and-Layers/?l=en_US&c=Product%3AScreenFlow%2CArticle_Type%3AFAQ%2CCategory%3AGeneral&fs=Search&pn=1
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Configuring Video Transitions
To configure a transition, do the following:

1. Double-click the Transition icon in the clip.

Figure 1. Transition Icon in Timeline Window

ScreenFlow displays the Transitions Inspector.

See The Transitions Inspection Window.

2. Click a transition icon to choose one of the transition types.

ScreenFlow displays a notice for transitions that are not configurable.

3. Click on a transition icon to see a demonstration of the transition action.

The transition keeps performing until you move the cursor off the icon.

4. Configure the transition properties (width, height, color, angle, opacity, etc.) using 
the controls displayed on the right side of the Transition Inspector window.

5. Click the Preview button to preview the transition in your clip on the canvas.

You can also set the transition duration value in seconds in the duration field at the 
bottom of the Transition Inspector window.

6. Show the Transition Groups area by clicking the arrow in the bottom left corner of 
the window. (Click it again to hide them).

7. Click All to display all available transitions.

When you hover over a transition a star appears.

8. Click the star to add the transition to the list of favorites.

9. To remove a transition from your list of favorites, click the star again.

10. Click Favorites to display a list of your most used transitions.

11. Click Built-in macOS to display transitions that are built into the operating system.

Configuring Audio Transitions
Audio transitions are applied to audio clips in the same manner as video transitions. 
However, since there is no visual media in an audio clip, there is one transition—a 
volume transition, which is automatically applied.

Audio transitions have no user-settable properties. Starting and ending audio 
transitions fade in and fade out. Overlapping transitions fade from one clip to the 
succeeding clip simultaneously.

Transition icon.
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Labels
ScreenFlow enables you to color code clips in the timeline for quick navigation and 
labeling. You can create labels from the Edit menu or by right-clicking the clip. One or 
more clips need to be selected in the timeline for the Label menu item to be enabled.

When the Label menu item displays, click the desired color to identify the selected clips. 
Click X to remove the color label from the clip(s). There are four colors available for 
labeling.

Adding Snapback Action
Snapback actions are available for each of the three types of override actions: Video, 
Audio, and Screen Recording. They behave like any other type of action. For example, 
you cannot have two video (or video Snapback) actions occupying the same time 
period. A snapback action will restore the state from before the previous action was 
executed.

To add a Snapback Action, select Actions > Add Snapback Action, and select Video, 
Audio, or Screen Recording.

In the example below, the values are restored from the clip itself, since there is no 
action behind the Video action.

In this example, the Video Snapback reverses the previous action.

You can’t add a Snapback Action if there is no action to snapback to. If you try to add a 
snapback action, ScreenFlow displays a warning.

Adding a Video or Audio Filter
ScreenFlow provides a vast array of filters. These add effects to video, still images, and 
audio.

To add a filter to one or more clips, follow these steps:
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1. Select the video or audio clip that you want to add the filter to.

2. Select the Video or Audio properties tab, as appropriate.

3. Next to the Filters and Effects heading in the Video tab, or next to the Audio Filters 
heading in the Audio tab, click the (+) button.

ScreenFlow displays the list of available filters.

4. Scroll through the list of filters. Alternatively, in the Audio tab, enter a filter name 
into the Search field and press Enter.

5. Select a filter, and click Add to add it to the filter list for the selected clip.

Note: If a manufacturer's audio unit plug-in does not work in a “sandbox” 
environment, it will not work in the Mac App Store version of ScreenFlow. Contact the 
manufacturer of the audio plugin directly for information on plugin sandbox support.

See Video Filters and Effects, The ScreenFlow User Interface, and The Properties Window.

Adding a Lookup Table (LUT) Video Color Filter
You can apply third-party video color filters supplied in CUBE-format lookup tables 
(LUTs).

To add an LUT video color filter to one or more clips, do the following:

1. Select the video clip you want to add the filter to.

2. Select the Video properties tab.

3. Next to the Filters and Effects heading in the Video tab, click the (+) button.

ScreenFlow displays the list of available video filters.

4. Click the Import... button.

ScreenFlow opens a file browser.

5. Browse to the CUBE lookup-table file containing the desired filter. Select the CUBE 
lookup table desired, and click Open.

6. Select the filter desired, and click Add.

ScreenFlow adds the LUT color filter to the filter list for the selected clip, and adds 
the CUBE file to the list of available color filters.

7. (Optional) To adjust the settings of the LUT filter, in the Video properties tab under 
Filters & Effects, check the box for Color Effects, select a style from the Style drop-
down menu, and drag the Intensity slider to adjust the intensity of the LUT color 
effect.

Removing a Filter
To remove a filter that has been added to a clip, follow these steps:

1. Select the clip that you want to remove the filter from.

2. Select the Video or Audio properties tab, as appropriate.



https://vimeo.com/560931223
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3. To display the filters, click the Filters & Effects triangle on the Video properties tab, or 
click the Audio Filters triangle on the Audio properties tab.

4. Scroll through the list of filters on the clip until you find the one you want to delete. 

5. Select the filter, and click the Filter Delete (x) button.

ScreenFlow deletes the filter from the clip.

Note: You can disable a filter temporarily, by unchecking its name.

Re-ordering Filters
A filter has different effects, depending on where it is stacked in relation to any other 
active filters. Filters are applied in list order, from top to the bottom, of the list of filters 
on the clip.

To set the order in which ScreenFlow applies the filters, do the following:

1. Select the clip that has the filters you want to re-order.

2. Select the Video or Audio properties tab, as appropriate.

3. To display the filters, click the Filters & Effects triangle on the Video properties tab, or 
click the Audio Filters triangle on the Audio properties tab.

4. Scroll through the filters to identify the one you want to re-arrange.

5. Click on the grab icon just to the left of the checkbox by its name.

6. Drag the filter up or down the list to re-order its application in relation to other 
filters in the list.

Configuring a Filter
Video filters that have a visual position coordinate display a cross-hairs button which 
allows you to adjust the position on the canvas. The label of the parameter you are 
editing also appears on the canvas when adjusting the position.

When multiple clips are selected, ScreenFlow attempts to display the list of filters in the 
Video Properties tab where the filters have similar settings. For example, if two clips have 
two identical filters in the same order, ScreenFlow will display the two filters regardless 
of whether any of the individual parameters are the same. However, if the two clips 
have the same filters but in different order, ScreenFlow displays a Multiple Filters 
message.

Note: Filter processing is CPU-intensive. Expect export and publishing times to 
increase with the number of filters enabled.

After you configure a filter, you can test it out by playing the video.

To configure a filter, follow these steps:

1. Select the clip that has the filter you want to configure.
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2. Select the Video or Audio properties tab, as appropriate.

3. To display the filters, click the Filters & Effects triangle on the Video properties tab, or 
click the Audio Filters triangle on the Audio properties tab.

4. Scroll through the filters to locate the one you want to configure.

5. Adjust the controls as necessary.

Removing a Filter Background
You can remove a background from a ScreenFlow effect or from imported camera 
video.

Note: You can’t remove backgrounds from screen recordings, which don’t have 
ScreenFlow filters. Filters are not visible when screen recordings are selected.

To remove a background from an effect, do the following:

1. Select a video clip on the timeline, and navigate to 
View > Switch to Inspector > Video > Filters & Effects.

2. Click the Add button (+), select Background Removal, and click Add.

ScreenFlow removes the background from the selected clip.

The Chroma Key Filter
The chroma key video filter creates transparency in a selected clip, based on a unique 
color. ScreenFlow makes all pixels of the key color transparent. Clips in tracks lower 
than the chroma key clip show through the transparent areas of the chroma key clip.

For example, if you chroma-key a shot of a weatherman standing in front of a green 
screen, you can make a shot of a weather map appear in the green areas.

Figure 2. Typical Chroma Key Filter Application

Green and blue are the two most commonly used colors for chroma keying because 
people don’t have much green or blue in their skin or hair color. However, for special 
purposes, you can key on colors other than green or blue.

For best results, light the background screen brightly and evenly, and make sure the 
talent isn’t wearing anything that matches the background screen.

Original clip Green color keyed out Background - 2nd track Final composite clip
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Chroma Keying a Clip
To chroma key a clip, do the following:

1. Shoot your subject against a chroma key screen.

2. Shoot your background image or clip.

3. Add these clips to your document.

4. Select a background color on the canvas for chroma key testing.

5. Add the Chroma Key filter and set it up.

See Chroma Key Filter Settings.

6. Test your clip by previewing it, and adjust chroma key settings as necessary.

See Refining the Chroma Key Filter Settings

7. If necessary, split your clips. Then, add and adjust the chroma key filter.

8. When you’re satisfied with the chroma key, add your background image or clip to 
the screencast in the track immediately below the target clip.

Chroma Key Filter Settings
Settings for the Chroma Key filter are described in the table below.

For details on adding filters, see Video Properties.

Adjust the Chroma Key settings as needed. For details, see Selecting a Chroma Key Color.

Table 1. Chroma Key Filter Settings

Menu Item Description

Color Click to refine the key (to specify the color to be converted to 
transparency. See Selecting a Chroma Key Color.

White Clip Use the slider to adjust the whiteness tolerance to reduce 
white pixel transparency. Adjust the gray scale value (0 to 
255) to the right, until the entire background is transparent.

In a source with lots of very bright white, the background may 
bleed through the white part of the image. To avoid this, 
adjust the White Clip value.

Tolerance Use the slider to specify how far from the chroma key color is 
considered background. Adjust to remove more or less of the 
background color without affecting the foreground image. 

Angle Use the slider to specify the angle around the chosen color. 

The amount of color varies, depending on how far from the 
center of the color space the selected color is. 
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Selecting a Chroma Key Color
It ‘s important to choose the correct color for the chroma key. The color should match 
or closely match the background. ScreenFlow selects the color displayed in the box by 
analyzing the current frame. Sometimes this is not the best color.

To select the chroma key color, do one of the following:

• Click the desired color in the original image.

It's often best to click next to the edge of an object that is not going to be removed. 
The color near the object is often the most effective chroma key color.

• Click the Color button to open the Refine Key window in the upper right corner of 
the Canvas window.

Use the Refine Key image to refine the key as required.

When the Refine Key window is open, you can click anywhere in the clip image on 
the canvas to select a new color.

• Click directly in the Refine Key window to adjust the selected color.

The Refine Key color range displays the colors that are near (in value) to the cur-
rently selected color.

The Refine Key window does not display all colors in the image.

Refining the Chroma Key Filter Settings
You can find the most effective chroma key settings by adjusting all three parameters, 
viewing results over time, and adjusting them again. Here’s a suggested pattern of 
refinement:

1. Temporarily move your background or image clip out of the way, so that the canvas 
color can be used as a backdrop against your foreground image.

2. Next, adjust the White Key value by dragging the slider from left to right.

As the opaque area shrinks, pay close attention to the edges of the foreground 
image.

3. (Optional) If the background starts showing through, creating a shadow, drag the 
Tolerance level to the left. This eliminates the shadows around the edge.

4. Then, return to the White Key parameter and completely eliminate the opaque 
areas so that the entire background is fully transparent.

5. Switch back and forth adjusting the White Key and Tolerance sliders to strike a 
perfect balance as you scrub your clip.

6. Finally, reduce the Angle slider value to zero. Move the slider to the right until the 
background is completely transparent.

7. Scrub the clip to make sure the chroma key works well across the entire clip.

Note: Sometimes the color of a background varies over time. A clip might need 
different keys in different sections. To add different chroma keys to a clip, split the 
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source clip into several clips. Then apply a slightly different key color to each of the 
clips.

Adding and Configuring a Text Clip
To display the Text Properties tab, click the Text Properties icon in the Properties window.

See Text & Titles Properties.

To add a text clip, do the following:

1. Place the scrubber at the location where you want the clip to start. 

2. Click Add Text Box, click the gear icon  on the Text Properties tab and select Add 
Text Box, or select Insert > Text Box.

ScreenFlow adds a five-second text clip in a new, top track (which you can move 
anywhere on the timeline).

Note: To change the default duration of your Text clip, go to 
ScreenFlow > Settings > Timeline.

ScreenFlow creates a text clip with the word Text in it.

3. Select the text to edit it.

You must have at least one character in the clip, or ScreenFlow automatically 
deletes it. If you later remove all text, ScreenFlow deletes the clip automatically.

Figure 3. Sample Text Clip on Canvas (left) and Timeline (right)

4. With the text selected, adjust the text properties.

5. To reset all properties in this tab to default values, click the gear icon  and select 
Reset to Defaults. ScreenFlow applies the settings for Make Settings Default for New 
Text Clips.

For descriptions of the Text & Titles controls, see Text & Titles Properties.

Formatting Text and Titles
You can design on-screen text, determining font, color, animation, and more, with the 
controls in the Text & Titles tab of the Properties window.

To format text or titles, do the following:
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1. On the Canvas, select a text box containing text. On the Properties window, click 
the Text & Titles tab.

See The Properties Window.

2. Use the controls in the Text & Titles tab to customize the text.

For descriptions of the Text & Titles controls, see Text & Titles Properties.

Animating Text
To animate text within a text box, do the following:

1. Create a text clip.

See Adding and Configuring a Text Clip.

2. Select the text box, or a range of text within the text box.

3. On the Properties window, select the Text & Titles tab.

See The Properties Window.

4. Check the box for Build In Animation, and select the animation settings desired.

See Build In Animation checkbox in Text & Titles Properties.

5. Check the box for Build Out Animation, and select the animation settings desired.

See Build Out Animation checkbox in Text & Titles Properties.

Adding an Annotation Clip
To add an annotation clip, set the scrubber in the location where you want the clip to 
start, and click the Add icon (+). ScreenFlow adds a five-second annotation clip in a 
new, top track (which you can move anywhere on the timeline you want).

When you create an annotation clip, you must immediately add at least one object to 
the clip, or ScreenFlow will automatically delete it. As a matter of fact, if you later 
remove all annotations, ScreenFlow deletes the annotation clip automatically.

Figure 4. Sample Annotations Clip on Canvas (left) and Timeline (right)

Adding and Configuring Annotation Items
To add annotation items to an annotation clip, follow these steps.

1. Select the clip to which you wish to add an Annotation.

2. Choose the Annotations Property tab.

3. Choose an Annotation Object from Tool Palette.

4. Adjust object on canvas to desired effect.
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While selected, you can adjust the item’s properties.

Note: Notice that as you are drawing, the timeline loses focus and darkens. Drawing is 
a modal operation: When you’re done drawing and configuring objects, you must click 
on the timeline to continue working on the canvas or timeline. 

To save these settings for new annotations clips you may add in the future, click the 
gear icon  and select Make Settings Default.

See Annotations Properties.

Table 2. Annotations Properties Controls

Control Description

Shapes Choose from the types of annotations in the tool bar: 

• Line (arrow)

• Line

• Square (filled)

• Square

• Circle

Color Click to select the color of the annotation.

Opacity Use the slider (or enter the percentage value manually) to set 
the opacity of the selected object.

Thickness Use the slider or manually enter the value to specify the 
thickness (in pixels) of annotation lines (range: 2 to 350). 
Default: 55.

Shadow Check to create a shadow on objects in the annotation. Use 
the slider or manually enter the value (in pixels) to specify the 
opacity of the shadow (range: 1 to 60). Default: 25. The value 
creates a gradual loss in opacity as the shadow spreads from 
the center.

Outline Check to create an outline around objects in the annotation. 
Use the slider to specify the thickness of the outline.

Color Click to select the color of the outline.

Endpoints Select a shape to affix to the end of a line segment. The first 
and second field represent the starting and finishing point of 
the line segment, respectively.
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Adding Freehand Annotations
You can also create freehand annotations (freehand drawings accessible through the 
existing annotation’s Inspector panel). This feature enables you to draw smooth and 
accurate freehand lines and shapes, move and resize them, and change properties such 
as: color, opacity, shadow, and outline.

To add a new Freehand Annotation, click the Freehand button on the Annotations tab, 
then click the Add button (+) to place a freehand Annotation in the timeline.

Freehand annotations are stored as Bezier Curves, which are generated from a list of 
mouse points. Freehand annotations are drawn like any other annotation type. Lines 
are created by dragging the mouse along the canvas to draw lines.

One difference between Freehand Annotations and other annotation types is that 
Freehand Annotations are not automatically selected when the mouse is released from 
drawing. This prevents you from having to deselect a drawing each time you want to 
create a new one. Another difference is that in order to select a Freehand Annotation, 
you are required to hold down the Command Key. This is to prevent users from 
selecting other freehand annotations while drawing.

Adding Freehand Callouts to Images
You can highlight freehand areas directly on images, using either a circular paint brush 
or a rectangle tool. You can use freehand callouts to blur out sensitive data or create a 
highlighted box around the content you are discussing, for example.

To create a freehand callout, follow these steps:

1. Set the location of the scrubber.

2. Select an image on your canvas.

3. Click the Callout Properties tab, click the + Action button, and click Freehand. 
(Because you’re working on an image, Freehand is the only callout option.)

4. When ScreenFlow displays the tool palette in the upper right corner of the canvas, 
select either the brush or the rectangle tool. If you select the brush, you can set the 
size of the brush.

Figure 5. Freehand Callout Tool Palette

5. Draw the highlighted region on your selected image using your mouse. To 
brush-on a highlighted area, select the brush tool, set the brush size, then click and 
drag the mouse to define an area. To create a rectangle highlighted area, select the 
rectangle tool, then click and drag the mouse to define an area.

6. Use the callout properties to adjust the look of your callout.

Brush tool

Rectangular tool

Brush size adjust
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7. To remove a brushed-on freehand callout, select the brush tool, then hold down 
the Option key and the left mouse button while moving the mouse over the 
highlighted area to erase it. To remove a rectangle freehand callout, select the 
rectangle tool, then hold down the Option key and the left mouse button while 
moving the mouse over the highlighted area to select it. When you release the 
mouse button, the callout is removed.

Modifying Style with Style Presets
To create video style presets based on existing presets, do the following:

1.  Click the Video tab in the Properties window.

See the Properties window on the screenshot in the topic, The ScreenFlow User Inter-
face.

2. Select a video in the timeline.

3. Click the Style Presets button  at the upper-right of the tab to open the Style 
Presets window.

ScreenFlow displays the Styles Presets window.

4. Click the plus (+) button to create a new style based on the current properties of 
your video.

ScreenFlow displays the next setup window.

5. Select parameters to include in the new style preset.

6. Click the plus (+) button.

ScreenFlow displays the next setup window.

7. Rename the style preset from its default name.

8. (Optional) You can also update the preset or delete it by clicking on the gear icon to 
open a drop-down menu.

Once you have created a list of style presets, you can associate them with any video by 
selecting a video and choosing a style preset from the list.

Adding a Clip to the Media Library
To add clips to the screencast, you can drag clips from the Media Library onto your 
canvas or timeline.

To add a clip to your media library, do one of the following:

• Record a source in ScreenFlow.

ScreenFlow records a media file, creates a clip associated with the media file, and 
adds the clip to the document media library.

• Drag the media file from the Finder into the media library.

ScreenFlow creates a clip associated with the media file in the media library.
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• Drag the media file from the Finder onto the timeline.

ScreenFlow creates a clip associated with the media file in the media library, and 
adds the clip to the timeline.

• In the Media Library tab, click Add Media.

ScreenFlow displays a File System dialog. ScreenFlow creates clips in the media 
library for media files you select.

Duplicating a Media File from a Clip
To copy the media file associated with a clip to the computer file system, drag the clip 
from the Media Library out to your desktop, target folder or server.

MacOS duplicates the source media file in the new location.

Deleting a Clip from the Media Library
To delete a clip from your media library, do the following:

• Right-click the clip, and select Delete Media.

ScreenFlow deletes the clip from the Media Library. If this clip is used on the time-
line, ScreenFlow deletes the clip from the timeline as well.

Renaming a Clip in the Media Library
To rename a clip, do the following:

1. Select the clip.

2. Click on the clip name, and enter a new name.

ScreenFlow renames this clip wherever it appears on the timeline, except in those 
instances where the clip has a custom name.

Relinking a Clip to a Media File
Moving or renaming a media file breaks the link between the file and the clip in your 
ScreenFlow document. To relink the file to the clip, click the relinking button.

Previewing a Clip in the Media Library
To preview a clip before placing it on the timeline, hover the cursor over the clip. 
ScreenFlow displays a scrubber for previewing the clip before adding it to the canvas or 
timeline.

Navigating the Media Library
To display the media library, click the Media Library tab in the Properties window.

See Media Library.
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You can also view the Media Library on the left side of the ScreenFlow main window.

Finding Clips with the Media Library Filter
You can find clips by filtering the media library to show only certain types.

To select a filter, do the following:

1. Click the Filter button.

ScreenFlow opens the Filter window.

2. Click a filter to open its menu and select a type.

ScreenFlow displays all clips matching the selected type.

Finding a Clip Using Media Library Search
You can search for any text in the clip name by entering a text string in the search field. 
The list of clips changes as you type.

Adding a Clip to the Timeline
To add a clip to your timeline, do one of the following:

• Drag the clip from the Media Library to either the canvas or to the timeline.

• Double-click on the clip to add to the timeline at the scrubber location.

ScreenFlow places the selected clip at the location of the scrubber in the timeline.

Note: You can select one or more clips using lasso selection. Click and drag across 
some portion of each clip to select it.

For complete details on these and other ways to add clips to your document, see 
Editing Clips.

Deleting All Unused Media
At the completion of a project, you might have clips in a ScreenFlow document that 
you haven’t used in the timeline. These unused files make your ScreenFlow document 
unnecessarily large. To delete such orphaned media sources from the Media Library, do 
the following:

1. Click the Media Library tab.

See the Properties window in the screenshot of the ScreenFlow user interface in the 
topic, The ScreenFlow User Interface.

2. Click the gear button.

ScreenFlow opens a drop-down menu.
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3. Select Remove All Unused Media.

ScreenFlow displays a list of unused media.

4.  Click Delete to delete all the unused sources from the Media Library.

Adding Media to the Global Library
You can store media files in the global library for use in any number of ScreenFlow 
documents.

1. Select the Media Library tab in the Properties window.

See Media Library.

2. Click the globe button.

3. Do one of the following:

• Drag and drop media files into the global library panel

• Click the plus (+) button, navigate to a file and select it

Once you’ve added content to the global library through one inspector panel, the 
content appears in the global library of all ScreenFlow documents.

ScreenFlow stores global library contents here:
~/Library/Application Support/ScreenFlow/GlobalLibrary

ScreenFlow creates a hard link from the original content to the Global Library folder.

Deleting Media from the Global Library
1. To delete an item from the global library, do one of the following:

• Right-click on the file icon, and select Delete Media.

• Select the file icon and press the Delete key.

ScreenFlow warns you that other ScreenFlow documents might reference the file 
you want to delete.

2. Click Delete or cancel the operation.

When ScreenFlow deletes the item, ScreenFlow deletes the file in the global library.

Purchasing the Stock Media Library
To access the Stock Media Library, you first must purchase it. To purchase the Stock 
Media Library, do the following:

1. Select File > New.

ScreenFlow opens the New dialog.

See The New Dialog.

2. Click the Stock Media Library tab.

3. Click Buy to purchase the Stock Media Library.
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Importing a Stock Media File
You can query, filter, and preview all of the content in the Stock Media Library. However, 
to add clips from the Stock Media Library to a ScreenFlow document, you must 
purchase the Stock Media Library.

To import files from the Stock Media Library, do the following:

1. Click the Media Library tab on the inspection panel.

2. Do one of the following:

• Click the Stock Media button.

• Enter a search term into the Search field at the bottom of the Media Catalog win-
dow.

ScreenFlow populates the Stock Media Library as you enter your search term.

3. Select the stock media file desired.

4. Do one of the following:

• Right-click on any stock media icon to access its menu. From this menu, choose to 
add the stock media file to the timeline at the scrubber position, add the media to 
the Global Library, or download different format versions of the media.

Stock media video comes in these formats: HDMP4, 4KMOV, HDMOV, and 4KMP4. 
Stock media audio comes in these formats: WAV and MP3. Stock media still images 
come in these formats: PNG and JPG.

• Drag and drop the clip onto either the timeline or the canvas.

ScreenFlow creates a temporary clip in the timeline until it fully downloads the 
media file. A spinner shows the download progress. Once the download is com-
plete, ScreenFlow replaces the clip’s temporary source with the newly-downloaded 
source. If you delete the clip before the download is done, ScreenFlow cancels the 
download.

Previewing a Stock Media File
You can preview any stock media clip by scrubbing or playing the clip. To preview a 
stock media clip, select a clip, and do one of the following:

•  Move the scrubbing slider.

• Click the Play button.

Displaying and Previewing Closed Captions
You can use the ScreenFlow caption editor to add, edit, and publish ADA-compliant 
soft subtitles as caption tracks to a screencast (Figure 6).

You can include captions in MPEG-4 outputs, and in outputs for YouTube. You can 
create caption tracks in multiple languages. Also, you can export captions as SRT 
subtitle files.
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Caption clips are permanently joined to their parent clips, and are the same length as 
their parent clips. You can’t move caption clips independently. When you move, copy, 
or delete a parent clip, you move, copy, or delete the caption clip with it.

Caption clips contain one or more caption boxes, each one lasting three seconds. The 
number of boxes depends on the total duration of the parent clip. You can adjust the 
durations of the caption boxes. The caption boxes contain the text to display. Click each 
caption box independently to add text.

Note: To view closed captions in a movie player, you must enable closed caption 
viewing. Enabling closed caption viewing in players is beyond the scope of this guide.

Figure 6. Screencast with Closed Captions

Closed caption text is rendered on-screen in white, sans-serif type, centered at the 
bottom of the screen.

To display closed captions on the canvas, select View > Show Captions. As you scrub or 
preview the screencast, ScreenFlow displays closed captions on the canvas along with 
all other visual elements in the screencast.

Adjusting Video to Accommodate Caption Text
To provide a suitable background on which to display caption text clearly, use black or 
another dark background color, and consider using one of the following techniques:

• Shorten the computer video frame vertically to create an empty rectangle at the 
bottom. (This creates a minor distortion in the image.)

Captions are rendered on the 
frame from the text you enter 
in caption clips.
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Figure 7. Shortening Video Frame Up for Captions

• Crop the computer video frame upward (Figure 8)—preserving the application 
window, but hiding the dock bar at the bottom. (This doesn’t distort the image.)

Figure 8. Cropping Video Frame for Captions

• Reduce the frame proportionally (Figure 9), positioning it at the top center of the 
canvas.

You can leave the canvas as-is—with pillars on each side of the frame—or shorten 
the canvas horizontally to eliminate the pillars.

Shorten video frame 
upward to create space for 
closed caption text.

Crop bottom of video 
frame to create space for 
closed caption text.
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Figure 9. Shrinking Video Frame for Captions

Viewing Closed Captions
To view closed captions, select View > Show Captions Track.

ScreenFlow displays the caption track at the top of the timeline. Each clip on the 
timeline with an audio track has a corresponding caption clip. ScreenFlow can show 
only one caption track at a time.

If there is more than one audio clip in the screencast at the same time (for example, a 
voice-over and a music bed), ScreenFlow displays the audio clip on the highest track.

Navigating Caption Boxes
To move between caption boxes, do one of the following:

• Press the left and right arrows in the caption playback controls.

• Press the tab key to advance to the next box and use Shift-tab to go to the previous 
box.

The scrubber jumps to the beginning of the next (or previous) box, and displays its 
text, so you can add or edit it.

Note: When transitioning to the next caption, captions with a duration of 0.9 seconds 
or shorter get skipped over. Transitioning jumps only to captions that are one second 
or longer in duration.

Editing Caption Text
To edit text in a clip’s caption box, do the following:

1. Click the target box.

ScreenFlow displays the caption editor, where you can enter text and test it for 
appropriate time length, adjusting the length as necessary.

Reduce video frame to 
create space for closed 
caption text.

Leave pillars or reduce 
canvas size horizontally to 
remove them.
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2. (Optional) To display closed caption text on multiple lines, press Enter to add line 
returns.

Changing Caption Display Time
Do one of the following:

• To lengthen the display time of a caption box, press Command-up arrow.

• To reduce the display time of a caption box, press Command-down arrow.

You can also change the time in the caption editor.

Deleting All Text from Captions
To delete all of the text in all captions, do the following:

1. Control-click a caption box.

2. Do one of the following:

• Select Clear All Captions

• Select Edit > Captions > Clear All Captions.

Setting the Caption Language
To set the caption language, do the following:

1. Control-click on the caption box.

2. Do one of the following:

• Select Set Language

• Select Edit > Captions > Set Language.

3. Select the language you want to display captions in.

Generating Closed Captions
You can generate closed captions when exporting or publishing in these formats:

• Export the screencast as an MP4 (H.264 video) file. Select the Web-High or Web-
Low preset or any Apple device preset, or a customized derivative. You’ll need to 
check Add Captions Track on the export window.

For details, see Video Encoding.

• Publish the screencast to YouTube. You’ll need to check Add Captions Track on the 
export window.

For details, see Publishing to Video Hosts.

• Export with burned-in captions. To do this, check the Burn In Captions checkbox, 
under Options in the Export window.
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Exporting Closed Captions as SRT Subtitles
To export your closed captions into an SRT subtitle file, do the following:

1. Control-click on the timeline.

2. Select Export to SRT or Edit > Captions > Export to SRT.

ScreenFlow displays a Save As dialog.

3. Name the file, select a location, and save the file.

Importing Closed Captions as SRT Subtitles
To Import an SRT file, do the following:

1. Select Edit > Captions > Import from SRT.

2. Pick the SRT file you wish to import.

3. In the file dialog window, select the language of the caption file.

ScreenFlow parses the imported SRT file and generates captions for each entry. If there 
are any existing captions for the imported language, ScreenFlow clears them before the 
import. The import always overwrites any existing captions and does not merge them.

If there are any gaps in time between captions in the imported SRT file, ScreenFlow 
inserts spacer captions to keep the captions in sync. ScreenFlow imports the captions 
into the first audio clip on the timeline. If the captions are longer than the clip, 
ScreenFlow doesn’t split them onto other audio clips.

Adjusting Recorded App Audio
If you have configured ScreenFlow to record computer audio, the Audio Properties tab 
displays controls for Recorded App Audio. You can set volume levels for each app 
individually using these controls. To set app volume levels, do the following:

1. Check the box near the name of each app you want to control.

2. To set the volume of an app, drag and drop the slider for the app to the desired 
level.

See Audio Properties.

Reducing Background Audio Volume (“Ducking”)
To enable ScreenFlow to automatically reduce the volume of background audio under 
narration (ducking), do the following:

1. In the Properties window, select Audio Properties.

2. Check the box for Ducking.

3. Select narration clip(s).

ScreenFlow highlights narration clips with a yellow border.

4. Select the Audio Inspector tab in the properties inspector.
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5. Select Ducking.

6. Adjust the percentage slider to desired level of ducking.

See Audio Properties.

Adding Narration
You can add a narration to an existing recording. To add a narration, do the following:

1. Select Insert > Narration.

ScreenFlow displays the settings window.

2. Select an audio device.

3. (Optional) To set a recording duration, check the End After checkbox, and enter a 
time in seconds.

4. (Optional) To hear the audio already in your document, uncheck Mute Audio During 
Narration.

Note: The Mute Audio Playing During Narration box is checked by default to prevent 
feedback while adding narrations.

5. To start recording your narration, click the Record button.

ScreenFlow displays a count-down window to let you know when to begin your 
narration, and displays a progress bar on the timeline.

6. Click the Stop button when you finish your narrative.

If you selected the End After option, as the finish time approaches, an ending 
countdown appears on the screen. When the recording ends manually or automat-
ically, ScreenFlow adds the narration to the document.

7. Save the recording or discard it.
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Media Export and Project 
Archiving

You can use ScreenFlow to export your video to a standard video file, to upload your 
video to a video hosting service, and to archive your screencast project.

Topics
■ Video Encoding

■ Video Publishing

■ Exporting Batches

■ Archiving a ScreenFlow Project

Video Encoding
When you’re done editing your project, you encode it: you convert it to a standard video 
format for publication and distribution.

ScreenFlow provides two methods of encoding:

• Export a standard video file. Then distribute or publish the file.

• Publish a video file directly to an online video service such as Vimeo, YouTube, Goo-
gle Drive, Dropbox, Wistia, Box, or Imgur. ScreenFlow converts the project to the 
appropriate video format as part of the publication process.

Note: If you have in and out points set in your project, the menu item displays Export 
Selected Range. ScreenFlow exports the media between the in and out points.

See Publish To.

Exporting Video

Note: Apple has deprecated QuickTime in favor of AVFoundation. ScreenFlow export 
options using the QuickTime APIs have been removed.


https://vimeo.com/227463940
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To export your video, do the following:

1. Select File > Export.

ScreenFlow opens the Export Settings dialog.

See The New Recording Pane of the New Dialog.

2. Configure your export settings.

3. Click Export to begin encoding the project into a video file.

ScreenFlow displays a progress dialog.

When exporting a ScreenFlow project, ScreenFlow displays an export-progress overlay. 
This allows you to minimize the application during export, while still monitoring the 
time remaining.

Note: ScreenFlow displays an alert if you try to select a drive formatted with FAT 16 or 
FAT 32.

Note: If you export your video from an unlicensed version of ScreenFlow, ScreenFlow 
watermarks your exported video.

See The New Recording Pane of the New Dialog.

Customizing Animated GIF or Animated PNG Outputs
To customize Animated GIF or Animated PNG outputs, do the following:

1. Select File > Export.

ScreenFlow opens the Export Settings dialog.

See The New Recording Pane of the New Dialog.

2. Click the Manual button.

3. In the Preset drop-down menu, select Animated GIF or Animated PNG.

4.  Click the Customize button.

ScreenFlow displays the customization dialog for animated GIF or animated PNG.

See Customization Dialog for Animated GIF or Animated PNG.

5. Select the desired values for the fields in the customization dialog.

6. Click OK.

Customizing H.264/AAC (MPEG-4) Codec Settings
To customize settings for Web-High, Web-Low, Lossless - ProRes with Alpha, or iOS App 
Preview, do the following:
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1. Select File > Export.

ScreenFlow opens the Export Settings dialog.

See The New Recording Pane of the New Dialog.

2. Click the Manual button.

3. In the Preset drop-down menu, select Web-High, Web-Low, Lossless - ProRes with 
Alpha, or iOS App Preview.

4.  Click the Customize button.

ScreenFlow displays the customization dialog.

See Customization Dialog for H.264/AAC (MPEG-4).

5. Select the desired values for the fields in the customization dialog.

6. Click OK.

Managing Export Presets
To manage export presets, do the following:

1. Select File > Export.

ScreenFlow opens the Export Settings dialog.

See The New Recording Pane of the New Dialog.

2. Click the Manual button.

3. Click the Manage button.

ScreenFlow displays the preset management dialog.

4. Check the box to the left of the preset to show it in the Preset list. Uncheck it to hide 
it.

5. Click the Copy button to the right of the preset to generate a copy of the preset so 
that you can modify it.

ScreenFlow displays custom presets in the list at the bottom of the window.

6. To change the custom preset name, double-click the name. Click the Edit button to 
customize your preset.

7. To create a new Custom Preset, select an existing preset in the list, then click the Plus 
(+) button.

8. Once you’ve created the new Preset, click the Edit button to edit it. Click the Minus (-
) button to delete it.

9. Click OK.

Video File Size Considerations
Video files often become very large, making them difficult to send to others, download, 
or post to servers via the Internet.
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The resolution of video clips in your project typically is higher than the resolution of the 
video file you need to export. For example, your original screen resolution might be 
1280 x 800 pixels, but you might need an output video file of only 640 x 400 resolution.

See ScreenFlow: Estimate Exported File Size.

Reducing Video File Size
To preserve the aspect ratio of your project, use the Scale by Dimensions option as 
opposed to Scale to a custom size. For general purposes, you may want to scale by 50%.

Reducing the Frame Rate
ATSC video standard frame rates are either 30 fps or 60 fps. You can reduce the size of 
the output video by reducing the frame rate. If you reduce the frame rate below 24 fps, 
motion in the video will appear less smooth.

You can experiment with codec settings to determine the frame size and frame rate 
works best for your project. Find out if your target platform or audience requires certain 
frame sizes and frame rates.

Estimated Export Time
When exporting, ScreenFlow displays the estimated time needed for encoding at the 
bottom of the screen. The accuracy of this estimate depends on many factors in the file 
being exported, and the estimate might change over time.

Video Publishing
You can publish videos from ScreenFlow to various video-hosting platforms. 
ScreenFlow encodes videos correctly for each platform, and uploads them to the 
platforms.

Note: If you check Save Copy to Disk the Location button is enabled, enabling you to 
select the location for the file to be written to disk. If you do not choose a location, the 
file will be saved to your Movies folder. If you do not specify a file extension, 
ScreenFlow uses MP4.

Publishing to Video Hosts
To publish your video to a video-hosting platform, do the following:

1. Select File > Publish to, and select one of the video-hosting platforms from the 
menu.

ScreenFlow opens the Publish to dialog for the platform chosen.

2. Configure the settings for the platform chosen.

See The “Publish to” Dialogs.


https://support.telestream.net/s/article/ScreenFlow-7-Estimate-Exported-File-Size

https://support.telestream.net/s/article/ScreenFlow-7-Estimate-Exported-File-Size
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3. Click Sign In.

ScreenFlow displays a Log In window.

4. Enter your email and password. Then click Log In.

The target platform displays the Publish To [platform] window.

5. Click Publish when finished.

The target platform returns the URL for uploads when it has completed the upload.

When exporting a ScreenFlow project, ScreenFlow displays an export-progress 
overlay. This allows you to minimize the application during export, while still moni-
toring the time remaining. Also, ScreenFlow displays an Upload Manager button 
(upward-pointing arrow) under the canvas.

Note: ScreenFlow displays an alert if you try to select a drive formatted with FAT 16 or 
FAT 32.

Note: If you are using an unlicensed version of ScreenFlow your exported video will 
be watermarked.

6. To display details of the upload, click the Upload Manager button.

Note: ScreenFlow displays any upload errors in the Upload Manager window. Click 
the yellow warning triangle to display more information about the error.

7. To view the uploaded video on the video host, click the Upload Manager button.

8. To clear the completed uploads from the list, click the Clear button.

Exporting Batches
ScreenFlow Batch Export encodes batches of ScreenFlow documents into formats you 
specify. This is quicker than encoding documents individually.

To export a batch of files, do the following:

1. Select File > Batch Export.

This opens the Batch Export dialog.

See File Menu.

2. Click the plus (+) button located in the bottom left corner of the dialog, or drag and 
drop documents onto the Documents pane.

ScreenFlow loads the documents into the batch queue. The documents list displays 
an icon, the document name, and the duration for each document.
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3. In the Output Folder field, click Choose. Choose a folder for the exported files.

The default folder is the Movies directory.

4. Select a preset from the Preset menu.

5. (Optional) Customize the preset by clicking Customize.

6. To manage the arrangement of the list of presets, click Manage. 

7. Select desired options by checking their boxes.

The export settings are the same ones displayed in the Export Settings dialog.

See The New Recording Pane of the New Dialog.

8. Click Begin.

ScreenFlow encodes the documents according to the settings chosen, and saves 
the exported files to the chosen output folder.

In a batch export, ScreenFlow applies the settings across the entire batch. You can’t 
configure batch export settings on an individual document.

Once ScreenFlow starts the batch processing, ScreenFlow dims the options and dis-
plays a progress bar for each document. ScreenFlow also displays a progress bar at 
the bottom right of the Batch Export dialog, showing the progress of the whole 
batch.

9. (Optional) Click the Cancel button to stop the processing.

Note: By default, if you quit ScreenFlow with the Batch Export window open, when 
the application reopens, ScreenFlow doesn’t reload the documents. To have 
ScreenFlow reload the documents by default, go to the Mac System General 
Preferences. Check the box for Close windows when quitting an application.

Archiving a ScreenFlow Project
You can archive a ScreenFlow project upon completion. ScreenFlow truncates screen 
recordings to the sections of the recordings used in the timeline, and saves the project 
in a ScreenFlow file. To archive a project, do the following:

1. Navigate to File > Archive.

2. In the Save As field, enter a filename for the archived project.

3. In the Where field, select a location from the drop-down menu.

4. Click Save.

ScreenFlow removes unused content from the project and saves the project in a file 
with the extension SCREENFLOW.

See Archive Storage.



https://vimeo.com/564309893
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Windows in ScreenFlow

You can control most of the features of ScreenFlow through the ScreenFlow user 
interface.

Topics
■ The ScreenFlow User Interface

■ The Editor Window

■ The Timeline Window

■ The Clip Editor

■ The Properties Window

The ScreenFlow User Interface
You create ScreenFlow documents through the ScreenFlow user interface. You can add 
media, text, actions, and other effects. You can arrange elements spatially and 
temporally in your screencast. You can configure elements to behave just the way you 
want. Also, you can preview your screencast and adjust the results.

You can arrange screencast elements spatially and temporally. You can configure the 
display and behavior of each element. You can also preview and modify your 
screencast.
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Figure 1. ScreenFlow User Interface Overview

Each ScreenFlow document is stored in a ScreenFlow document file. You can open 
several ScreenFlow documents to work on them simultaneously.

Note: To create a new, untitled ScreenFlow document for a new screencast, see 
Creating a Document.

The user interface contains the Editor window, the Timeline, and the Properties window.

You can resize the Canvas and Timeline windows by clicking and dragging the toolbar 
up or down. Click anywhere in the region of the toolbar directly below the toolbar icons 
(and above the timeline) and drag the toolbar up or down to resize the windows.

All windows work together to help you create, edit, and preview your screencast.

The Timeline 
Window

Canvas Button

Playback 
Controls

The Properties 
Window

Audio 
Meters

Timeline 
magnification 
slider Timecode Display

Scrubber

Tools 
Menu

The Editor Window

The Canvas Window

Track 
controls

Open/Close Clip Editor

Editor Drop-Down Menu Button
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The Editor Window
The Editor window is a spatial representation of the visual clips of your screencast (and 
their properties, actions, etc.), based on the position of the scrubber on the timeline. At 
any given point in time, elements in a screencast might be entirely or partially visible in 
the frame, or off-screen entirely. You use the Editor window to arrange, resize and 
configure these elements.

It displays several tools you’ll use to configure your canvas, preview your video, and 
monitor your audio, as described below, in Table 1.

Canvas Button

Playback Controls
Audio Meter

<headphone icon>

Open/Close Clip Editor

Timecode Display

Editor Drop-Down Menu Button
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See Editor Drop-Down Menu and Customizable Toolbar.

Table 1. The Editor Window

Control Description

Open/Close Clip 
Editor

When clicked, ScreenFlow opens or closes the Clip Editor 
window.

Editor Drop-Down 
Menu Button 

When clicked, ScreenFlow opens or closes the Editor Drop-
down menu.
See Editor Drop-Down Menu.

Canvas Button Click the Canvas button  (far left) to display the canvas 
controls—click it again to hide them. You can use these 
controls to view and adjust Canvas properties: the Canvas size 
(and resulting frame size of your exported video) and 
background color.
For details, see Configuring the Canvas.

Playback Controls Use the playback controls (center) to play your screencast as 
well as jump to the beginning or end of your screencast.

You can also use the traditional video editor’s JKL keystrokes 
for Rewind, Stop, and Playback. Press J or L repeatedly to 
speed up rewind/playback respectively.

ScreenFlow displays the timecode of the screencast directly 
to the right of the playback controls. You can set timecode to 
SMPTE or ScreenFlow.

See Timeline Settings Tab.

Timecode Display & 
Progress Display

Displays the timecode at the scrubber location.
If you load a long media file onto the time line (or move a 
long file to another location in the time line), the progress is 
displayed in percent in the right side of the timecode display.

Audio Meter The audio meter (far right) displays audio volume. The top 
meter represents the left channel; the bottom, the right 
channel.

<headphone icon> Click the headphone icon to toggle (on and off ) muting of the 
preview audio (headphones).

Progress 
display



https://www.telestream.net/telestream-support/screen-flow/support.htm# 
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The Canvas Window
The Canvas is a real-time video preview window. Canvas controls enable you to size and 
position the visual elements of your screencast.

Figure 2. The Canvas Window

The center rectangle (which may be obscured by a clip) represents the video frame of 
your screencast. The Canvas dimensions determine the frame size of your exported 
video.

The gray space around the video frame rectangle is workspace; space that isn’t 
included in exported video. You can use this space for off- or partially off-screen visual 
elements for scaling or pan effects.

See Editing on the Canvas and Configuring the Canvas.

The Timeline Window
The bottom window (directly below the playback controls) is the Timeline—a temporal 
representation of your screencast, with a time scale at the top. The Timeline enables you 
to arrange the clips in your screencast in play order, and add fades and other effects. 
The elements on the timeline reference media in your screencast media library. 
Changes made on the Timeline or in the Editor window do not alter your original media 
clips in the media library.

For details, see The Timeline Window.

The timeline (Figure 3) is a temporal representation of your screencast. The timeline 
displays all of the clips in your screencast and represents the start and end time for each 

Canvas work
area

Canvas Button

Playback Controls
Timecode Display & Progress Display

Canvas 
properties
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of the clips. You can use the timeline to arrange clips in the order you want them 
played. You can also layer them, and crop them. You can also use the timeline to add 
actions (such as fade) to your clips.

Figure 3. The Timeline Displaying Media Clips

The timeline is divided vertically into tracks to allow you to arrange clips that overlap at 
certain points on the timeline.

Timeline Buttons
There are four timeline buttons.

Mouse Tool Button

When clicked, ScreenFlow opens the Mouse Tool pane. The Mouse Tool lets you select 
how the mouse is used on the timeline. 

Thumbnail Button
Snapping Button

Framerate Button

Mouse Tool Button
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Note: If you hold down the shortcut key for a mouse tool, you can access it 
immediately. If you release the key after 1/4 second, ScreenFlow restores the previous 
tool.

Thumbnail Button

When clicked, ScreenFlow opens the Thumbnail pane.

To display thumbnails, check Thumbnails and then select either Single, or Track.

To display waveforms, check Waveforms and the select either Single or Stereo.

Snapping Button

Click the Snapping button to turn snapping on or off. When snapping is on, the button 
is displayed in blue. When off, it changes to white.

Table 2. The Mouse Tool Button

Mouse Tool Button Description

Select The mouse selects items on the 
timeline. Shortcut: “A.”

Zoom Enables you to click and drag a 
region to zoom. If the mouse is 
clicked once (without dragging), 
it zooms in on the timeline one 
step per click. If the Option key 
is held down while clicking, it 
zooms out one step per click. 
Shortcut: “Z.”

Hand Mouse moves the timeline by 
clicking and dragging with the 
mouse. Shortcut: “H.”

Blade When rolling over the timeline, a 
red line will follow the cursor. If 
the mouse is clicked, the 
timeline will have all clips split at 
that mouse position. Shortcut: 
“B.”

Track Select Cursor changes to a right facing 
arrow. Clicking on the timeline 
in this mode selects clips that 
are forward in time the current 
selection (from left to right). 
Shortcut: “N.”
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Framerate Button

When clicked, ScreenFlow opens the Framerate menu. Select framerate settings and 
click Update when finished.

The Transitions Inspection Window

Figure 4. Transitions Inspector Window

Transitions
You can add transitions only between clips in the same track. The default duration of a 
transition is one second. You can expand or contract the duration by moving the thin 
vertical line separating the transition from the main part of the clip. You may need to 
zoom in on the timeline to make it easier. As you adjust the duration of the transition, 
ScreenFlow displays the time value in real time.

Note: You can also change the default duration of transitions in the ScreenFlow 
Settings >Timeline tab.

See Timeline Settings Tab, and Adding Transitions.

Favorites 

Transition groups button

Preview button

Transition ControlsTransition icons

Duration field
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The Clip Editor
The Clip Editor enables you to select an individual clip, view it in a clip editor on the left-
hand side of the main document user interface. You can preview the clip and perform 
quick edits, adding the resulting clip directly to the timeline.

Table 3.  (Sheet 1 of 2)

Button Description

Close Window Click X to close the Clip Editor. 
You can also select View > Hide 
Clip Editor and View > Show Clip 
Editor.

Adjust Size Click and grab the edge of the 
Clip Editor window to adjust its 
size.

Scrubber Click and move the scrubber to 
change the display location in 
the media.

Close Window

Add In-Point

Add Media

Jump to Beginning
Play/Pause

Jump to End
Timecode Display

Audio Meters

Mute Audio

I/O Section

Adjust Size

Add Out-Point

 Scrubber
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The Properties Window
The upper-right window is the Properties window. The Properties window contains 
these tabs: Video, Audio, Video Motion, Screen Recording, Callout, Touch Callout, 
Annotations, Text and Titles, and Media Library.

Add Media Click the Plus (+) button to add 
the media (in its current state) to 
the Timeline.

Add In-Point Click to add an in-point at the 
scrubber location. A blue bar 
will display to indicate the 
selected section of the clip.

Add Out-Point Click to add an out-point at the 
scrubber location. A blue bar 
will display to indicate the 
selected section of the clip.

I/O Section After setting an In-Point and 
Out-Point, you can move these 
points by clicking on the either 
end of the blue bar and moving 
them. Selecting the three dots 
in the center move the entire I/O 
selection.

Jump to Beginning Click to jump the scrubber to 
the beginning of the media.

Jump to End Click to jump the scrubber to 
the end of the media.

Play/Pause Click to start playback of the 
media. Click again to pause it.

Timecode Display Displays the time location of the 
scrubber in the media.

Audio Meters Displays audio levels (left and 
right channels) during playback.

Mute Audio Click the headphone button to 
mute playback audio. Clicking 
the button again turns the audio 
back on.

Table 3.  (Continued) (Sheet 2 of 2)

Button Description
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You can customize the settings of a document in the tabs of the Properties window.

See the Properties window in the screenshot in The Properties Window.

Video Properties
Video effects include advanced color adjustments, distortion effects, blurring, color 
effects, chroma key, and alpha mask. Each filter has parameters that you can configure 
for optional features and for fine-tuning the effects of the filter.

Note: For descriptions of the Vantage video and audio filters, visit
https://cifilter.io/
See also the instructional video https://vimeo.com/560931223
Also, you can purchase third-party Core Audio or video filters for use in ScreenFlow.

In the Properties window, the Video Properties tab contains the following controls:

Name of open tab

Open/close Properties window

Video tab button
Audio tab button

Video Motion tab button
Screen Recording tab button

Callout tab button
Touch Callout tab button

Annotations tab button
Text & Titles tab button

Media Library tab button


https://vimeo.com/560931223


Windows in ScreenFlow
The Properties Window

110

ScreenFlow User Guide

Table 4. Video Properties Tab

Control Description

Scale Use the slider or enter a value (0-400%) to change the scale of 
your image. This is useful for highlighting a particular portion 
of the screen, or in a video action to create a zoom effect. 

Position Enter X and Y coordinates to specify the location (in pixels) of 
your video or image on the canvas, based on the center of the 
image. You can also reposition the image by dragging the 
image on the canvas, or nudging the selected image with the 
arrow keys.

X/Y/Z Rotation Use the rotation options to rotate (in degrees: -180 to180) the 
image in a virtual, three-dimensional space. X rotates the 
image along a horizontal axis. Y rotates the image along a 
vertical axis. Z spins the image along a depth axis. Or, use the 
thumb wheels to rotate the image in real time.

Opacity Use the slider to set the opacity value or enter it manually (0 
to 100%). The greater the value, the more opaque the image. 
When set to zero, the image is transparent—invisible. This can 
be used with a video action to fade an image in or out, or if 
you have a video voice-over, and would like to periodically 
display your entire camera recording frame.

Cropping Click the disclosure triangle down to display cropping 
options. Set the crop margins (by pixel) for left, right, bottom, 
and top.

Reflection Check to implement reflection. Use the slider to set the value 
or enter it manually (0 to 100%).

Reflection creates a mirror image of the selected clip below 
the clip itself. The greater the value, the more opaque the 
reflection. When set to zero, the reflection is invisible. 

Corner Round Drag slider to adjust the roundness of the corners.

Drop Shadow Check to create a shadow effect behind a still image. If the 
image uses a transparency, the shadow only reflects the non-
transparent part of your image.

Use the thumb wheel (or enter the value manually) to set the 
angle of the shadow relative to the image in degrees (-180 to 
80 degrees). The default is -45 degrees.

Angle Use the thumb wheel (or enter the value manually) to set the 
Angle of the shadow relative to the image in degrees (-180 to 
80 degrees).
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See Configuring Video Properties.

Audio Properties
Audio effects include EQ, multi-band compression, peak limiting, and delay. You can 
apply multiple filters to a single clip. You can apply filters to nested clips. Each filter has 
parameters that you can configure for optional features and for fine-tuning the effects 
of the filter.

Color Click the color field to select the shadow color from the color 
picker. Default: black.

Offset Use the slider to set the value (in pixels) or enter it manually (0 
to 150 pixels) to specify the distance between the shadow 
and the clip. Default: 40.

Opacity Use the arrows to set the value or enter it manually (0 to 
100%). The greater the value, the more opaque the shadow. If 
the value is set to zero, the shadow is invisible. Default: 75%. 

Blur Size Use the arrows to set the value or enter it manually. Blur is a 
gradual loss in opacity as the shadow spreads from the center. 
Default: 4. Range: 0 to 100 pixels.

Color Controls Click the disclosure triangle down to display color options. 

Saturation Use the slider to set the value or enter it manually (0 to 400%). 
Saturation is the intensity of a color relative to its brightness, 
represented as a percentage. Default: 100%. 

Brightness Use the slider to set the value or enter it manually (0 to 400%). 
Brightness is the degree of luminosity present in the image, 
represented as a percentage. Default: 100%. 

Contrast Use the slider to set the value or enter it manually (0 to 400%). 
Contrast is the relative intensity of the black and white values 
in an image. A high contrast has a greater intensity of black 
and white values. This value is represented as a percentage. 
Default: 100%. 

Video Filters Click the plus icon to add filters to the selected clip.

Add Video Action Click to add a video action at the moment indicated by the 
scrubber in the selected clip. You can also click the +Action 
icon at the top of the tab.

Table 4. Video Properties Tab

Control Description
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Note: For descriptions of the Vantage video and audio filters, visit
https://cifilter.io/
See also the instructional video https://vimeo.com/560931223
Also, you can purchase third-party Core Audio or video filters for use in ScreenFlow.

In the Properties window, the Audio Properties tab contains the following controls:

Volume

The slider, and accompanying text field, provide the volume adjustment for the Audio 
Mixer. The volume is set to 100% by default, but can be reset above or below this value.

Mute Audio

Check to mute all audio output from the mixer.

Ducking

Check to activate ducking. This lowers the audio levels for background audio whenever 
there is a voiceover. You can set the percent of ducking by moving the slider or by 
entering a value and pressing Enter. ScreenFlow updates the slider accordingly.

Processing

Check Smooth Volume Levels to activate a smoothing process imposed on the audio 
output.

Mix Output Pane
Displays the audio output of the mixer using a stereo meter bar.

The Effect Pane
The effect pane contains the following:

Effect

Check to activate effects. Select an effect from the pull-down menu.

Amount

Move the slider to adjust the amount of effect you want in your audio output. You can 
also enter a value directly. Press Enter when finished. The slider is updated accordingly.

Filter

Check Remove Background Noise to remove or lower the background noise in your 
audio output.

Amount

Move the slider to adjust the amount of background noise to remove. You can also 
enter a value directly. Press Enter when finished. The slider is updated accordingly.

See Configuring Audio Properties.


https://vimeo.com/560931223


Windows in ScreenFlow
The Properties Window

113

ScreenFlow User Guide

The Audio Filters Pane
Audio Filters triangle

Opens the Audio Filters control window.

Plus (+) icon

Opens the list of filters. You can add multiple filters.

“x” icon (to the right of each filter name)

Removes the audio filter from the audio effects applied.

The Audio Mixer
You can mix, pan, and solo all of your audio channels using the controls in the audio 
mixer. The Audio Mix panel is closed by default, but you can open it by clicking on the 
triangle next to Audio Mix. ScreenFlow displays each individual input channel. The 
Audio Mix dialog contains the following:

Gear icon

Click to open the options menu where you can select Rest to defaults or Set Mix to Mono.

Channel Number

Each individual audio channel has a number of controls. On the far left is the channel 
number string; this is simply the index of the channel.

Audio Meter

Next to the number is an audio meter showing the RMS power, peak and peak hold of 
audio in that channel. The meter is dB based and has a scale from -72 to +6. If the peak 
goes above 0dB, the meter will be tinted red to let the user know clipping is occurring. 
Once the peak hold decays below 0dB, the meter resumes its normal look. The lighter 
green value is the RMS power, which provides a general indication of the current 
loudness of the channel. The darker green color is the current peak dB value and the 
white line is the current peak hold value.

Solo Buttons

To the right of the audio meter is the 'S' or Solo button. This mutes all other channels in 
the mix during preview. Selecting the solo button for one channel automatically 
deselects the solo buttons for all other channels. To monitor more than one channel, 
press the command key while clicking solo buttons on desired channels. Clicking an 
already-selected Solo button without holding down the command key deactivates solo 
track preview. When the Solo button is selected for one channel, the audio meters for 
all other channels are disabled, and turn a gray shade.

Note: The Solo button state is not saved to the document.

Pan Controls

The control next to the Solo button is the pan button. The pan function in the audio 
mixer determines how much of the channel is mixed to the left & right channels of the 
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final mix. When the pan control is in the middle (0%), the input channel is mixed equally 
to both left & right output channels. When the pan is at -100% (all the way to the left), 
the input channel is being mixed only to the left output channel. If it is 100% (all the 
way to the right), the input channel is being mixed only to the right output channel. If 
the pan is set to -50%, 100% of input channel will be sent to the left channel, which 50% 
will be sent to the right. This is particularly useful when the ScreenFlow is using two 
microphones: one can slightly favor each channel. When a stereo media is imported 
into ScreenFlow, its audio mix will be setup by default to have the left input channel at 
-100% pan, and the right input channel at 100% pan.

Note: This setup emulates how earlier versions of ScreenFlow behave: the left input 
channel is sent to the left output channel, and the right input channel is sent to the 
right output channel. Please be aware that the 'Mix to Mono' feature has been 
removed: this functionality can now be achieved with audio mixer's pan feature.

Slider

The slider and accompanying text field provide the volume adjustment for the input 
channel. The volume is 100% by default, but can be boosted beyond or below this 
value.

See Adjusting Recorded App Audio.

Video Motion Properties
In the Properties window, the Video Motion Properties tab contains the following 
controls:

Table 5. Video Motion Properties Controls

Control Description

Duration Enter the duration of the Video Motion.

Effect Check to enable effects, then select the type of effect: Gravity, 
Spring, or Pulse.

Lock to Check to lock the Video Motion to the Duration entered in the 
Duration field. When you check this box, the Duration field is 
disabled, preventing you from making changes until you 
unlock it.

Preview Click the triangle to see a preview of your Video Motion.

Apply to Check (individually) to adjust the position, scale, or rotation of 
the clip after the action to see the effect.
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Screen Recording Properties
In the Properties window, the Screen Recording Properties tab contains the following 
controls:
Table 6. Screen Recording Properties Controls

Control Description

Show Mouse Pointer When checked, any mouse pointer icon activity in the screen 
recording is displayed. When unchecked, the mouse pointer 
is hidden.

Pointer Zoom When Show Mouse Pointer is checked, use the slider to specify 
the size of the mouse icon in the screen recording.

Use the slider or manually enter the value to specify the 
percent of increase to apply.

Often it can be difficult to distinguish or track the mouse in a 
screencast, particularly if the video has been significantly 
resized. Increasing the pointer zoom value increases the size 
of the mouse icon, making it easier to follow.

Click Effect Select None > Radar > Invert from the popup menu to create a 
visual effect when you click the mouse. Radar displays an 
animated red circle with each click. Invert changes the cursor 
from black to white and back with each click.

Attention Effect Select Circle to pick an effect to display over the mouse 
pointer during their screen recording. Set the size, fill color, 
border width, edge color and edge blur for the effect. The 
effect can be turned on & off using a screen recording action.

Pointer Select Default > Circle-Light > Circle-
Dark > Square > Choose Image from the popup menu to 
change the pointer image.

The Circle - Dark option is particularly good for iOS 
screencasts.

When you select Choose Image, ScreenFlow displays an Open 
dialog, so you can navigate and select an image file. When 
selecting a custom image, you also specify the cursor hot spot 
position.

Opacity Specifies the degree of pointer translucency.

Use the slider to set the value or enter it manually (0 to 100%).

The greater the value, the more opaque the pointer. If the 
value is set to zero, the pointer is invisible. Default: 100%.

This can be used in a screen recording action to fade the 
pointer in or out.
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See Configuring Screen Recording Properties.

Callout Properties
In the Properties window, the Callout Properties tab contains the following controls:

Smoothing Increases the smoothness of the motion of the mouse cursor 
as you record.
Use the slider to set the value or enter it manually (0 to 100%).

Sound on Click Check to generate a sound when the mouse button is 
pressed.

Click the disclosure triangle to display Sound on Click details. 

Volume Specify the volume level of the mouse click sound (from 0 to 
5,000%). Use the arrows to set the value or enter it manually.

Click Sound Click Choose to display an Open dialog, and navigate to and 
select any custom sound file, to play a unique sound file every 
time the mouse is clicked.

Show Keystrokes Check to display the characters (one at a time) of keyboard 
characters typed during the recording.

Show All Keys Check to display all keystrokes typed during the recording, 
including the modifier keys.

Show Only Modifier 
Keys

Check to display modifiers used in hotkey commands, 
function keys, and the arrow keys that were pressed during 
the recording.

Height and Position Specify the height and position of the font.

Font Button Click to display the font settings and specify all font 
information for the characters shown in the keyboard 
characters display.

Width Slide the slider right or left to adjust the keystroke bar 
horizontally. You can also enter a value into the numeric box.

Attached To Clip When checked, the keystroke bar will be attached to the 
screen recording clip, and will be affected by any changes 
made to the recording. This includes scaling, cropping, and 
any changes made to the canvas crop.

When unchecked, the keystroke bar will only be affected by 
changes to canvas crop, and will remain centered to the 
canvas if any changes are made.

Table 6. Screen Recording Properties Controls

Control Description
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Table 7. Callout Properties

Control Description

Highlight Select how to highlight an area of the recording: mouse 
pointer highlights a circular space around the mouse pointer. 
Foreground Window highlights the window which is in the 
screen recording. Mouse and foreground highlights can only 
be added to screen recording clips.

Freehand callouts can be added to video clips, image clips, 
and screen recording clips.

See Adding Freehand Callouts to Images.

Opacity Use the slider to control the percent of opacity of the space 
outside the callout. A value of 0 makes the surrounding area 
entirely visible; a 100% value makes the surrounding area 
invisible.

Blur Use the slider or manually enter the pixel value to blur the 
callout area (range: 0-16).

Blur Background Check to blur the area outside of the callout.

Zoom Up Use the slider or manually enter the percentage value to 
magnify the area inside the callout (range: 0 to 500%).

Border Use the slider or manually enter the value to create a gradual 
loss in opacity as the shadow spreads from the center (range: 
0-300). This feature does not apply to freehand callouts. This 
is not a zoom control, but instead it adds more area to the 
callout.

Outline Enter the value (in pixels) to create an outline around the 
callout area (range: 0 to 59.) Click the color box to change the 
color of the outline.

Shadow Check to add a shadow behind the callout. Use the slider or 
manually enter the value to create a gradual change in size as 
the shadow spreads from the center (range: 0-80).
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See Configuring Callout Properties.

Touch Callout Properties
In the Properties window, the Touch Callout tab contains the following controls:

Feather Specify the blend value (in pixels) to apply to the callout 
border to create a smooth transition between the callout area 
and the surrounding space (range: 0-20).

Round Applies to foreground window callouts only. Specify the 
round-off value (in pixels) of the callout edge to create a more 
gentle appearance (range: 0-59).

Build Specify the transition time of the callout, in seconds, up to 2 
decimal places, and from 0 to 4 seconds. Duration In 
determines the amount of build-in time to reach the full 
effect of the callout. Duration Out determines the amount of 
build-out time to return to normal.

Table 7. Callout Properties

Control Description

Table 8. Touch Callout Properties

Control Description

+Action Modifies video or 
recording properties over 
time.

Count Sets the number of touch 
callout areas on-screen.

Fill/Color When Fill is checked, you 
can determine the fill color.

Outline/Color When Outline is checked, 
you can determine the 
outline color.

Size The slider determines the 
size of the touch callout.

Spacing The slider determines the 
amount of space between 
the touch callouts.

Opacity Determines the opacity of 
the touch callout.
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Annotations Properties
Annotations are used for displaying simple shapes in your screencast.

In the Properties window, the Annotations Properties tab contains the following controls:

Rotation Determines the rotation of 
the touch callout.

Callout Has End State When checked, you can 
determine the end state 
for the touch callout.

Wait When checked, you can 
determine how long to 
wait before ScreenFlow 
starts the animation to the 
end state.

Curve Determines the type of 
animation for displaying 
and removing the touch 
callout.

Animates Values to End 
State

When checked, you can 
animate various values of 
the touch callout until its 
end point.

Size The slider determines the 
end-state size of the touch 
callout.

Spacing The slider determines the 
end-state spacing of the 
touch callout.

Opacity The slider determines the 
end-state opacity of the 
touch callout.

Rotation The slider determines the 
end-state rotation of the 
touch callout.

Table 8. Touch Callout Properties

Control Description
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Table 9. Annotations Properties

See Configuring Annotations Properties, and Adding an Annotation Clip.

Text & Titles Properties
Text boxes are clips which display blocks of text in your screencast. Text clips behave 
like image clips—they are static images which play for the length of time you specify. 
You can also apply video properties and transitions to text clips, along with Text 
Animations.

Text clips can have the interesting property of per character animations for building in 
and out the clip to the screen. These effects are commonly seen in other popular 
applications. Once enabled, a default effect is selected, with a default duration of 0.75 
seconds. You can switch between different effects.

In the Properties window, the Text Properties tab contains the following controls:

Control Description

(+) Add annotations clip When clicked, adds an 
annotation clip

Tool Palette Contains five drawing tools

Color Annotation color picker

Opacity Slide to change opacity

Thickness Slide to change thickness

Shadow When checked, adds a 
drop shadow. Slide to 
change shadow thickness.

Outline When checked, adds an 
outline. Slide to change 
thickness. Color picker for 
outline.

Endpoints Drop-down menus for 
setting the annotations 
clip endpoints
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Table 10. Text Properties Controls

Menu Item Description

Font drop-down 
menu

When clicked, ScreenFlow displays the list of fonts on your 
computer. If you selected the whole text box, ScreenFlow 
applies the font selected to the entire text box. If you selected 
a range of characters in the text box, ScreenFlow applies the 
font only to the characters selected.

Size drop-down 
menu

When clicked, ScreenFlow displays available font sizes, in 
pixels, ranging from 9 to 288. If you selected the whole text 
box, ScreenFlow applies the size selected to the entire text 
box. If you selected a range of characters in the text box, 
ScreenFlow applies the size only to the characters selected. 
Select Font > Show Fonts to enter a custom size.

Font selection button When clicked, ScreenFlow displays the list of fonts on your 
computer. If you selected the whole text box, ScreenFlow 
applies the font selected to the entire text box. If you selected 
a range of characters in the text box, ScreenFlow applies the 
font only to the characters selected.

Alignment buttons When either the Left , Center , or Right  alignment 

button is clicked, ScreenFlow aligns the text in the text box 
accordingly.

This property can affect single or multiple selected 
paragraphs.

Font style buttons When the Bold  button is clicked ScreenFlow sets the 

selected text or text box in boldface. When the Italic  

button is clicked ScreenFlow sets the selected text or text box 
in italic.

Fill checkbox Check to choose Solid Color | Image | Gradient from the 
popup menu. For solid color, select a color from the color 
wheel. The color is applied to the entire text box (if none or all 
text is selected) or a range of selected characters. For Image, 
ScreenFlow displays an Open dialog, so you can navigate to 
and select any custom image file. Deselect the checkbox to 
remove the file. This can be used with Outline to create 
characters which are transparent. Applying an image uses the 
color patterns represented in the image to fill the text. These 
properties are applied to the entire text box (if none or all text 
is selected) or a range of selected characters.

Fill type drop-down 
menu

When clicked, ScreenFlow lists the fill types available. Select 
Solid Color, Image, or Gradient.
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Fill color box When clicked, ScreenFlow opens the color field dialog. 
Choose a color for your text. For Gradient, click in the top half 
and select a color, then click in the bottom half and select the 
second color.

Outline checkbox Check to outline the text. If you selected the whole text box, 
ScreenFlow applies the outline to the entire text box. If you 
selected a range of characters in the text box, ScreenFlow 
applies the outline only to the characters selected.

Outline slider Use the slider to set the width of the outline, in pixels, ranging 
from 0 to 15.

Outline size field As an alternative to the Outline slider, enter a number, from 0 
to 15, to set the size of the outline in pixels.

Outline color box Click to select the color of the outline. Select the color, 
brightness, and opacity. Brightness is only available on the 
Color Sliders pane of the Show Colors tool.

Line Spacing drop-
down menu

When clicked, ScreenFlow displays a list of the line spacings 
available. Select a line spacing. Selecting Multiple, activates 
the At: selection field

At: selection field Click the up or down arrows to set the location of the selected 
multiple line spacing.

Kerning buttons To tighten the kerning of the selected text or text box, click 
the Tighten Kerning button . To loosen the kerning of the 

selected text or text box, click the Loosen Kerning button 
.

Bullets buttons Click the filled circle button  to add a bullet to text. Select 

the unfilled circle button  to remove a bullet.

Backdrop checkbox Check to add a backdrop.

Type drop-down 
menu

When clicked, ScreenFlow displays a list of backdrop types. 
Select Solid Color or Image Fill.

Color box Click to select the color of the backdrop. Select the color, 
brightness, and opacity. Brightness is only available on the 
Color Sliders pane of the Show Colors tool.

Round slider Use the slider to specify the value in pixels to smooth the 
edge of the text box, ranging 0 to 100. The default is 20.

Table 10. Text Properties Controls

Menu Item Description
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Round size field As an alternative to the Round slider, enter a number to 
specify the value in pixels to smooth the edge of the text box, 
ranging 0 to 100. The default is 20.

Margin slider Use the slider to enter the size, in pixels, of the backdrop, 
ranging 0 to 300. The default is 25.

Margin size field As an alternative to the Margin size field, enter the size, in 
pixels, of the margin, ranging 0 to 300. The default is 25.

Build In Animation 
checkbox

Check to enable Build In Animation. Click the arrow on the 
right to view the action.

Type drop-down 
menu

When clicked, ScreenFlow displays a list of Build-In 
animations. Select the type desired.

Duration slider Use the Duration slider to set the duration of the Build-In 
animation.

Duration field As an alternative to the Duration slider, enter a number to 
determine the duration in seconds.

Build drop-down 
menu

When clicked, ScreenFlow displays a list of Build-In options. 
Select the option desired.

Directionality arrows Click an arrow to determine the direction of text animation.

Distance slider Drag the Distance slider to determine the distance traveled 
by the text.

Distance percentage 
field

As an alternative to the Distance slider, enter a number to 
determine the distance in a percentage,

Overlap slider Drag the Overlap slider to determine the amount of overlap 
between text elements.

Overlap percentage 
field

As an alternative to the Overlap slider, enter a number to 
determine the amount of overlap by percentage.

Easing drop-down 
menu

When clicked, ScreenFlow displays a list of available easing 
types. Select the type desired.

Fade Characters 
checkbox

Check to fade characters on Build In.

Build Out Animation 
checkbox

Check to enable Build Out Animation. Click the arrow on the 
right to view the action.

Type drop-down 
menu

When clicked, ScreenFlow displays a list of available Build-Out 
types. Select the type desired.

Table 10. Text Properties Controls

Menu Item Description
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See The Properties Window and Adding and Configuring a Text Clip.

Media Library
The media library contains all the clips for a ScreenFlow document. When you record a 
source with ScreenFlow, ScreenFlow records the input to a file in a media folder. 
ScreenFlow then creates a clip in the Media Library that points to the file. When you 
import a media file located on any drive, ScreenFlow leaves the media file on its drive, 
but creates a clip for the media file in the Media Library.

The Stock Media Library is a large collection of stock audio, video, and graphics files you 
can use in ScreenFlow documents. The Stock Media Library is integrated into the 
ScreenFlow Media Catalog. ScreenFlow stores downloaded Stock Media files here: 
~/Movies/ScreenFlow Data.

When you add properties to a clip or change them, ScreenFlow stores these properties 
in the clip. ScreenFlow doesn’t alter the associated media file.

Duration slider Drag to set the duration of the Build-Out Animation, in 
seconds.

Duration field As an alternative to the Duration slider, enter a number to 
determine the Build-Out Duration, in seconds.

Build drop-down 
menu

When clicked, ScreenFlow displays a list of available Build-Out 
types. Select the type desired.

Directionality arrows Click an arrow to determine the direction of the Build-Out 
animation.

Distance slider Drag the Distance slider to determine the distance traveled 
by the text.

Distance percentage 
field

As an alternative to the Distance slider, enter a number to 
determine the distance in a percentage,

Overlap slider Drag the Overlap slider to determine the amount of overlap 
between text elements.

Overlap percentage 
field

As an alternative to the Overlap slider, enter a number to 
determine the amount of overlap by percentage.

Easing drop-down 
menu

When clicked, ScreenFlow displays a list of available easing 
types. Select the type desired.

Fade Characters 
checkbox

Check to fade characters on Build Out.

Table 10. Text Properties Controls

Menu Item Description
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Note: In the version of ScreenFlow sold on the Telestream Web Store, you can edit a 
media file outside ScreenFlow that already has a clip associated with it. ScreenFlow 
adds a refresh button to the associated clip in the Media Library. When you click the 
refresh button, ScreenFlow re-associates the clip with the edited media file.
This feature is not present in the Mac App Store version of ScreenFlow.

In the Properties window, the Media Library tab contains the following controls:

Figure 5.  Media Library Tab.

Use the buttons and other controls on the Media Library tab to perform tasks, as 
described in Table 11.

Table 11. Media Library Controls

Control Description

Add Media button Click to browse local drives or network servers for media to 
import into your document. This may include video files, 
audio files, and still images.

Display Type Buttons Click these buttons to select between thumbnail and list view.

Source Buttons Click these buttons to select between Media Files, iTunes, and 
Global Library. Media added to the Global Library can be used 
by any ScreenFlow document.

Search field

Add media button

Source buttons

Zoom slider

Media Library

Gear button

Display Type buttons
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See Navigating the Media Library, Deleting All Unused Media, Viewing Clip Metadata, and 
Properties.

Search To search for a file, enter a search text and press the Enter key.

Gear Button Click the Gear button to select either Remove All Unused 
Media or Show Duration Overlays. Show Duration Overlays 
displays the duration value on the media icon image.

Zoom Slider Use the slider to change the display size of the media 
thumbnails.

Table 11. Media Library Controls

Control Description
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You can find many of the controls for ScreenFlow in the ScreenFlow menus.

Topics
■ ScreenFlow Helper Menu

■ ScreenFlow Menu

■ File Menu

■ Edit Menu

■ Mark Menu

■ Clip Menu

■ Insert Menu

■ Actions Menu

■ Font Menu

■ Arrange Menu

■ View Menu

■ Window Menu

■ Purchase Menu (Telestream Web Store Only)

■ Help Menu

■ Editor Drop-Down Menu

■ The Media Library Context Menu

ScreenFlow Helper Menu
The ScreenFlow Helper menu is identified by the camera button  in the status menu.
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Table 1. ScreenFlow Helper Menu Items

Menu Item Description

Record/Stop Record
(Shift-Command-2)

Begins recording using the selected sources (display, 
camera, microphone, and/or computer audio). The menu 
icon changes from  to , advising you that 
ScreenFlow is recording.

Select Stop Record or press Shift-Command-2 to stop 
recording.

Pause/Resume Pauses recording. The menu icon changes to a blinking 
dot, advising you that ScreenFlow has been paused. 
Select Resume to continue recording.

To modify the hotkey for these commands, see General 
Settings Tab.

Add Marker Allows you to mark a key moment location while you are 
recording.

Configure Recording Displays the dialog for setting recording parameters.

Show Recording Monitor Displays the ScreenFlow recording monitor.

Hide Desktop Icons/Show 
Desktop Icons

Hides all icons on your desktop if you prefer a less 
cluttered background. Select Show Desktop to show them 
again.

Quit ScreenFlow Closes the ScreenFlow and ScreenFlow Helper 
applications.
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ScreenFlow Menu
The ScreenFlow menu contains the following commands:
Table 2. ScreenFlow Menu Items

Menu Item Description

About ScreenFlow Displays a dialog indicating the version of ScreenFlow you are 
running.

Check For Updates Note: This option is not available to users who purchased 
from the Mac App Store. The App Store has its own update 
procedure.

Checks the Telestream Online Store to determine if there is a 
more recent version of ScreenFlow available. If so, you can 
download it. To check for ScreenFlow updates automatically, 
check the Check the Updates option in the General Settings 
Tab.

Settings
(Command-,)

Opens the Settings dialog so that you can view and change 
ScreenFlow settings. If the Settings dialog already is open, 
ScreenFlow brings it to the front.

Services Displays Macintosh Services—none are implemented in 
ScreenFlow.

Hide ScreenFlow
(Command-H)

Hides all ScreenFlow windows.

Hide others
(Option-Command-H)

Hides all windows which aren’t ScreenFlow windows.

Show All Shows all previously hidden windows.

Quit ScreenFlow
(Command-Q)

Closes all open documents and then quits.

If a document has not been saved, ScreenFlow displays a Save 
dialog, so you can save the document before quitting.

If Launch ScreenFlow Helper at user login is checked in the 
Settings General Settings Tab, ScreenFlow Helper keeps 
running when you quit ScreenFlow.
See Configuring ScreenFlow Helper.
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File Menu
The File menu contains the following commands:
Table 3. File Menu Items

Menu Item Description

New
(Command-N)

Displays the New dialog for creating new clips or documents.

You can add clips to ScreenFlow documents, or discard the 
clips.

See Creating a Document, Creating a Document from a 
Template, Recording Clips, and Configuring a Recording.

Open
(Command-O)

Displays the Open dialog, so you can navigate and open a 
ScreenFlow document that was saved earlier.

Open Recent Click to select from up to 15 recently accessed documents. 

Every time you open or save a document, it is added to the 
list. Select Open Recent > Clear Menu to reset the list.

Add Additional 
Recording
(Shift-Command-R)

Displays the Add Additional Recording dialog. After recording 
is complete, displays the Recording Complete dialog so you 
can add the recording to a new document or to a currently-
open document.

See Adding Recordings to a ScreenFlow Document.

Close
(Command-W)

Closes the active ScreenFlow document.

If the document has not been previously saved, ScreenFlow 
displays a Save As dialog, so that you can name the document 
and save it before closing it.

Close Tab
(Command-W)

Closes the active tab on the timeline.

Save Saves changes to your ScreenFlow document.

Save As Saves your ScreenFlow document with a new name and /or 
new location. Optionally, select a File Format from the drop-
down menu. You can set the default file format in the 
Advanced tab on the Settings dialog.
See Default File Format.

Save As Template Saves your current document as a template. (See Creating a 
Document Template).

Archive When clicked, ScreenFlow opens the Save Document dialog.

Document Settings Opens the screen dimensions setting window.

Save Frame Select to save the video frame of the canvas (as rendered by 
the location of the scrubber) as a PNG or JPEG file.
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See Changing the Canvas Size.

The New Dialog
The New dialog contains the following controls:

Table 4. The New Dialog

Publish to Displays the Publish dialog, enabling you to log in, encode 
your project (or the selected range, when in and out points 
are present) and publish your video.

Export Displays the Export Settings dialog, so you can select your 
encoding options, encode your project (or the selected 
range, when in and out points are present) and export the file.

See The New Recording Pane of the New Dialog.

Batch Export Exports a large number of ScreenFlow documents, re-
encoding each document into a different formats as needed.

Table 3. File Menu Items

Menu Item Description

Control Description

Welcome Displays the ScreenFlow Welcome window.

Permissions Displays the Grant ScreenFlow Permissions window for setting 
permissions.

New Recording Displays the New Recording window where you can assign 
sources for recordings.
See The New Recording Pane of the New Dialog.

New Document Displays the New Document window where you can define 
the settings for new documents.

New from Template Displays the list of existing templates, from which you can 
create new templates.

Recent Documents Displays a list of recently-opened documents.

Stock Media Library Displays the Stock Media Library window. This lists stock 
media if you have purchased the Stock Media Library.
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The New Recording Pane of the New Dialog
See Configuring Recording Options.

The File menu contains the following controls:

Edit Template (pencil) 
button

When clicked, this allows you to edit the selected template.

New Document 
(page) button

When clicked, this allows you to create a new document.

Radio button Opens the Other Settings window.

Table 5. The New Recording Pane

Control Description

Show Advanced Options (three-dot) 
button at upper-right of the New 
Recording Pane

When clicked, ScreenFlow opens the 
Advanced Options pane for the new 
recording.

Record When checked, ScreenFlow activates the 
drop-down menu for selecting a source 
for recording.

Desktops When selected, ScreenFlow records your 
computer display. ScreenFlow records 
this source by default. If you have 
multiple displays connected, you can 
record any or all of them. ScreenFlow 
combines desktop video and computer 
audio into a single clip, and adds the clip 
to your document as an SCC file.

Note:  ScreenFlow automatically 
updates the list of displays in the 
Record menus as you add displays to 
the system.

Built-in [type] Display When checked, ScreenFlow records the 
display selected.

Control Description
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Video Cameras Select this option to record video from 
any camera connected to your 
computer. Use the drop-down menu to 
choose from multiple cameras. When 
you select a source, ScreenFlow displays 
a preview image below.

ScreenFlow combines camera video and 
microphone audio into a single clip, and 
adds the clip to your document as an 
SCC file.

Note: If a particular virtual camera 
does not work in a sandbox 
environment, it will not work in the Mac 
App Store version of ScreenFlow. 
Contact the manufacturer of the virtual 
camera for information on virtual-
camera sandbox support.

FaceTime HD Camera (Built-in) When checked, ScreenFlow records the 
FaceTime camera selected.

Microphones When selected, ScreenFlow records 
audio from a microphone connected 
to your computer. Use the drop-
down menu to choose from multiple 
microphones. Upon selecting the 
source, ScreenFlow displays the vol-
ume level below.
ScreenFlow combines camera video 
and microphone audio into a single 
clip, and adds the clip to your docu-
ment as an SCC file.

Note: ScreenFlow records microphone 
audio at a sample rate of 48KHz with 
16-bit sample depth.

Built-in Audio When selected, ScreenFlow records the 
built-in audio source selected.

Table 5.  (Continued)The New Recording Pane

Control Description
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The Advanced Options Pane for New Recordings
See Configuring a Recording.

Add (+) button If you have additional displays to record, 
click the Add (+) button. ScreenFlow 
adds a new Record Desktop from drop-
down menu-with a Minus (-) button that 
lets you remove this menu.

Note: If the number of displays you’re 
recording matches the number of 
displays connected to the system, 
ScreenFlow disables the Add (+) button 
on the first row. This informs you that 
you can’t record any more displays.

Computer Audio When selected, ScreenFlow records 
all sounds played through your com-
puter. To use this feature, you must 
install the ScreenFlow audio driver. If 
the driver is not installed, ScreenFlow 
prompts you to install it.
ScreenFlow combines desktop video 
and computer audio into a single 
clip, and adds the clip to your docu-
ment as an SCC file.

Record (red) button When clicked, ScreenFlow records 
the sources selected in the Record 
drop-down menus.

Table 5.  (Continued)The New Recording Pane

Control Description



Menus
File Menu

135

ScreenFlow User Guide

The Advanced Options Pane contains the following commands.

Table 6. The Advanced Options Pane

Control Description

Loop Recording Activate loop recording by checking 
the Record in a loop box. To set the 
recording loop duration, enter hours 
and minutes. Click the Record button 
to activate. Once the recording starts, 
you can see the loop duration in the 
status menu of ScreenFlow Helper.

Timed Recording You can also set your timer to stop 
the recording after a set number of 
minutes and seconds. Click the Set 
Timer button to apply this setting. 
Once the timer has been set, this but-
ton changes to Reset Timer. Click 
again to disable timed recording.

Countdown Window Each time you start recording, 
ScreenFlow displays the countdown 
panel, providing a delay to allow you 
to prepare recording.
To skip the countdown, simply click 
on the countdown window. 
ScreenFlow begins recording imme-
diately. By default, the countdown is 
set to five seconds. To change the 
countdown option, go to 
ScreenFlow > Settings > General. You 
can set the countdown delay for up 
to 20 seconds.
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The Export Settings Dialog
The Export Settings dialog contains the following commands.

Adding A Recording When you have finished your record-
ing, ScreenFlow automatically opens 
the clips that you have recorded in a 
new document. If you already have a 
document open, ScreenFlow gives 
you the option of creating a new doc-
ument or adding your recording to 
an existing document.
If you’ve accidentally created a new 
document when you intended to add 
the recording to an existing docu-
ment, drag, or copy and paste, your 
recording into the editor window, 
timeline, or media library of the 
desired document. This duplicates 
the recording in the document folder 
of the desired document.

Add Additional Recording To add a recording to your docu-
ment, create a new recording, choose 
File > Add Additional Recording, or 
add from the media library.
The Add Additional Recording selec-
tion reopens the New Recording win-
dow so you can add another 
recording.

Table 6.  (Continued)The Advanced Options Pane

Control Description
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Table 7. Export Settings Options

Control Description

Save As Enter the name of your screencast. The default name is the 
name of your project file. The file extension is applied 
automatically based on your choice of preset.

Where Navigate and select the location of your exported video file.

NOTE: If you purchased ScreenFlow from the Mac App Store, 
the Where popup menu does not display. Instead, ScreenFlow 
displays the File Save dialog after you click Export, so you can 
navigate and select your folder for the exported file.

Type (Automatic)

Type (Manual)

Encoding Quality Select: Fastest, Normal, or Slowest.

Resolution Select a resolution, or select Custom which opens Width and 
Height fields to enter custom resolution values.

Letterbox Content Check to display letterbox content (text display of audio 
content).

Options Use these controls to specify motion blur, add chapter tracks, 
add captions, and burn in captions, depending on your 
encoding options.

Use Motion Blur Check to apply a blurring algorithm to blend movement 
smoothly into the video. This is useful if you are using video 
properties effects to move clips on the canvas. This option 
increases encoding time so it should only be used if objects 
are not moving smoothly in your exported video.

Add Chapter Track 
from Markers*

When encoding with some codecs, check to add chapter 
markers to your movie based on the location and names of 
the markers in your project. These markers provide quick 
navigation and require named markers to be present in the 
project.

Add Captions Track Check to include your caption track.

Burn In Captions When checked, imported captions are burned into the clip.

Preset Export presets are designed for both general and specific use, 
based on the most common applications.

Select a preset from the popup menu.

See the Export Preset Options table.

Gear icon
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Make Current 
Settings Default

Select to make the current settings become the “default” 
settings that are used when a new document is created.

Reset to Factory 
Defaults

Select to return the default settings to the original factory 
settings. Any current default settings (set by Make Current 
Setting Default above) are cleared.

Customize Click to make changes to your video and audio encoding 
settings. Some presets cannot be customized. See 
Customization Dialog for H.264/AAC (MPEG-4). 
If iOS App Preview is the selected Preset, clicking Customize 
lets you set the Framerate and the ProRes profile to 4444, 
422LT, or 422 HQ. It also lets you select a Stereo or Mono 
channel

Manage Click to modify the preset encoding settings. See The New 
Recording Pane of the New Dialog.

Table 7. Export Settings Options

Control Description
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Table 8. Export Preset Options

Preset Description

Web-High Default export option, which encodes 
video in H.264 format using the x264 
codec, with AAC audio, balancing the 
demands of image quality and file size, 
producing an MP4 file.

Web-Low Encodes video in H.264 using the x264 
codec, with AAC audio, for low 
bandwidth, producing an MP4 file. It 
plays more smoothly on slow Internet 
connections but with reduced image 
quality when compared to Web-High.

HEVC Encode as video in HEVC / H.265 with 16-
bit 48kHz AAC audio.

NOTE: Before using the HEVC export 
option, please be advised that this is not a 
widely supported codec. There are still 
many programs and services that will not 
accept files encoded with the HEVC / 
H.265 codec. If you are using this export 
option, you may want to check with 
whatever service or program you wish to 
upload to before doing so, as Telestream 
does not govern 3rd party policies and 
specifications.

Lossless - ProRes with Alpha Encodes a lossless file in ProRes 4444, 
including a clear alpha channel and 
stereo audio. Suitable for usage in 
applications such as Motion and After 
Effects.

To view transparent portions of the 
canvas, select View > Show Checkerboard.

ProRes 422 Encodes ProRes 422. Click Customize to 
select profile: 4444, 422HQ, 422, or 422LT.

Lossless - Audio Only Encodes an uncompressed audio-only 
AIFF format ideal for additional editing.

AAC - Audio Only Audio only
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Customization Dialog for Animated GIF or Animated PNG
Descriptions of the fields in the customization dialog follow:

Framerate Higher frame rates produce larger files. For most GIF files, 15 fps is standard.

Colors 256 is the optimum setting for GIF files. If your animation contains less than 256 
colors, use lower settings.

Loop Check to cause the output file to continuously play in a loop.

Dither Check to turn on dithering in GIF images. This helps reduce banding in 
gradients of color, but it also increases the file size. The Error Diffusion setting produces 
smaller files while maintaining the quality to the Ordered option.

Strength Select the amount of dithering: Light, Medium, or Heavy.

Customization Dialog for H.264/AAC (MPEG-4)
Descriptions of the fields in the customization dialog follow:

Set these options, as described below in Table 9. When you’re done, click OK.

iOS App Preview Exports according to Apple’s guidelines 
for App Store previews (30 fps ProRes 422 
with stereo AAC 16-bit 48khz).

iPhone X Optimized/iPhone X Screen Fill/
iPhone/Apple TV

These export options are configured 
based on the recommended video 
specifications for these devices. They 
can’t be altered.

Animated GIF/Animated PNG Exports as an animated GIF or PNG. 
     (See Customization Dialog for Animated 
GIF or Animated PNG)

1080 Vertical Exports in vertical frame of 1080x1920.

1080 Square Exports in square frame of 1080x1080.

720 Square Exports in square frame of 720x720.

Table 8. Export Preset Options (Continued)

Preset Description
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Table 9. H.264/AAC (MPEG-4) Settings

Option Description

H.264 Video Uncheck when you do not want your exported file to contain 
video tracks.

Frame rate Enter the frame rate in frames per second, or select preset 
values from the popup menu.

Data rate Enter the data rate in kbits per second.

NOTE: The data rate you enter is a target value. Therefore, the 
actual data rate may be higher or lower than entered.

Profile Select the codec profile (which establishes parameter ranges 
for a given application) from the popup menu:

Automatic The codec determines which profile to use, based on the size 
of the input video.

Main This profile results in longer encoding; it was designed 
primarily for SD digital TV broadcasts. It is well-suited for 
playback on desktop computers.

Baseline This profile is used for faster, simpler encoding, and improved 
data loss robustness, particularly for playback in mobile 
applications.

High The High Profile is used as the preferred choice for HD 
broadcast and disc storage applications.

Codec Select: Single-pass, Multi-pass, or Hardware Accelerated.

Keyframe Rate Select automatic or fixed keyframe rate

Automatic ScreenFlow selects the optimum rate

Fixed every Manually enter the frame rate

AAC Audio Uncheck when you do not want your exported file to contain 
audio tracks.

Sample Rate Select to signify the number of samples taken from the source 
per second (in kHz) and added to the audio track being 
generated.
Select the sample rate from the popup menu. Web-High and 
Web-Low, defaults to CD quality (44.1 kHz). 

Data rate Enter the data rate in kbits per second. Web-High defaults to 
256kbits/sec. Web-Low, defaults to 96kbits/sec.

Channels Select Mono or Stereo
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The “Publish to” Dialogs
ScreenFlow opens a dialog of settings for each of the supported video-hosting 
platforms. Descriptions of the various platform settings follow.

The Publish to Vimeo Settings
Table 10. Publish to Vimeo Settings

Control Description

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Tags Enter keywords to describe your project. When Vimeo users 
search for these words, your video is included in the search 
results.

Privacy Select the level of privacy required. Account Default uses the 
defaults set up through the Vimeo Web interface.

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Vimeo account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.
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The Publish to YouTube Settings

Table 11. Publish to YouTube Settings the

Note: For recommended upload encoding settings on YouTube, see https://
telestream.net/ScreenFlow/youtube-settings.htm

Control Description

Category Select the category of your project from the options in the 
popup menu.

Title Enter the title for your project, up to 60 characters. By default, 
this field uses the base name of your project file.

Description Enter a description for your project.

Tags Enter keywords to describe your project. When YouTube users 
search for these words, your video is included in the search 
results.

Privacy Public: Anyone can view this video

Unlisted: Only people with a link can view this video

Private: Only YouTube users that you authorize can view this 
video

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your YouTube account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.


https://www.telestream.net/ScreenFlow/youtube-settings.htm

https://www.telestream.net/ScreenFlow/youtube-settings.htm
https://support.google.com/youtube/answer/1722171?hl=en
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Publish to Google Drive Settings

Table 12. Publish to Google Drive Settings

Publish to Dropbox Settings
The Dropbox upload places all the files into a ScreenFlow folder inside the Apps folder 
at the root of the user’s Dropbox. This cannot be changed because it is the only way for 
third-party applications to upload to Dropbox directly.

Control Description

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Sharing Check Public | Unlisted | Private:

Public: Anyone can view this video

Unlisted: Only people with a link can view this video

Private: Only Google Drive users that you authorize can view 
this video

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Google account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.
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Table 13. Publish to Dropbox Settings

Publish to Wistia Settings

Table 14. Publish to Wistia Settings

Publish to Box Settings

Table 15. Publish to Box Settings

Control Description

Filename Enter a filename to use for your publication. 
NOTE: The Apps folder at the root of the user’s Dropbox 
cannot be changed because it is the only way for third-party 
applications to upload to Dropbox directly.

Privacy Public: Anyone can view this video

Private: Only users that you authorize can view this video

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Dropbox account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.

Control Description

Video Encoding Select an encoding preset from the drop-down menu.

Frame rate Enter the frame rate in frames per second, or select preset 
values from the popup menu.

Options Letterbox Content
Use Motion Blur

Media File Check box to save a copy of the media file locally.

Save copy to disk Click Location to choose the location for the saved media file.

Control Description

Video Encoding Select an encoding preset from the drop-down menu.

Frame rate Enter the frame rate in frames per second, or select preset 
values from the popup menu.
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Publish to Imgur Settings

Table 16. Publish to Imgur Settings

Edit Menu
The Edit menu contains the following commands:

Note: Most of these commands are also on the gear  menu, directly on the clip.

Options Letterbox Content
Use Motion Blur

Media File Check box to save a copy of the media file locally.

Save copy to disk Click Location to choose the location for the saved media file.

Control Description

Preset Select an encoding preset from the drop-down menu.

Dimensions Enter the desired frame dimensions.

Options Use Motion Blur
Add Chapter Track from Marker
Add Captions Track

Media File Check box to save a copy of the media file locally.

Save copy to disk Click Location to choose the location for the saved media file.

Control Description

Table 17. Edit Menu Items

Menu Item Description

Undo
(Command-Z)

Reverses your last change.

ScreenFlow permits an unlimited number of undo/redo 
actions (limited only by memory constraints). However, 
undo information is stored on a per-window basis. If you 
close a window and then reopen it, its undo list is lost.

Redo
(Shift-Command-Z)

Reverses your last Undo action.

Cut
(Command-X)

Removes the selected object or objects, and place them on 
the clipboard.
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Copy
(Command-C)

Copies the selected object or objects onto the clipboard.

Note: Clips in the media library cannot be copied, but they 
can be added to the timeline multiple times.

Paste
(Command-V)

Adds objects on the clipboard to your document.

Copied text is added to the text box at the cursor position. 
Inserted text adopts the text formatting of the character 
immediately preceding the insertion point.

If the scrubber is at the start of the timeline or anywhere on 
a clip, the clip is added one layer up, at the scrubber 
position.

If the scrubber is at the end of a clip, the pasted clip is added 
on the same layer.

Paste Properties Updates the properties of the selected clip on the timeline 
with the properties of the clip on the clipboard.
Paste Properties has these sub menu items:

Video
(Option-Command-I)

Pastes video properties into a video clip.

Audio
(Option-Command-A)

Pastes audio properties into an audio clip.

Screen Recording
(Option-Command-S)

Pastes the screen recording properties into a clip.

Callout
(Option-Command-C)

Pastes callout properties into a callout action.

Video Filters
(Option-Command-V)

Pastes video filter properties into a clip.

Callout
(Option-Command-U)

Pastes audio filter properties into a clip.

Table 17. Edit Menu Items

Menu Item Description
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Table 18. Edit Menu Items (continued)

Menu Item Description

Paste and Match Style
(Option-Shift-
Command-V)

Adds text on the clipboard to your text box. Inserted text 
adopts the text formatting of the character immediately 
preceding the insertion point.

Note: You can paste properties to multiple clips 
simultaneously; however, If you copy multiple clips with 
different properties and paste adjustments to another clip, 
which properties will be pasted is not predictable.

Delete Permanently removes the selected items. If you have marked 
in and out points, the segment between the in and out point 
is deleted for all clips.

See Deleting Clips.

Ripple Delete
(Command-
Backspace or Delete)

Delete the elements (or portions of elements) between the in 
and out points on all tracks of the timeline and shift all clips 
left to close the gap on the timeline.

See Creating Timeline In and Out Points.

Select All
(Command-A)

Highlights all clips on the timeline.

Deselect All
(Shift-Command-A)

Deselects all clips on the timeline. This can also be done by 
clicking in an empty area of the canvas or timeline.

Close Gaps Removes all selected gaps between clips in the timeline.

Deselect All Unused 
Media

If any media are unused they are deselected. If all media are 
used “No Unused Media Found” is displayed.

Captions See Displaying and Previewing Closed Captions and Exporting 
Closed Captions as SRT Subtitles.

Set Current Language Specifies the language you want to display captions in.

Import from SRT Imports the closed caption text from a file

Export to SRT Exports the closed caption text in this project to a file.

Clear All Captions Removes caption text from all caption clips in this project.

Start Dictation Displays the macOS dictation system, so that you can add text 
to a text box clip using your voice.

Emoji & Symbols Displays the Characters window so that you can enter special 
characters in text fields.
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Mark Menu
The Mark menu contains the following commands:

Table 19. Mark Menu Items

Menu Item Description

Mark In Point
(I)

Sets the in point of a range on the timeline at the current 
point of the scrubber.

When you create an in point without an out point, 
ScreenFlow automatically sets the out point to the end of the 
last clip on the timeline, and highlights the range in blue. In 
and out points can be used to delete entire sections of your 
timeline using the Ripple Delete command.

Select the in point (click on the line directly over the timeline 
scale) and drag it right or left to adjust its point on the 
timeline.

Shift-click on the timeline scale to set in and out points 
relative to the position of the scrubber.

Mark Out Point
(O)

Sets the out point of a range on the timeline at the current 
point of the scrubber.

When you create an out point without an in point, 
ScreenFlow automatically sets the in point to the beginning 
of the timeline, and highlights the range in blue. In and out 
points can be used to delete entire sections of your timeline 
using the Ripple Delete command.

Select the out point (click on the line directly over the 
timeline scale) and drag it right or left to adjust its point on 
the timeline.

Shift-click on the timeline scale to set in and out points 
relative to the position of the scrubber.

Clear In & Out Points
(Option-Z)

Removes the in and out points you created previously.

Markers

Add

(back single quote 
mark, left of the “1” 
key)

Adds a marker to the timeline at the scrubber location.

If you export a ScreenFlow document as a QuickTime movie, 
chapter markers are placed at each named marker position in 
the movie when Add Chapter Track from Markers is checked.

See Adding a Timeline Marker.

Add To Clip Adds a marker to a clip and prompts you for a name.

See Adding a Clip Marker.
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See Adding a Timeline Marker and Adding a Clip Marker.

Clip Menu
The Clip menu contains the following commands:

Delete
(Shift-~)

Deletes the selected marker.

Delete All Deletes all markers on the timeline.

Go to Next
(Shift-Up Arrow)

Moves the scrubber to the next marker to the right on the 
timeline.

Go to Previous
(Shift-Down Arrow)

Moves the scrubber to the previous marker to the left on the 
timeline. You can also use the mouse to drag markers and 
adjust their position.

Go to See Navigating the Timeline with the Scrubber.

   Project Start Moves the scrubber to the start of the project timeline.

   Project End Moves the scrubber to the end of the project timeline.

   Previous Frame Moves the scrubber to the previous frame on the timeline.

   Next Frame Moves the scrubber to the next frame on the timeline.

Table 19. Mark Menu Items

Menu Item Description

Table 20. Clip Menu Items 

Menu Item Description

Split Clip
(Command-T | 
Command-Shift-T | T)

Converts each selected clip into two separate clips, splitting 
them at the current scrubber point, so that you can adjust the 
parts of the clip independently.

When splitting a clip, the previous clip name is retained on 
both clips. By default, each segment of a clip uses the name of 
the original media located in the Media Library.

These segments can be renamed for convenience and clarity.

Replace Media Navigate to and select new media. All settings from old media 
are maintained.

Detach Audio Removes the audio stream from the selected clip (visible as a 
green waveform through the center of the clip unless 
View > Show Audio Waveforms is unchecked), and creates a 
new audio clip at the same point on the timeline. 
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Extract Audio Select individual audio channel to extract. The extracted 
audio channel is placed into a new track.

Extract App Audio

Add Freeze Frame
(Shift-Command-F)

Inserts a freeze frame in the middle of a selected clip.

First, the clip is split at the scrubber, then a two second freeze 
frame is inserted between the clips. The duration of the freeze 
frame can be set by dragging the edge of the clip, much like 
any other still image clip. The second half of the clip is moved 
to the right to adjust for the added clip.

See Creating a Freeze Frame.

Note: Go to ScreenFlow > Settings > Timeline to change the 
default duration of freeze frames.

Trim Front to 
Scrubber
(W)

Trims the front of the selected clips from the start of the clip 
up to the scrubber position.

Alternatively, you can adjust the left side of the clip by 
clicking the mouse just near the left edge of the clip (the 
mouse pointer changes to the drag cursor [left] to indicate 
that you can resize the clip). Click and drag the edge of the 
clip to the right to trim the amount you want off of the front 
of the clip. This method is functionally equivalent to using the 
Trim Front to Scrubber command.

See Trimming a Clip in the Timeline.

Trim End to Scrubber
(E)

Trims the back of the selected clips from the end of the clip 
up to the scrubber mark.

Alternatively, you can adjust the right side of the clip by 
clicking the mouse just near the right edge of the clip (the 
mouse pointer changes to the drag cursor [left] to indicate 
that you can resize the clip). Click and drag the edge of the 
clip to the left to trim the amount you want off of the back of 
the clip. This method is functionally equivalent to using the 
Trim End to Scrubber command.

See Trimming a Clip in the Timeline.

Edit Speech Clip Displays the Speech Clip window.

See Insert Menu.

Reverse Clip Select to check and uncheck. When checked, media is played 
in reverse.

Table 20. Clip Menu Items 

Menu Item Description
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Insert Menu
The Insert menu contains the following commands:

Lock Clip | Unlock Clip
(Option-Command-L)

Locks selected clips to their positions on the timeline and 
cannot be moved. When clips are locked, you cannot move 
other clips onto them to make transitions. Select again to 
unlock selected clips you have previously locked.

Disable Disables the selected clip.

Nest Clips
(Option-Command-
N)

Nests selected clips into a group for treating the group as a 
whole when operating on them.

See Nested Clips for details.

Unnest Clips Unnests a previously nested clip.

See Nested Clips for details.

Group
(Command-G)

Ties selected clips together on the timeline, so that moving 
one clip moves all grouped clips. Ideal for synchronizing 
voice-overs, music beds, etc., to a camera clip so that their 
timing remains synchronized as you move them around in 
your project.

Ungroup
(Command-U)

Returns selected clips to be independent of other clips.

Proxy Enables you to create or delete a proxy.

Add Starting 
Transition | Remove 
Starting Transition
(Option-Command-,)

Adds a transition to the beginning of the selected clip(s). 
Apply again to remove the transition.

Add Ending 
Transition | Remove 
Ending Transition
(Option-Command-.)

Adds a transition to the ending of the selected clip(s). Apply 
again to remove the transition.

See Adding Transitions.

Add Starting & 
Ending Transitions | 
Remove Starting & 
Ending Transitions
(Option-Command-.)

Adds transitions to the beginning and ending of the selected 
clip(s). Apply again to remove the transitions.

See Adding Transitions.

Label Enables you to add and remove colored labels.

Table 20. Clip Menu Items 

Menu Item Description
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Actions Menu
Actions are time-based changes to clips used to create gradual temporal or temporary 
effects. Actions are applied mid-point, where the change takes place.

The Actions menu contains the following commands:

Table 21. Insert Menu Items

Menu Item Description

Text Box Inserts a text clip into the project at the current scrubber 
position. Text box duration is five seconds, but can be 
adjusted by dragging the edge of the clip on the timeline.

See Adding and Configuring a Text Clip.

Note: Go to ScreenFlow > Settings > Timeline to change the 
default duration of text boxes.

Title Opens a title selection window. Select a title and click on 
Select.

Annotations Clip
(Option-Command-T)

Inserts simple graphic effects to visual clips including 
recordings, videos, and image files. Annotation shapes 
include circle, square, line, and arrow.

Note: Go to ScreenFlow > Settings > Timeline to change the 
default duration of annotation clips.

Speech Clip... Displays a sheet where you enter text, select a voice, then 
click Insert to create an audio clip in your project by 
converting text to speech using one of six automated voice 
programs. Text can be typed directly into the field or pasted 
from another document.

Template Placeholder 
Clip

Inserts a placeholder where a clip from a Screen Recording 
and Computer Audio, Camera and Microphone, or IOS device 
will be inserted in a new document created using a template.

See Creating a Document Template.

Narration Inserts a narration from an audio device.

Choose...
(Shift-Command-V)

Imports media files into your project at the current playhead 
position. ScreenFlow displays the Open dialog, so that you 
can browse your file system or network server and select the 
media file to add to the project’s media library and timeline.
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Table 22. Actions Menu Items

Menu Item Description

Add Video Action
(Command-K)

Adds a Video Action to the selected clip at the location of the 
scrubber. A Video Action allows you to apply effects like 
Zoom, Pan, and Rotate to your video clip.

Add Audio Action Adds an Audio Action to the selected clip. An Audio Action 
allows you to apply various effects on the audio of the 
selected clip, such as ducking, or adjusting the volume.

Add Screen 
Recording Action
(Command-R)

Adds a Screen Recording Action to the selected screen 
recording clip. Screen Recording actions enable you to 
modify the size of the Mouse Pointer, add click effects, or 
show keys pressed, for example.

Add Callout
(Command-L)

Adds a Callout to the selected screen recording clip. A callout 
lets you focus attention on a section of your project. For 
example, you can highlight the mouse pointer by dimming 
everything but the area just around the mouse pointer or 
highlight and magnify the foreground window.

Add Touch Callout Provides a way to automatically receive “touch” events from 
the iOS device.

Add Snapback Action Let you add a Video, Audio, or Screen Recording action.

See Modifying Style with Style Presets.

Go to Next Action Within a clip, selects the next action.

Go to Previous Action Within a clip, selects the previous action.

Play Selected Action Plays the currently selected action.

Curve Type By default, actions are applied to the clip in a linear manner. 
For example, when applying a scaling action, the image size 
changes by equal amounts from start to finish. This may be 
perceived as too abrupt, so you can modify the rate with 
which an action is applied.

The Curve Type menu item has these submenu items:

Linear Linear transition.

Ease-In Starting slow, speeding up towards the end.

Ease-Out Starting fast, slowing down towards the end.

Ease-In & Out Starting and ending slowly, faster in the middle.

Exponential 
        Ease-In

Starting slow, speeding up exponentially towards the end.
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Font Menu
Font options apply only to text in text clips.

The Font menu contains the following commands:

Arrange Menu
Font options apply only to text in text clips.

The Arrange menu contains the following commands:

Exponential
        Ease-Out

Starting fast, slowing down exponentially towards the end.

Exponential
        Ease-In & Out

Starting and ending slowly, exponentially faster in the 
middle.

None Applies action immediately.

The duration of the action is ignored if this option is applied.

Table 22. Actions Menu Items

Menu Item Description

Table 23. Font Menu Items

Menu Item Description

Show Fonts
(Command-T)

Displays the System Font pane. Select a font to apply to 
highlighted text, or all text if none is selected.

Bold
(Command-B)

Makes the selected text bold.

Italic
(Command-I)

Makes the selected text italic.

Underline
(Shift-Command-U)

Underlines the selected text.

Bigger Increases the font size by one point.

Smaller Decreases the font size by one point.

Kern Select Text Kerning mode: Default, None, Tighten, Loosen.

Copy Style Copies the style of the selected text, except background.

Paste Style Applies the previously copied text style to the selected text.
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View Menu
View options determine how the media is presented both on the canvas and on the 
timeline.

These options only change how your project is displayed on the canvas—they do not 
alter the media.

The View menu contains the following commands:

Table 24. Arrange Menu Items

Menu Item Description

Align Enables you to align selected clips in six different ways: 
Left, Horizontally Center, Vertically Center, Right, Top, Bottom.
NOTE: If you select a single item (not multiple items), alignment 
is made along the edge of the canvas. Selecting multiple items 
aligns those items to the furthest edge of the grouping, instead 
of aligning to the canvas.

Scale Enables you to scale selected clips: Scale to Fit, Stretch, or 
Reset. These are the same controls located at the top of the 
Video tab of the Inspector window.

See Resizing or Scaling a Clip on the Canvas.

Distribute Evenly distributes display of selected clips.

Group Groups selected items into a single grouped item.

Ungroup Ungroups a selected grouped item into single items.

Lock Clip Locks/unlocks a selected clip so that it can’t be altered.

See Locking Clips.

Table 25. View Menu Items

Menu Item Description

Enter Full Screen
(Command-F)

Displays the editor window in full screen mode to reduce on-
screen clutter.

Zoom In
(Command-=)

Magnifies the display of the canvas.

See Editing on the Canvas.

Zoom Out
(Command--)

Reduces the display of the canvas.

See Editing on the Canvas.

Zoom to 100%
(Option-Command-0)

Displays the canvas area at its direct pixel size.
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Zoom to Fit
(Control-Command-
0)

When the canvas is obscured, adjusts the display size so that 
it is completely visible in the window.

Show Checkerboard Displays transparent portions of the background as 
checkerboard to distinguish them from opaque portions that 
are the same color as the background. To export video with 
an alpha channel, use the Lossless - ProRes with Alpha preset 
or a custom derivative (see Video Encoding).

Show Captions Displays closed caption text on the canvas.

See Displaying and Previewing Closed Captions.

Hide/Show Inspector Hides or shows the inspector panels.

Hide/Show Timeline Hides or shows the timeline.

Show/Hide Quick 
Media Library

Shows or hides the Quick Media Library.

Show Clip Editor Displays the Clip Editor where you can preview media files 
and perform quick edits.

See Trimming a Clip in the Timeline.

Zoom Timeline to Fit
(Control-T)

Scales the timeline downward to display it entirely in the 
window.

See Zooming In and Out on the Timeline.

Zoom Timeline In
(=)

Expands the timeline.

Zoom Timeline Out
(-)

Contracts the timeline.

Switch to Inspector
(Command 0 - 9)

Displays the selected Properties pane: Video, Audio, Screen 
Recording, Callout, Annotations, Text, and Media (library).

Select Focus Timeline to return keyboard events back to the 
timeline. For example, when you are editing a text box on the 
timeline, you can select Focus Timeline, then use shortcuts.

See The Properties Window and Removing a Filter Background.

Table 25. View Menu Items

Menu Item Description
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Window Menu
The Window menu contains the following commands:

Snapping
(Control-N)

Toggles snapping for both the canvas and timeline.

When snapping is on, the mouse snaps to various guide-lines. 
For example, on the canvas, the mouse snaps your objects to 
the center and edges of your canvas. It also snaps to other 
objects, if you have any. On the timeline, the mouse snaps to 
the beginnings and endings of actions and clips. Checked/On 
by default.

You can temporarily toggle snapping by holding down the 
Command key.

Scrub Live Audio
(Shift-S)

When activated, you can hear the audio track while dragging 
the scrubber. Checked/On by default.

Show Audio 
Waveforms

When activated, clips that contain audio have the audio 
waveform shown along the center of the clip. Checked/On by 
default.

Show Tab Bar Displays the tab bar on the timeline, pushing the timeline and 
all tracks down in the window, to accommodate it. When you 
create nested clips, each clip nest is identified by a tab.

Show Caption Track Displays the caption track on the timeline—the caption track 
is the highest track on the timeline.

Table 25. View Menu Items

Menu Item Description

Table 26. Window Menu Items

Menu Item Description

Minimize
(Command-M)

Minimizes the foreground window.

Zoom Scales the foreground window to the full size of the screen.

Tile window to left of 
screen

Locates tie window on left side of the screen.

Tile window to right 
of screen

Locates tie window on right side of the screen.

Detached timeline Places selected timeline into a detached window.

See Detaching Timelines.
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Select Previous Tab
(Shift-Command-[)

When the tab bar is visible in the timeline (as when editing 
nested clips), this navigates to the previous timeline tab.

Select Next Tab
(Shift-Command-])

Navigates to the next timeline tab.

Markers Opens a window listing the markers in the current document.

You can add, delete, and rename markers, and jump to 
markers in this window.

See Jumping to a Marker.

Table 26. Window Menu Items

Menu Item Description
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Table 27. Window Menu Items (continued)

Purchase Menu (Telestream Web Store Only)
Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

Use these Purchase menu commands for purchasing from the Telestream Web Store 
and activating your ScreenFlow license, as described in table Table 28.

Note: If your ScreenFlow license is already activated, this menu does not display.

The Purchase menu contains the following commands:

Menu Item Description

Minimize
(Command-M)

Minimizes the foreground window.

Zoom Scales the foreground window to the full size of the screen.

Tile window to left of 
screen

Locates tie window on left side of the screen.

Tile window to right 
of screen

Locates tie window on right side of the screen.

Detach timeline Places selected timeline into a detached window

Select Previous Tab
(Shift-Command-[)

When the tab bar is visible in the timeline (as when editing 
nested clips), this navigates to the previous timeline tab.

Select Next Tab
(Shift-Command-])

Navigates to the next timeline tab.

Markers Opens a window listing the markers in the current document.

You can add, delete, and rename markers, and jump to 
markers in this window.

Bring All to Front Puts all ScreenFlow windows in front of any other 
application's windows on the desktop.

<documents> List of all open document windows, listed sequentially in the 
order they were opened.
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Help Menu
The Help menu contains the following commands:

Editor Drop-Down Menu
The Editor menu contains the following commands:

Table 28. Purchase Menu Items

Menu Item Description

Purchase ScreenFlow 
Online

Displays the Telestream online Web store.

Unlock ScreenFlow Displays the Licenses tab of ScreenFlow Settings to enter a 
license. Requires admin authentication first. See Unlocking 
ScreenFlow via Telestream Web Store.

Table 29. Help Menu Items

Menu Item Description

Search Searches the User Guide (this document).

ScreenFlow Help Displays the ScreenFlow Help Landing Page, where you can 
access the ScreenFlow User Guide, watch tutorials of 
ScreenFlow topics, and access other helpful resources.

Visit ScreenFlow Web 
site

Displays the Web page for general ScreenFlow information.

Visit Support Page Displays the Web page for ScreenFlow support information.

Provide ScreenFlow 
Feedback

Goes to the ScreenFlow support Web page.

Table 30. Help Menu Items

Menu Item Description

Text Box When clicked, ScreenFlow creates a text box on the Canvas.

Title When clicked, ScreenFlow opens the Media Library.

Annotations Clip When clicked, ScreenFlow opens the Annotations tab.

Speech Clip... When clicked, ScreenFlow opens a dialog where you can 
enter text that ScreenFlow converts into speech.

http://www.telestream.net/screen-flow/overview.htm
http://www.telestream.net/telestream-support/screen-flow/support.htm
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See The Editor Window.

The Recording Monitor
The Recording Monitor provides a preview of your microphone and camera during a 
recording. With the Recording Monitor, you can check audio levels, keep the camera 
shot correct, and set the duration of the recording.

Note: When the Recording Monitor is visible, ScreenFlow includes the Recording 
Monitor in the screen recording. To prevent this, move the Recording Monitor window 
to an area of the screen that will be cropped out, or move it to another monitor.

The Recording Monitor tracks the selected inputs in the ScreenFlow recording 
configuration. If you have disabled both the camera and microphone, the Recording 
Monitor shrinks to a timer. During recording, the green striped header at the top of the 
recording monitor changes to red. When recording, ScreenFlow displays the timer text 
in white. When not recording ScreenFlow grays out both the timer and the Add Marker 
buttons.

Note: Only the microphone audio is monitored, not the entire audio of your 
recording.

The Media Library Context Menu
Control-click (right-click) on a clip in the media library to display the context menu.

See The Editor Window.

You can perform the tasks described in Table 31.

Template Placeholder 
Clip...

When clicked, ScreenFlow opens a dialog you can use to 
create a placeholder clip.

Narration... When clicked, ScreenFlow adds an audio recording button to 
the Editor controls, and opens a recording dialog.

Choose File... When clicked, ScreenFlow opens a file browse you can use to 
select a file for the Canvas.

Table 30. Help Menu Items

Menu Item Description
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Table 31. Media Library’s Media Menu

Menu Item Description

Add to Timeline at 
Scrubber

Select to add your media to the timeline at the current 
scrubber position.

Select Clips in 
Timeline

Select to select the clip or clips to show where this clip is 
being used on the timeline.

Delete Media Select to remove the SCC media files from your document. If a 
media file is on the timeline, ScreenFlow removes it, following 
a confirmation prompt. ScreenFlow does not delete media 
files not in SCC format.
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ScreenFlow Settings

You can set your options and customize ScreenFlow to suit your specific needs via 
ScreenFlow Settings.

Figure 1. Settings Dialog

Note: If you purchased ScreenFlow through the Mac App Store, ScreenFlow doesn’t 
display the Licenses tab. The Mac App Store has its own licensing and updating 
processes.

Topics
■ General Settings Tab

■ Timeline Settings Tab

■ Canvas Settings Tab

■ Shortcuts Settings Tab

■ Proxy Settings Tab

■ Advanced Settings Tab

■ Licenses Settings Tab

ScreenFlow 
doesn’t display 
these features if 
ScreenFlow 
was purchased 
from the Mac 
App Store
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General Settings Tab
The General Settings tab provides startup, display, recording, and auto-update options.

The General Settings controls are described in Table 1.

Timeline Settings Tab
Use the Timeline Settings tab to set timeline options.

The Timeline Settings controls are described in Table 2.

Table 1. General Settings Options

Control Description

Interface Theme Select Light or Dark. This affects how menus are displayed.

ScreenFlow uses the macOS settings for Light and Dark mode 
by default.

Settings Check the features to be enabled when using ScreenFlow:

   Show ScreenFlow Check to toggle the ScreenFlow Helper menu on and off in 
the status menu.

   Countdown Check to use the Countdown window, and set the countdown 
time (in seconds). Range: 0 - 10. Default: 5.

   Send Diagnostic Sends anonymous usage data to Telestream.

Startup Check to launch ScreenFlow Helper when you log in so that 
you can record without first launching ScreenFlow.

Auto Update Check to automatically check for updates each time you start 
ScreenFlow, so you can update ScreenFlow immediately.

Note: This option is not available if you purchased 
ScreenFlow from the Mac App Store. The App Store has its 
own update procedure.
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Table 2. Timeline Settings Options

Control Description

Editing When checked, the scrubber will be repositioned after a paste 
action.

Display

   Use SMPTE timecode Check to display the scale as SMPTE timecode 
(HH:MM:SS:FF—Hours:Minutes:Seconds:Frames). 
If unchecked, the scale displays the scale informally. For 
example: 1h2m30s.

   Hide Action Menu Check to hide the action gear menu in clips.

Double-click in Media 
Catalog

Choose between sending a clip to the clip editor (when 
double clicking), or sending it directly to the timeline.

Thumbnail Cache Enter size of the thumbnail cache (in megabytes). A value of 
zero means unlimited cache sizing. Once you have updated 
the maximum cache size, the cache is checked for cleanup.

While thumbnails are being generated, the cache is 
automatically cleaned up every three minutes, to ensure it 
does not run out of control. When thumbnail icons are 
removed due to the size of the cache, the oldest are deleted 
first.

The thumbnails are stored at:

   ~/Library/Caches/net.telestream.ScreenFlow9/Thumbnails

Default Transition Select the default effect to use when generating a transition. 
Default: Bars Swipe.

Default Track Height Select the default track height of timeline tracks: Small, 
Regular, or Large. If your project has many tracks, you can set 
this to Small to view more tracks in your window without 
scrolling. Default: Regular.

Default Action Curve Select the default Action Curve: Linear, Ease In or Out, 
Exponential Ease In or Out, or None.

Default Durations Select the duration field of the item you want to change. 
These are default time values for actions, transitions, still 
images, callouts, and annotations. Enter the value (in 
seconds) of the default length of the item when added to the 
timeline. Range: one-tenth of a second (typically 3 frames) up 
to (but not including) 30 seconds.
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Canvas Settings Tab
Use the Canvas Settings tab to set canvas options.

The Canvas Settings controls are described in Table 3.

Shortcuts Settings Tab
To speed up your workflow, you can start many ScreenFlow features with keyboard 
shortcut commands. Use the Shortcuts tab to create custom keyboard shortcuts.

For a complete list of ScreenFlow keyboard shortcuts that you can customize, see 
ScreenFlow keyboard shortcuts.

Also see Finding Keyboard Shortcuts, Changing Shortcut Keys, and Keyboard Short-
cuts and Hotkey Customizations.

The Shortcuts Settings controls are described in Table 4.

Table 3. Canvas Settings Options

Control Description

Lock Aspect Ratio Check to cause aspect ratio to be maintained when scaling 
using the mouse.

Show Z Rotation 
Controls

Check to display Z rotation controls.

Default Background 
Color

Click on the color square to open the default background 
color pallet.

Snap to other clips Check to cause new clips to snap to other clips.

Snap to edges Check to cause new clips to snap to edges.

Snap Line Color Click on the color square to open the snap line color pallet.

Table 4. Shortcuts Settings Options

Control Description

Keyboard Shortcut 
Set

Select Configure, Import, or Export. Configure opens a 
configuration window.

   Default Select this option to activate the default keyboard shortcuts.

   <Custom Shortcut> Select from a list of user created custom shortcuts.

   Configure Select to open the configuration window. Click the plus icon 
(+) to add a new custom shortcut set. Click the minus icon (-) 
to delete any selected set.

   Import Select to import a saved (exported) shortcut set.


https://www.telestream.net/pdfs/technical/screenflow-shortcuts.pdf

https://vimeo.com/227757577

https://vimeo.com/227757577
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See Changing Shortcut Keys and Keyboard Shortcuts and Hotkey Customizations.

Proxy Settings Tab
The Proxy tab provides ScreenFlow settings for proxy media. Proxies are lower quality 
media files that take the place of the originals during editing. When the final export is 
done, ScreenFlow renders from the original files (not from the proxy files) for the best 
quality output.

ScreenFlow indicates the progress of proxy creation with a pink progress bar on the 
Timeline and on the Timecode user interface. When the proxy file is created, 
ScreenFlow displays a solid pink circle.

The Proxy Settings options are described in Table 5.

Advanced Settings Tab
The Advanced Settings tab provides ScreenFlow settings for video magnification, 
compression, and managing your audio driver and scratch disk. The Advanced Settings 
options are described below.

   Export Select to export (save) a shortcut set.

Show Select All or Customized. All displays all shortcuts sets, 
whereas Customized display only the set created by the user.

Search Enter a word to use for searching in the list of shortcuts. The 
list is reduced, as matches are found, while your type.

Table 4. Shortcuts Settings Options

Control Description

Table 5. Proxy Settings Options

Preference Description

Proxy Creation Mode In Automatic mode, ScreenFlow will decide if the imported 
content would benefit from having a proxy created. 

In Always mode, when a media file that can have a proxy 
made is added to the Media Library or the Timeline, the proxy 
creation progress starts.

Options Check Limit size of proxy cache to, then enter the size in GBs.

Check Automatically delete proxy files after, then enter the 
number of days.

Check Create proxies at half original resolution (Optionally).

Proxy Cache Location Click Change to select a proxy cache location.


https://vimeo.com/227757577
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Table 6. Advanced Settings Options

Preference Description

Video Magnification Select Smooth or Sharp to set the compression algorithm for 
magnification. Smooth blurs color values and creates 
smoother edges. Sharp does not blur color values, but can 
result in jagged, pixelated edges. Default: Smooth.
This setting controls both how ScreenFlow displays inputs in 
the Preview window, and how ScreenFlow generates outputs.

Screen Recording 
Compression

Select Adaptive | Lossless to specify the method of 
compression used. Adaptive is compressed, which minimizes 
file size, but the loss in video quality is not noticeable to most 
users. Lossless is uncompressed which captures all pixels, 
thereby resulting in a larger file size. Default: Adaptive.

Computer Audio Click to install or uninstall the ScreenFlow audio driver, which 
is required for recording computer audio.

Note: If you purchased ScreenFlow through the App Store, 
the computer audio driver is installed automatically.

DAW Support Check Allow device to be Sound Output, or Disable Sound 
Output Monitoring, as desired.

Allow device to be 
sound output

Checking this option makes the Telestream Audio Capture 
device always available for output and configuration. This 
allows you to design an audio workflow while not actively 
recording. The Telestream Audio Capture device is normally 
hidden from the user to simplify the common usage patterns.
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Licenses Settings Tab
Note: If you purchased ScreenFlow through the Mac App Store, ScreenFlow doesn’t 
display the Licenses tab. The Mac App Store has its own licensing and updating 
processes.

The Licenses Settings options are described below.

Disable sound output 
monitoring

Checking this option turns off the sound output monitoring 
capabilities of ScreenFlow. This results in the following:

• When recording begins, ScreenFlow routes all output auto-
matically to the Telestream Audio Capture device.

• ScreenFlow records all audio routed to the Telestream Audio 
Capture device, but does not play the audio through the 
speakers. To monitor output, configure your audio work-
flow.

• ScreenFlow records only mixed output. The ScreenFlow per-
application recording option is not available.

Default File Format Select the file format in which you want to save your 
ScreenFlow documents by default. ScreenFlow displays this 
default format in the File Format menu in the Save As dialog 
box. (See The ScreenFlow Document Formats and Save As.)

Capture Scratch Disk Click Change to specify a directory where ScreenFlow can 
temporarily save media as it is being recorded. By default, this 
is set to a private system location: ~/Movies/ScreenFlow Data. 
Specifying a custom scratch disk allows you to locate your 
recording in the event that it was interrupted before 
completion.

Table 6. Advanced Settings Options

Preference Description
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Table 7. Licenses Settings Tab

Preference Description

Serial Number Editable field where you enter 
the serial number for your 
license.

Stock Media Library ScreenFlow displays the path to 
your stock media library.

Purchase When clicked, the Purchase 
button sends your purchase 
order to Telestream.

Activate When clicked after a serial 
number has been entered into 
the Serial Number field, 
Telestream activates your 
ScreenFlow license.
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Troubleshooting

You can troubleshoot common ScreenFlow issues. If your issue is not listed, or if the 
recommended procedure doesn’t work, please contact technical support.

How do I provide Customer Service with diagnostic information about an issue?
1. Press Shift and click the Help menu.

2. Select Gather Support Diagnostics > Gather.

3. ScreenFlow collects debugging logs, crash reports, a system profile, names of open 
documents, and a snapshot of the current state of ScreenFlow.

 ScreenFlow generates an archive of these files.

4. Save the archive to your desktop, and send it to Telestream Customer Service when 
requested.

How do I provide Mac App Store with diagnostic information about an issue?

Mac App Store users can gather support diagnostics for the Mac App Store with a 
software tool provided by Telestream.

See ScreenFlow: Gather Support Diagnostics / Reset ScreenFlow Preferences.

My exported video looks fuzzy or blurry. What can I do to make it look better?

Compression of video on output can reduce sharpness. Here are a few things you can 
do to retain as much sharpness as possible:

• On the Advanced tab of the Settings dialog, check the Sharp box for the Video Mag-
nification setting.

See Advanced Settings Tab.

• Export using the Lossless - Apple ProRes with Alpha uncompressed video format. If 
you don’t reduce the resolution, the output resolution matches the resolution of 
the input video, but results in a large output-file size. Generate uncompressed 
video if it requires additional editing before publishing.

• Before recording, reduce your Mac display resolution through the Mac System Pref-
erences for Displays. A lower display resolution requires less compression. Make 
your display resolution the same as, but not lower than, the desired output resolu-

http://www.telestream.net/telestream-support/screen-flow/support.htm

https://support.telestream.net/s/article/Gather-Support-Diagnostics-Reset-ScreenFlow-Preferences
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tion. If you set the display to a smaller resolution than the output resolution, the 
image loses clarity.

• If you don’t want to reduce your display resolution or export to a large, uncom-
pressed format, select Video Properties > Scale or Callout Action > Zoom. Scale and 
zoom functions allow you to increase the visibility of a specific portion of the 
recording. This helps maintain clarity in a heavily compressed video.

• Sharp, clear text is hard to produce in digital video. Thin lines can look blurry or jag-
ged. If you have small text in your screencast, consider applying the Scale feature or 
increasing the text size.

How do you designate a display recording area?

ScreenFlow can capture the entire display, or a specific recording area. You can make 
use of any display area during editing in post-production.

When using a program which designates a recording space, you may unexpectedly 
move outside of this space due to a menu option or pop-up. If your recording space is 
preset, there is no way to recover this lost information. With ScreenFlow, however, you 
can move outside your area of focus when necessary.

Does ScreenFlow work with Parallels or VMware?

Since ScreenFlow captures everything on your display, both Parallels and VMware are 
supported (including Computer Audio output). However, ScreenFlow can’t use the 
Callout features, as these are dependent on information provided by macOS.

Telestream has tested ScreenFlow with Parallels in all modes (Coherence, Window, and 
Full Screen) without issue. In fact, when using Parallels/VMware, some users have 
reported that ScreenFlow produces smoother, higher-quality output while using fewer 
CPU resources than native Windows screen-capture programs.

What kind of graphics card should I use?

ScreenFlow uses video RAM (or VRAM) during the recording process, so it is important 
to have a graphics card with at least 64 MB of VRAM, but we recommend 128 MB. The 
amount of VRAM necessary to record smooth video depends on your display resolution 
and whether or not other applications are simultaneously using VRAM. If you have 
insufficient VRAM, the recording will drop frames. As a result, video skips during 
playback.

Does ScreenFlow support closed captioning?

ScreenFlow does support closed captioning. For details, see Displaying and Previewing 
Closed Captions.

How do I use ScreenFlow to record my iPhone/iPad?

ScreenFlow can capture directly from the screen of an iOS device over a USB 
connection. For details, see Touch Callout Properties.
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My USB microphone and iSight camera are out of sync. What should I do?

There can be a latency problem between the computer USB input and the iSight 
camera. If audio and video are out of sync, try using an analog mic instead of a digital 
one. Plug the analog mic into the analog audio jack on the computer.

I can’t find my media files. Where is the media library?

Once the first media file has been recorded or the first file has been imported into 
ScreenFlow, each document in ScreenFlow has a media library. To open the media 
library, see Viewing the Media Library.
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