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 Installation
Introduction
This topic guides you through installing (or upgrading) and activating Wirecast.

Topics
 Installing

 Activating

 Uninstalling

 System Requirements

Installing
To install Wirecast, follow these steps:

1. Download the installer from the Website at:  http://www.telestream.net/wirecast/
overview.htm

2. Run the installer (.exe) program and follow the instructions provided

Note: During installation, you will be asked if you want to install the Virtual 
Microphone feature. If you do (recommended), check the displayed check box and 
continue the installation. Installing Virtual Microphone requires administrative rights.

3. If you have an older version of Wirecast already installed on your computer, the 
installer upgrades to the newer version. Agree to the license terms and follow the 
instructions displayed by the installer program.

http://www.telestream.net/wire-cast/overview.htm
http://www.telestream.net/wire-cast/overview.htm
http://www.telestream.net/wire-cast/overview.htm
http://www.telestream.net/wire-cast/overview.htm
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Activating
When you purchased Wirecast a serial number was provided. This serial number must 
be registered in the Wirecast program to unlock the features of Wirecast. To register 
Wirecast follow these steps:

1. Run the Wirecast program.

2. Select Preferences from the File menu, select Licenses, then click Buy. Once you 
purchase and obtain your license number, enter it into the Serial Number field and 
click Activate.

   

3. Close the Preferences window.

Your Wirecast program should now be fully activated.

Uninstalling
To uninstall Wirecast, follow these steps:

1. Run the Wirecast installer (.exe) program. 

2. The installer asks if you want to repair or remove the existing version. Select 
Remove to uninstall the existing version of Wirecast.

System Requirements
Wirecast 

• Operating Systems: Windows 7 SP1 64-bit, Windows 8.1 64-bit, Windows 10 64-bit.
(Wirecast does not support Windows XP or Windows 8 32-bit)

• Minimum Dual-core CPU required, 2.3 GHz 32-bit or 64-bit

• 2.8GHz or higher recommended for 720p or higher streaming

• 2GB RAM minimum

Select Licenses

Click Activate

Click Buy

Enter serial 
number
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• 4GB RAM and 64-bit OS recommended for 720p or higher streaming

• 200MB free hard disk space for installation

• Hard disk space for recording to disk

• 512 MB PCI-Express graphics card with 3D acceleration

• GeForce or Radeon class card recommended

• Sufficient upload speed for streaming

• Minimum recommended is twice the bandwidth of the total bit rate of the stream 

Note: You are strongly advised to run Wirecast using the Windows Areo Theme, 
which includes a hardware accelerated window manager. Problems may result if you 
use the Windows Classic Theme.

Desktop Presenter

• Use the remote version of Desktop Presenter 2.0.6 with Wirecast; it's available as a 
separate download at:   http://dynamic.telestream.net/downloads/download-
desktop-presenter.asp?prodid=desktoppresenter.

Internet Connectivity

• Requires internet connectivity with HTTP/HTTPS port 80, and RTMP port 1935 open 
for streaming, Remote Desktop Presenter requires opening port 7272.

• An internet connection is recommended for Wirecast license activation.

• For lowest quality (240p) streaming an upload rate of at least 650Kbps is required.

• 720p streaming requires an upload rate of at least 2500 Kbps.

• 1080p streaming requires an upload rate of at least 4500 Kbps.

• Wirecast Cam requires iOS 8 or later.

• Consider lowering your canvas frame rate and/or streaming resolution to lower 
CPU usage.

• It is recommended that an upload rate of at least double the desired rate be avail-
able.

• Solid State Drive or fast RAID array recommended for ISO Recording and Replay 
functionality. Actual data rates will vary depending on quality level selected for 
MJPEG recording, as well as the resolution and frame rate selected.

• Windows MJPEG Best Quality Guidelines (Megabytes per second):

– 1080i and 1080p 29.97 and 30 FPS, MJPEG Best Quality – ~25MB/sec

– 1080p 60 FPS, MJPEG Best Quality – ~50 MB/sec

– 720p 59.94 and 60 FPS, MJPEG Best Quality – ~20 MB/sec

Recommended Hardware Specifications

• Intel Core i3 CPU @ 1.7 Ghz or higher recommended for 540p streaming with x264 
@ 30 fps.

http://dynamic.telestream.net/downloads/download-desktop-presenter.asp?prodid=desktoppresenter
http://dynamic.telestream.net/downloads/download-desktop-presenter.asp?prodid=desktoppresenter
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• Intel Core i5 CPU @ 2.5 Ghz or higher recommended for 720p streaming with x264 
@ 30 fps.

• Intel Core i7 CPU @ 3.0Ghz or higher recommended for 1080p streaming with x264 
@ 30fps. 

• Note: 60 FPS streaming will result in increased CPU usage and a high bit rate 
(4Mbps or higher) for good quality.

• Intel HD, NVIDIA GeForce, or AMD Radeon class graphics adapter that are both 
DirectX 9 and DirectX 10 capable.

• Minimum 4GB RAM, 2GB free hard disk space. Additional hard disk space required 
for recording to disk. 

Hardware Accelerated Encoding Requirements

• Intel Quick Sync Video encoding requires an Intel CPU with an Intel® QuickSync 
Video core. List of Intel CPUs supporting QuickSync.

• NVIDIA NVENC encoding requires an nvidia GPU with Kepler architecture or newer. 
NVIDIA only maintains a general list of supported GPUs.

• Apple Hardware Accelerated H.264 encoding requires a Mac with an integrated 
Intel GPU.
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Tutorials
Introduction
The best way to get started using Wirecast is to quickly work through all its main 
features. This tour presents a series of three tutorials, each designed to help you 
understand how to create and broadcast presentations using Wirecast. 

As you work through these tutorials, you will also become familiar with important 
Wirecast concepts and how you can use them to deliver high quality broadcasts. The 
more you know about Wirecast, the better it will serve your broadcasting objectives.

Because each tutorial builds on the skills and knowledge you learn in the previous 
tutorials, it is recommended that you take the tutorials in succession. Working through 
all the tutorials takes about thirty minutes.

As you gain hands-on experience creating video and audio presentations - which leads 
to a working knowledge of Wirecast and its components and architecture - you will 
gain proficiency in using Wirecast.

Tutorials
 Tutorial 1: Basic Concepts

 Tutorial 2: Editing Shots

 Tutorial 3: Broadcasting

Note: You can run all of the tutorials without a license. However, a watermark on the 
video and an occasional voice-over on the audio are present until a valid license is 
activated. 

Note: For licensing information, select Preferences from the File menu, select License, 
then click Buy. Or, you can contact Telestream at: desktopsales@telestream.net.
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Tutorial 1: Basic Concepts
The goal of this tutorial is to provide you with a quick but successful experience 
creating and broadcasting a presentation using Wirecast. 

This tutorial requires that you open the tutorial document in Wirecast. To do this, select 
Create Document for Tutorial from the Help menu in Wirecast. 

Note: If you are running the tutorial with Wirecast in demonstration mode, the 
Wirecast logo appears from time to time and audio output has a periodic voice-over.

Tutorial Prep
To prepare for this tutorial you need to make two changes.

First, select Switch >Auto Live to turn on the Auto Live option. But also select Layout > 
Show Live Only to turn off the Preview option. Both of these options will be changed 
back later in the tutorial. 
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The Wirecast Main Window shows the AutoLive LED as turned on.

The Main Window
Wirecast has two main display areas: Live Broadcast and Shot List. The Live Broadcast 
area is in the upper portion of the window displaying what Wirecast broadcasts to your 
viewers (or what it records to disk). The Shot List, in the lower half of the window, 
displays the shots available for broadcast.

What Is a Shot?
Wirecast uses the concept of a shot to construct presentations. A shot contains media, 
along with the settings for that media. In its simplest form, a shot contains one piece of 
media such as a photo or a video clip. But it can also be something more complex, like a 
live camera with a title, and background music, or even a Playlist of shots.

AutoLive LED on

Live Broadcast Area

Shot List
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A shot can be edited and its settings can be changed (See Tutorial 2: Editing Shots). 
Shots are important because they enable you to configure a lot of information before 
you broadcast your presentation. This enables you to concentrate on creating a good 
production during your broadcast. 

Switching Between Shots
Individual shots are displayed in the Shot List. Click the Ripples shot in the Shot List area 
and the image fades into the Live Broadcast Area display. This is called “taking a shot 
live”. 

Shot in Live Broadcast Area

Click Ripples
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Click the shot labeled Clear Layer and the Ripples image fades to a blank screen. The 
Clear Layer shot enables you to display nothing, which is sometimes needed. 

Transitions
In the previous examples, a fade occurred when you clicked on a shot. This is because a 
smooth transition is the default. 

Note: The Windows version of Wirecast does not support a true Dissolve transition. 
The Smooth transition is the closest choice for dissolve. The main difference is that 
when Smooth is used in transitions that involve position or size changes in the images, 
the smooth transition migrates from one image to the other rather than dissolving out 
of one and into the other. 

If you are transitioning from an A to A shot (another shot that also contains A - such as 
a picture in picture, or AB side-by-side shot) then Smooth will interpolate the 
difference between A's position and size and will smoothly animate the changes, 
making A bigger or smaller and moving it on screen as needed. However, if you are 
transitioning from an A to B shot, then Smooth will act like a traditional Dissolve and 
fade between the to images.

Transition controls are located just below the Live Broadcast Area where two kinds of 
transitions are shown: Cut and Smooth.

Blank screen in Live Broadcast Area

Click Clear Layer
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When Cut is selected, transitions are immediate. When Smooth is selected, transitions 
fade in (as demonstrated above).

There are more than just two kinds of transitions to choose from, but only two can be 
assigned to the Transition Panel. To select a different transition type, click the small 
arrow on the right side of either transition button. When the list appears, select a new 
transition to assign to the button. You can also click the transition button and drag the 
mouse downward until the menu of selections is displayed.

For example, to change the first transition button from Cut to Swoop, click the Cut 
button and drag downward until the menu appears. select Swoop from the menu. 
Swoop should now be selected for the first button. 

Now click back and forth between River and Ripples using Swoop.

These two transition buttons can also be selected by using the following key 
combinations: Ctrl+1 and Ctrl+2. 

Transition Speed 
You can also control how fast a transition occurs, by selecting the Switch >Transition 
Speed. Your choices range from Slowest to Fastest.

Click arrow to open menu

Select a 
transition type
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Go Button 
The Go Button (or Ctrl+G) enables you to make a transition.

Clicking the Go button does nothing when Wirecast is in AutoLive mode. The only 
exception is that it will update a live shot if you have made changes to it using the Shot 
Editor. Later in this tutorial you will discover how to use the Go button to transition 
between different shots when AutoLive is off.

Layers 

Note: Before you start this section, please select Smooth as your transition.

Wirecast enables you display several shots in the Preview and Live windows at the same 
time by rendering them one on top of another according to Wirecast's Layer system. 
This is an excellent way to add and remove objects in your broadcast. 

Wirecast displays five layers in the Main Shot List window. They are numbered 1 
through 5 along the right side of the window. Each layer contains shots that can be 
selected by clicking it. A red LED light indicates that a shot is selected. When a shot is 
selected it is displayed in the Live Broadcast window. If you select multiple shots (by 
selecting a shot on more than one layer) they will all be displayed in the Live Broadcast 
window. The shots are displayed in a layering manner, where layer 1 is on top and layer 
5 is at the bottom (and layers 2 through 4 are layered in between). 

Select the Logo shot in layer 2 and the River shot in layer 3. The result is a layered shot 
containing both images.

Go button

Layer numbersSelect River 
shot

Layered shot 

Select Logo 
shot
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Layers are displayed in a particular order: Layer 1 is on top, Layer 2 below it, Layer 3 
below Layer 2, etc. This tutorial, so far, has been operating on Layer 3. Clear Layer, 
Ripples, River shots (and more) are on Layer 3, but Layer 2 has only a logo and a Clear 
Layer shot.

    

Each layer can be turned on or off by clicking the white LED light on the far right side of 
the layer window. Click the Layer 2 LED to remove the Logo shot. 

Click the LED again to turn Layer 2 back on.

Auto Live 
So far in this Tutorial, Wirecast has been running in AutoLive mode. What this means is 
that any change you make in the Shot List is automatically made live in your Broadcast. 

Click to turn Layer 2 off

Logo removed
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This mode is very useful for those users who want to set up all of their shots at once and 
then single-click them as they run their presentation. But the disadvantage of this 
single-click method is that you can only see one shot change at a time. Once you click a 
shot, your viewers also see it (with no preview of how it looks on your part). 

Turn AutoLive Off 
An LED light, next to the Go button is lit when you are in AutoLive mode.

Make sure AutoLive is off by unchecking AutoLive in the Switch menu. A dialog box is 
shown informing you that AutoLive is off and transitions must be made using the Go 
button. Click OK in the dialog box to continue. 

Try clicking the Ripples and River shots. Nothing happens because AutoLive is off. Now 
click the Ripples shot and click the Go Button. The Ripples shot is taken live in the Live 
Broadcast window. Click the River shot and, as expected, nothing happens. Click the Go 
button again and the River shot becomes Live. 

Note: When AutoLive is off, you must always click the Go button (or press the Ctrl+G 
keys) to display the selected shot in the Live Broadcast Area. 

AutoLive LED



Tutorials
Tutorial 1: Basic Concepts

16
Multiple Changes
The benefit of having AutoLive off is that you can make several changes first and then 
have them occur all at the same time. To do this, first verify that AutoLive is off. Click 
Sample Title in layer 1, click Clear Layer Shot in Layer 2, and click the Ripples Shot in Layer 
3. Click the Go button (or Ctrl+G) to make the Ripples and Sample Title shots live at the 
same time.

Preview 
One problem you may have noticed while running this tutorial is that you cannot see 
the changes you are making before broadcasting them. To solve this problem, Wirecast 
enables you to see a preview of what you broadcast. 

Select Sample 
Title

Select Ripples
Layered shotsClick Go button

Select Clear 
Layer shot
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Select Layout > Show Live and Preview from the Layout menu. A preview window is 
displayed to the left of the Live Broadcast window. 

Click the River shot on Layer 3. The River shot is displayed in the Preview window. The 
Preview windows uses a green LED light to identify it. The Live Broadcast window uses 
a red LED. When shots are selected they display a green or red LED to indicate selection 
for preview or live broadcast.

    

Preview window

River shot

Live window

Red LED’s

Green LED
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Click the Go button to make the River shot live. Click the Clear Layer shot in Layer 1 to 
remove the title from the ripples shot. 

Note: Taking a shot live will set the Master volume slider to the value of the Preview 
volume slider.

Click Clear Layer Shot Click Go button
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Click the Go button again to make the Ripples Shot live, then click the River shot to select it. Notice that 
the Ripples and River shots LED’s have change color because the Preview and Live windows exchanged 
images. This lets you know what your last live window looked like as you prepare your next shot in the 
Preview window. 

Tutorial 2: Editing Shots
The first tutorial used only the Main window, and explained various ways in which you 
can use an existing shot. But shots can also be created and edited. This tutorial 
demonstrates how to edit your shots.

Shot LED’s changed color

Click Go button again

Select River shot
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To edit a shot, click it to select it, then click the double-arrow on the left to open the 
shot editor panel. You can also double-click the shot to open the shot editor.

The shot editor has six tabs: Shot Layers, Shot Layer Properties, Audio Properties, 
Chroma Key Properties, Build-in/Build-out Properties, and Additional Properties.

      

Click double-
arrow

Select a shot

Shot Layers tab

Build-in/Build-out Properties tab

Chroma Key Properties tab

Additional Properties tab

Shot Layer Properties tab

Audio Properties tab
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Shot Properties Enables you to add and delete sources and to change the display 
order (layering within the shot).

Shot Layer Properties Enables you to change the size, position, and other properties 
of a shot source. The sources in a shot are selected for editing by clicking it, or by 
selecting it in the Shot Properties tab.

Audio Properties Enables you to set and monitor audio level.

Chroma Key Properties If a source in your shot uses a chroma key, this tab enables you 
to configure the chroma key settings. Each source in a shot can have its own chroma 
key settings.

Build-in/Build-out Properties Enables you to control how objects are added to and 
removed from your broadcast.

Additional Properties Enables you to set any additional properties for a source in your 
shot: System device properties, screen display properties, Twitch Widgets (Chat and 
Followers), etc.

Tutorial 3: Broadcasting
This tutorial demonstrates how to setup and broadcast your Wirecast presentations. 
You can broadcast to a specific computer (Unicast), multiple viewers (Multicast), or 
even record your broadcast to disk.

There are two main components for broadcasting your presentation (or saving it to 
disk): Encoding and Destination.

You need to decide how you are going to encode the broadcast. Encoding is the type of 
compression used (JPEG, MPEG4, etc.). Wirecast comes configured with many common 
encoding options.  (see The Encoder Presets Window)

A destination for the broadcast must be selected. You can send it to a server for 
broadcast or save it to disk.

Streaming
You can stream your broadcast to any streaming service provider you choose. The 
Broadcast section of this user guide provides details on how to do this for many 
popular providers. This tutorial will show how to stream to Bambuser.

To stream to Bambuser (as an example), follow these steps:

1. Select Output > Output Settings.

2. Select Bambuser from the Destination menu.

3. Select an encoder. 

4. Enter your Bambuser username.

5. After you have entered your username, click Authenticate to enter your password 
and generate the RTMP URL. You only need to do this one time because Wirecast 
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stores the channel information for future streams. The default RTMP port is 1935. 
You may need to configure your firewall to enable connections on this port.

Note: If you do not have a username and password, you can sign up with Bambuser 
by clicking the Bambuser icon or by clicking Sign Up.

6. Select your Bambuser channel.

7. Optionally, enter a Stream Delay value. This provides a time buffer between your 
live stream from Wirecast and the actual broadcast itself. You can set the delay from 
0 to 999 seconds. However, greater delays require greater memory use. The amount 
of memory used is displayed when you enter the amount of delay.

8. Click OK. 

    

You can stream your broadcast to your service provider. To do this, click the Stream 
button  at the top  of the Main window. You can also record your streaming by clicking 
the Record button .

    

Select an encoder 

Select Bambuser

Click Authenticate 
and enter 
password

Select Channel

Enter user name

Click Stream Click Record
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If you have not already selected a destination and logged into it, a dialog box displays. 
Select a destination, log in when asked to do so, then click OK. 

        

The Stream icon will blink until a connection is made. Once you are connected the 
Stream icon turns green. If you cannot connect an error message will display. 

        

Connection strength is indicated by how many bars are displayed in the Stream icon. 
Fewer bars indicates a weaker (slower) connection.

        

If the connection is ever broken, a no connection icon is displayed in place of the bars.

        

When the connection is recovered, the no connection icon is replaced with the green 
bars.

Click Stream again to stop streaming. You can also record your broadcast by clicking 
Record. When you stop streaming, if your event is still live, you will be asked if you want 
to complete the event. 

        

Select Destination

Click OK

Green Stream icon

Green connection 
strength bars

No connection icon
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